locked
MSI install programs fail to add icons to start menu RRS feed

  • Question

  • Consider this bacgkround.  I renamed the thread to better reflect the true problem.  Easy Transfer has nothing to do with it.  I've got a Windows Installer problem.  See  update below.

    I just used the Windows 7 Easy Transfer utility to pack my stuff (unselected some items) from my Vista Ultimate (x64) machine (actually the same machine).  I saved off the easy transfer file to my D: drive then installed a new SSD as my drive C: and did a clean install of Windows 7 Ultimate x64 onto that drive.  I ran Windows Update, installed Office 2007 + SP2 + Win Updates, and a few other programs and then I ran the Windows Easy Transfer utility to install my file.  It ran fine and seemed to mostly work.

    I noticed, however, after I installed several programs (several including Audible Manager, Camtasia Studio, and Windows Home Server Connector) that they were not appearing on the Start Menu.  Oddly, the folder for the software (Windows Home Server, for example) shows up fine but then clicking it shows (empty) as opposed to the installed program.  I checked and the programs really do exist and they do run if I go find them and run them manually. 

    After some digging I found out that the .lnk files in the folders have messed up security/permissions.  Some show as "the owner cannot be displayed" (peroperties | security) and others are avialable only to the administrator account (I'm logged in as Tony).  The really odd thing is that these programs were not "transferred" by Easy Transfer at all.  I installed them fresh - they're just hosed.  If I manually take ownership of the .lnk files, they appear in the Start Menu just fine.  The behavior is reproducible.  I've installed and uninstalled the WHS Connector software several times in trying to figure this out.  It installs and runs but the Start Menu is toast.

    It seems there must be something going on with transferring my account information from Vista to Win 7.  I didn't do anything crazy with the account mapping option in Easy Transfer.  The only account on the new PC (Tony) was selected as the account to copy things to (from account Tony on Vista).  The only "odd" thing I've done is to move the My Documents folder for Tony from C: to D: (so it's not on my SSD) - which I did using the "Move" option in Windows.  (oddly, I moved it to "D:\Tonys Documents" and that's what shows for the folder but, in reality, the folder on the drive D: is really named "My Documents")

    On a potentially related note, I get spurious warnings about "The recycle bin on drive x is corrupt.  Do you want to empty..?"  This occurs on various drives.  Web search shows people manually deleting the $Recycle.bin folder to address this but as far as I know this could also be a permissions issue. 

    Any ideas here?  I'd hate to have to reformat and re-install yet again since I have installed most of my software at this point... and since I no longer trust Easy Transfer I'd have to manually reconfigure Outlook, certificates, favorites, documents,.... you know :-)

    Tony
    • Edited by Tony B Tuesday, February 2, 2010 7:08 AM
    Thursday, January 28, 2010 6:02 AM

Answers

  • Not sure what exactly was incorrect about my previous drive config but moving drives between SATA controllers and doing a bit of shuffling sure seems to have solved the problems.  I've got more stuff installed now that I had on either of the previous two runs and things are running smoothly. 

    I did post a question on TweakTown (Gigabyte's tech support forum) asking about their RAID controller but have not received a reply.

    So, I'm chalking it up to a lose cable and moving on :-)
    • Marked as answer by Tony B Saturday, February 6, 2010 4:06 AM
    Saturday, February 6, 2010 4:06 AM

All replies


  • Hi Tony,

    I suggest you try to fix current issues one by one.

    As you may know, Windows Easy Transfer cannot transfer program files, only program settings. Actually, I just use it transfer my Account data and Windows settings.
    http://windows.microsoft.com/en-us/windows7/Transferring-files-and-settings-frequently-asked-questions

    Since Windows 7 is a great move from Vista, I just reinstall my programs instead of transfer them in order to avoid any potential issues.

    Regarding the Start Menu shortcut permission issue, I’m not sure if it was caused by Easy Transfer. If you would like to run a test, you can:
    1. Setup a new account, do you have the shortcut permission issue in the new account?
    2. If there is no problem, pls use Easy Transfer to transfer your account and Windows settings (only) to this new account, do you still have this issue now?

    Friday, January 29, 2010 12:37 PM
  • Update:

    Ok, so I reformatted my drive and reinstalled Win7 and decided to snap resotre points as I went along (and I did NOT use Easy Trasnfer at all -- just setting up a new system).  I thought things were going well with the new install until tonight when I realized that I cannot install any .msi (that I've tried) without it failing to put the .lnk on the Start Menu.  Again, the installs worked fine and the programs run but the .lnk files do not get put on the Start Menu.

    What I think I've found is that msiexec (windows installer - I have v 5.0.7600.16385 installed) is trying to install the programs for All Users.  This is actually what I want but it doesn't work.  If I create a shortcut to the .msi and put ALLUSERS="" as a param, it will run and properly add icons to the Start Menu.  So... definitely a permissions issue with the UAC/Non-Admin admin :-)   I don't want to install for just me, however.

    Examples of the .msi's that fail are the Cisco VPN AnyConnect Client and CamtasiaStudio 5.1. 

    No clue what triggered these to start failing or if, in fact, they'd never work even if they were the first things installed.  I'd rather not reinstall again to test that theory.  I can successfully run setup.exe installers and they put the icons on the start menu even with this system in this state that prevents .msi's from working.

    Any thoguths on what to try?  I did try to run msiexec /i myapp.msi from an elevated command prompt and that still fails. 

    Other technical info that might be relevant (but I hope not :-)):
    Only other thing to note is that I am getting random "Recycle bin on drive C:\ is corrupt.  Do you want to empty..." messages (I see posts from others getting the same thing).  I did manually remove all the $Recycle.bin folders from all my drives.  No help, they still appear.  As far as drives go, I've got an Intel 160G X-25M SSD as my C:\ drive.  I also have two Velociraptors in RAID 0 as a data drive - not really used yet but I know their existence can affect Win 7 (ex: install hangs unless RAID drivers are installed even though I'm not installing the OS on that volume).  Core i7 965 (not overclocked) w/ 12Gb RAM.  I manually set the pagefile.sys to be 800Mb-1Gb.  Also disabled hibernate so no 12Gb hiberfile.sys ends up on my SSD. 

    Tuesday, February 2, 2010 7:04 AM
  • Hi,

    First of all, I suggest you check disk first. Computer> right click main drive>> properties>>tools>>check now.

    Since the issue is related to Windows Installer file, you can check the installer log file for detailed information.
    ===========================
    1. Click Start, input cmd, right click the cmd.exe icon under “Program” and click “Run as Administrator”
    2. Copy the following command line into the Open box:
    REG ADD HKLM\SOFTWARE\Policies\Microsoft\Windows\Installer /v Logging /t REG_SZ /d voicewarmup /f
    3. Press Enter to run this command.
    4. Restart the computer.
    5. Click Start, click Run, type "%temp%" (without quotation marks) and press Enter.
    6. Delete all the files in this folder.
    7. Try to install the MSI program
    7. If it fails, click Start, click Run, type "%temp%" (without quotation marks) and press Enter.
    8. Please check the new "MSIXXXX.log" files to find detailed error.

    You can also upload the log file to Skydrive (public folder) so others can check it.

    Meanwhile, regarding the Recycle bin message, I’m not sure if you are use command “ rd /s /q C:\$Recycle.bin“ and repeat it for any other hard drive letter that you have. You can consider open another threads once this MSI issue fixed.

    • Edited by Gordon 7 Tuesday, February 2, 2010 8:40 AM
    Tuesday, February 2, 2010 7:43 AM
  • There are no disk errors/problems and "sfc /scannow" reports no integrity violations.

    The log file only has something interesting in it for the Cisco install (which reports it as an error).  The other installs think they were successful.  They end up creating a folder in the Programs directory and the folder, in fact, contains the .lnk files.  The problem is that the folder itself has messed up permissions.  If I right click a newly installed folder (like "Cisco", for example) and select "Open", I get a dialog telling me I dont' have permission for that directory.   If I go to explorer and take ownership of the directory and files that were added to the Programs directory, then the .lnks show up and all is well.  For some reason, the .msi is creating directories using some bad credentials).

    FYI: I see the following in the log file when I tried to install the Cisco VPN Client:

    Warning 1909. Could not create Shortcut Cisco AnyConnect VPN Client.lnk. Verify that the destination folder exists and that you can access it.
    === Logging stopped: 2/2/2010  0:54:26 ===

    Tuesday, February 2, 2010 8:04 AM
  • Hi,

    Do you have those programs installed to their default folder (e.g C:\Program Files\Program name)? There is an old KB article which may helpful for this type of issue (http://support.microsoft.com/kb/217648/), even if it’s not for Windows 7, but the symptoms are same.

    Meanwhile, I would like to know if the folder (with corrupted permission) is the all user folder or the account folder for yourself.
    All User folder: C:\ProgramData\Microsoft\Windows\Start Menu\Programs\
    Your account folder: C:\Users\AccountName\AppData\Microsoft\Windows\Start Menu\Programs\

    Additional, can you let me know the original permission and the current permission to those folder? (did you add Full Control permission to everyone or your account?) do you still have any MSI shortcut issues after taking ownership of this folder?

    Your findings would be helpful for other users who may encountered this type of issue.

    Wednesday, February 3, 2010 8:29 AM
  • Wow, that's an old MSDN post :-)

    Still, you're right in that I did get that error from the VPN Client install.  The others, however, simply failed silently.

    As far as permissions on the items: there were none.  Looking at them in the Security tab displayed something along the lines of "No permissions have been assigned to this object.  This could be a security risk.... etc. etc.".

    In any case, since there were clearly problems with permission on the drives (which could explain the corrupted recycle bins as well), I decided to bite the bullet and re-install (yet again).  However, not wanting to end up in the same spot, I took at look at my drives/config and did some re-arranging.  I'm running an i7 965 on a Gigabyte EX58-UD5 mobo w/ 12GB RAM and ATI HD4870X2 graphics.  I was using the Gigabyte RAID controller for a 600GB RAID 0 volume (2x WD Velociraptors) and was using an Intel X25-M SSD as the main OS drive.  I also have two other data drives (1TB and 500GB) and two optical drives.

    So, I decided to move my main OS drive (the SSD) to position 0 on the Intel ICH10 controller (it was on channel 1) and also move the RAID 0 array to channel 1on the Intel controller which I switched to RAID mode.  I removed the data drives to get Windows 7 x64 installed.  I also did NOT load any Intel ICH10 RAID drivers (or Gigabyte drivers) during install since I believe Win 7 should have those out of the box (and it did since all is up and running).

    Can't say I found anything "illegal" with my older setup.  The only odd thing was that I had a lone drive on the second Gigabyte RAID channel.  The drive was not part of a RAID array at all but the BIOS makes it look like it's in RAID 0 with itself :-).  It showed up and ran fine both in BIOS and Windows so I don't think it was a problem but Gigabyte's RAID software doesn't make it obvious if it was a problem.  Intel's is nice - clearly indicates which drives are part of a RAID array and which aren't -- even though they're all connected to the RAID controller.

    I'm currently re-installing programs, keeping a log, and occassionally storing an image of the boot drive.  So far, so good.  I have yet to install Office 2007 though (and all the Windows Update items that it's going to bring with it).  I also have yet to hook up my data drives (to the Gigabyte controller) or activate Windows (which I did immediately the first couple times).

    I'll post back if I run into issues but no problems with Recycle bins or permissions so far...

    Thursday, February 4, 2010 6:22 AM
  • Nice going, pls post it if there is any update.
    • Marked as answer by Tony B Saturday, February 6, 2010 4:03 AM
    • Unmarked as answer by Tony B Saturday, February 6, 2010 4:04 AM
    Friday, February 5, 2010 1:11 AM
  • Not sure what exactly was incorrect about my previous drive config but moving drives between SATA controllers and doing a bit of shuffling sure seems to have solved the problems.  I've got more stuff installed now that I had on either of the previous two runs and things are running smoothly. 

    I did post a question on TweakTown (Gigabyte's tech support forum) asking about their RAID controller but have not received a reply.

    So, I'm chalking it up to a lose cable and moving on :-)
    • Marked as answer by Tony B Saturday, February 6, 2010 4:06 AM
    Saturday, February 6, 2010 4:06 AM
  • I know this is an old thread but I have had the same thing happen to me twice. In both instances it immediately followed installing audible manager. I would love to know how to fix this without reformatting - any ideas?
    Wednesday, February 29, 2012 11:59 AM