locked
regarding column deletion in content type RRS feed

  • Question

  • hi ,

    I am using share point 2007 (out-of-box) .

    I have a site content type with 3 columns (title, month, year) . this content type was used in some lists , but data doesn't exists for any of the lists .

    1) I have created 1 more column "year1".

    2) i have deleted(remove button click) the column "year".

    while updating the column "year1" (updating its name from "year1" to "year") I am getting fallowing error "the column name that you entered is already in use or reserved. choose another name"

    please suggest the solutions ...

    Thanks and Regards

    Prashanth

     



    Friday, March 25, 2011 8:10 AM

Answers

  • Hello Prashanth,

    This problem is in this KB

    http://support.microsoft.com/kb/923589

     

    Please use the steps as suggested.

     

    Thanks,

    Ashok Yadala

    • Marked as answer by Peng Lei Thursday, March 31, 2011 7:28 AM
    Friday, March 25, 2011 9:10 AM

All replies

  • Hi Prashant,

    I think you might have modified the columns in the default content type. And regarding the error, it occurs only if there exists some data in that list that is using that content type. So please delete that data and then update that content type if you wish to.

    And you also specified that "data doesn't exists for any of the lists"....so where is the data going? It has to go somewhere right!!

    My suggestion is use a new content type instead of modifying the existing one so that you won't get that error and then you can verify the results.


    Thanks & Regards, Chandra Shekhar Rameneni
    Friday, March 25, 2011 8:52 AM
  • Hello Prashanth,

    This problem is in this KB

    http://support.microsoft.com/kb/923589

     

    Please use the steps as suggested.

     

    Thanks,

    Ashok Yadala

    • Marked as answer by Peng Lei Thursday, March 31, 2011 7:28 AM
    Friday, March 25, 2011 9:10 AM