none
Disable export to Excel and Powerpoint? RRS feed

  • Question

  • Hi - I'm doing preliminary research for a project with the requirement that users can not print, copy & paste, or export reporting data including Performance Point scorecards & dashboards.

    I've seen a number of topics about how to get the export functions to work, but my question is the opposite - how do I turn off export functionality for all users?

    Appreciate the help.
    Nathan Andersen
    Thursday, January 22, 2009 5:47 PM

Answers

  • Hello Nathan,

    What did you attempt in your dev environment? The below steps will disable the export to excel.

    There is a modification that you can make to the web.config file to disable 'Export to Excel' and 'Export to PowerPoint'.

    Open up IIS, expand websites and PPSMonitoring. Right click on the Preview folder and choose Explore. Open up the web.config file in that folder. Find these entries:

    <add key="ExportToExcelEnabledControls" value="SqlReport,Scorecard,OLAPGrid,OLAPChart" />
    <add key="ExportToPowerPointEnabledControls" value="Scorecard,OLAPGrid,OLAPChart" />

    The value for these entries controls which report types are enabled to export. If you remove the OLAP values then that remove Analytic Grids and Charts. Setting value equal to nothing like this value="" turns off exporting to all report types.

    The above example is for the Preview site. If this needs to be done for a SharePoint site, then these changes will need to be done on the SharePoint web.config file where PPS has been installed.

    Thanks,
    Jon Thomas


    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Marked as answer by AseemN Monday, February 16, 2009 8:47 PM
    Tuesday, February 3, 2009 5:12 PM
    Moderator

All replies

  • Hi Nathan,

    I am not sure about this but This can be i guess done using the Site setting.

    You have to to edit your SiteSetting-->Permissions-->then you will have different levels of permissions

    like Full Control, Design, Read,View Only

    I think you have to do something from Share point level only

    Let me know if that is the case and if you get succeed.

    Thanks


    D
    Saturday, January 24, 2009 6:52 AM
  • Thanks Dibyant, I'll give that a shot when our demo environment is up.
    Nathan Andersen
    Thursday, January 29, 2009 2:34 PM
  • Hi Nathan,

    this is the link where it has been discussed ,please have a look

    http://social.technet.microsoft.com/Forums/en-US/ppsmonitoringandanalytics/thread/7232bc82-502d-4a75-86e4-e93c8599fe17

    Thanks


    Dibyant S U padhyay
    Friday, January 30, 2009 1:56 AM
  • Thanks for the link.  I'll take a look tomorrow.

    Just for the record, the Sharepoint permission levels appeared to have no influence on the PPM web part.  Once the web part is on a page, and a user has access to the page, they can use the PPM web part (assuming no audience filtering is being used).  No change in functionality based on Sharepoint permission levels.
    Nathan Andersen
    Monday, February 2, 2009 11:43 PM
  • I just tested this out in my dev environment and it did not work.  Export is still functional.


    Nathan Andersen
    Tuesday, February 3, 2009 4:49 PM
  • Hello Nathan,

    What did you attempt in your dev environment? The below steps will disable the export to excel.

    There is a modification that you can make to the web.config file to disable 'Export to Excel' and 'Export to PowerPoint'.

    Open up IIS, expand websites and PPSMonitoring. Right click on the Preview folder and choose Explore. Open up the web.config file in that folder. Find these entries:

    <add key="ExportToExcelEnabledControls" value="SqlReport,Scorecard,OLAPGrid,OLAPChart" />
    <add key="ExportToPowerPointEnabledControls" value="Scorecard,OLAPGrid,OLAPChart" />

    The value for these entries controls which report types are enabled to export. If you remove the OLAP values then that remove Analytic Grids and Charts. Setting value equal to nothing like this value="" turns off exporting to all report types.

    The above example is for the Preview site. If this needs to be done for a SharePoint site, then these changes will need to be done on the SharePoint web.config file where PPS has been installed.

    Thanks,
    Jon Thomas


    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Marked as answer by AseemN Monday, February 16, 2009 8:47 PM
    Tuesday, February 3, 2009 5:12 PM
    Moderator
  • What you just posted is exactly what I attempted.  It did not work.  I edited the web.config files in both the PPS sites and SharePoint and tested - no good.  I edited the web.config files just in the SharePoint site & tested - no good.

    I edited the keys in the web.config files to the following:

    <add key="ExportToExcelEnabledControls" value="" />
    <add key="ExportToPowerPointEnabledControls" value="" />

    I have tried setting the value to "False", "none", " ", "0", tested, all no good.  I have tried just removing one of the values, or all but one value, no good.

    After every different attempt to correctly change the web.config file I restarted the sites, cleared my browser cache, and launched a new browser session.  Export functionality was intact every single time, except when I removed the keys entirely, which broke the web part entirely.

    There must be something else.

     


    Nathan Andersen
    Tuesday, February 3, 2009 5:33 PM
  • Hello Nathan,

    Thats interesting that these changes did not work for you. I know for a fact that these steps do disable the Export to Excel option because I have done it myself numerous times. It sounds like you have done all the correct steps on this as well so we must be missing something.

    What are the steps that you go through to see the Export to Excel functionality? Each report within a Dashboard, both in the Preview Site and SharePoint, has a drop down arrow in the upper right hand side that shows the export options. Is this where you are seeing the functionality? Also does your SharePoint environment have multiple Web Front End servers? If so this web.config change will need to be made on all of them to ensure the export is disabled.

    Thanks,
    Jon Thomas
    This posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, February 3, 2009 7:27 PM
    Moderator
  • I am curious as to how do you disable the standard Windows "Print Screen" function?
    My Ramblings @ http://alanwhitehouse.wordpress.com
    Tuesday, February 3, 2009 9:20 PM
  • Good question Jon, sounds like we do have different methods.  Here's how I export:

    We have just one test scorecard up right now.  On a cell, I right click & the 'Show Details' button appears.  I click Show Details, then a new window opens up.  In the upper left of that window, I see 'Export to Excel' - which has remained both visible and functional as I change the web.config file.

    Oh and I should say we only have one WFE in this environment.

    Alan, strangely enough I do know a way to do that, but I'd prefer if you started a new topic & then I can answer you there.
    Nathan Andersen
    Tuesday, February 3, 2009 10:09 PM
  • Hello all please I urgently need your help!!! I wana disable export to excel and export to power point on my dashboards in sharepoint!!

    Where can i find the sharepoint.config file in order to try what you mentioned above.

    Please i need it very urgently! 

    Monday, February 10, 2014 2:01 PM
  • Hello all please I urgently need your help!!! I wana disable export to excel and export to power point on my dashboards in sharepoint!!

    Where can i find the sharepoint.config file in order to try what you mentioned above.

    Please i need it very urgently! 

    THIS IS VERY URGENT
    Monday, February 10, 2014 2:04 PM
  • Hello all please I urgently need your help!!! I wana disable export to excel and export to power point on my dashboards in sharepoint!!

    Where can i find the sharepoint.config file in order to try what you mentioned above.

    Please i need it very urgently! 

    Monday, February 10, 2014 3:54 PM