locked
Only internal Mail Problem to public Folder - '550 5.7.13 STOREDRV.AuthenticationRequiredForPublicFolder RRS feed

  • Question

  • Error Message:

    '550 5.7.13 STOREDRV.AuthenticationRequiredForPublicFolder; Anonymous users are not permitted to add contents to mail enabled public folder

    External Mails to Public folder: ok

    Internal Mails to public folder fails.

    env:

    2x Exchange 2016 DAG


    following steps, was not helping:

    Remove-PublicFolderClientPermission -Identity "Pfad\zum\Ordner" -User Anonymous Add-PublicFolderClientPermission -Identity "Pfad\zum\Ordner" -User Anonymous -AccessRights CreateItems

    Remove-PublicFolderClientPermission -Identity "Pfad\zum\Ordner" -UserDefault Add-PublicFolderClientPermission -Identity "Pfad\zum\Ordner" -User Default -AccessRights CreateItems

    [PS] C:\Windows\system32>Get-MailPublicFolder info | fl name, require*,reject*,accept*


    Name                                   : info@xxxxx.com
    RequireSenderAuthenticationEnabled     : False
    RejectMessagesFrom                     : {}
    RejectMessagesFromDLMembers            : {}
    RejectMessagesFromSendersOrMembers     : {}
    AcceptMessagesOnlyFrom                 : {}
    AcceptMessagesOnlyFromDLMembers        : {}
    AcceptMessagesOnlyFromSendersOrMembers : {}

    all public Mailbox affected.


    Any ideas?

    best regards

    Chris


    • Edited by Chris---84 Friday, July 3, 2020 6:50 AM added Informations
    Friday, July 3, 2020 6:49 AM

All replies

  • After i changed the right to:

    Add-PublicFolderClientPermission -identity "\Folder\Mails\info@xxx.com" -User Anonymous -AccessRights CreateItems,EditOwnedItems

    It is working, but why? 

    best regards

    Chris

    Friday, July 3, 2020 8:54 AM
  • Hi Chris,

    Do you mean the problem solved after you added "EditOwnedItems" for Anonymous users?

    Could you run the following command to check the permission now:

    Get-PublicfolderClientPermission "\PFolder1"

    Actually "CreateItems" permission should be enough to send mails to PF.

    Please try to remove the permission and assign "CreateItems" again, re-enable the PF and restart the Information Store service. Run the following command to manually replicate the permissions to public folder mailbox assigned on the user and see if it's working now:

    Update-PublicFolderMailbox pfmailboxname -InvokeSynchronizer

    Besides, what kind of messages are you trying to send? "EditOwnedItems" is used to edit the owned items in PF, it shouldn't work in this scenario.

    Regards, 

    Eric Yin


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Monday, July 6, 2020 6:11 AM
  • Hi,

    I'm here to confirm with you if your issue has been resolved. If the problem is successfully solved, you can share your solution and mark them or the helpful reply as answer, this will make answer searching in the forum easier and be beneficial to other community members as well.

    Regards,

    Eric Yin


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Monday, July 13, 2020 1:42 AM