locked
service offering error in SCSM 2012 sp1. RRS feed

  • Question

  • Hi all,

           I have created a Runbook using orchestrator to add a user to an Active directory group,and integration pack for service manager has been deployed to the orchestrator server machine.

    I have created a Service Request template and added the Runbook Activity Template to this service request template. Created  a Request offering and pointed it to the SR template.

    But when I opened the self service portal in a browser and entered the required information like UserName & Group Name. The request was submitted successfully from the self service portal. But the user was not added to the group. In service manager the status initially was "In Progress" and after some time got the error as below:-

    Please help me with yours suggestions.

    Thanks,

    Monday, March 18, 2013 8:29 AM

Answers

  • If an activity in the runbook is not working like in your runbook the runbook at all is not working and you get an error message in the service request action log.

    You have to fix the problem in the runbook and it should work.

    The Group Name is a property of the service request (user Input in service request) you mapped to a field in the SR?

    If so, the name of the group should be available in the "Get Service Request" activity. The "Get Group Relationship" should not be needed.


    Andreas Baumgarten | H&D International Group

    Tuesday, March 19, 2013 5:44 AM

All replies

  • What happens if you manually start the runbook in the Orchestrator Runbook Tester? It runs without any Problem? You could also check the status of the runbook in Runbook Designer. 

    Andreas Baumgarten | H&D International Group

    Tuesday, March 19, 2013 12:53 AM
  • Thanks Andeas for your breezy response. When I manually start the runbook in the Orchestrator runbook tester i got the following error.

    But when i request for the service using self service portal it shows "In Progress" Status.



    Tuesday, March 19, 2013 4:02 AM
  • If an activity in the runbook is not working like in your runbook the runbook at all is not working and you get an error message in the service request action log.

    You have to fix the problem in the runbook and it should work.

    The Group Name is a property of the service request (user Input in service request) you mapped to a field in the SR?

    If so, the name of the group should be available in the "Get Service Request" activity. The "Get Group Relationship" should not be needed.


    Andreas Baumgarten | H&D International Group

    Tuesday, March 19, 2013 5:44 AM