none
Unable to set SAPWD in 2008 Express Silent Install RRS feed

  • Question

  • Hello! I am trying to create an install package that includes a silent install of SQL Server 2008 Express, no service packs.

    I'm installing it with Mixed Mode Authentication and setting the SAPWD, but then I am unable to login to the sa account using that password. Then, when I login with the Windows account and manually change the SA password to what I specified in the /SAPWD to begin with, I can then login just fine. So my question is, why isn't SAPWD working correctly in my silent install?


    My configuration file:

    ;SQLSERVER2008 Configuration File
    [SQLSERVER2008]
    
    ; Specify the Instance ID for the SQL Server features you have specified. SQL Server directory structure, registry structure, and service names will reflect the instance ID of the SQL Server instance. 
    
    INSTANCEID="GroupdotLive"
    
    ; Specifies a Setup work flow, like INSTALL, UNINSTALL, or UPGRADE. This is a required parameter. 
    
    ACTION="Install"
    
    ; Specifies features to install, uninstall, or upgrade. The list of top-level features include SQL, AS, RS, IS, and Tools. The SQL feature will install the database engine, replication, and full-text. The Tools feature will install Management Tools, Books online, Business Intelligence Development Studio, and other shared components. 
    
    FEATURES=SQLENGINE,REPLICATION
    
    ; Displays the command line parameters usage 
    
    HELP="False"
    
    ; Specifies that Setup should install into WOW64. This command line argument is not supported on an IA64 or a 32-bit system.
    
    X86="False"
    
    ; Specify if errors can be reported to Microsoft to improve future SQL Server releases. Specify 1 or True to enable and 0 or False to disable this feature. 
    
    ERRORREPORTING="False"
    
    ; Specify the root installation directory for native shared components. 
    
    INSTALLSHAREDDIR="c:\Program Files\Microsoft SQL Server"
    
    ; Specify the installation directory. 
    
    INSTANCEDIR="C:\Program Files\Microsoft SQL Server"
    
    ; Specify that SQL Server feature usage data can be collected and sent to Microsoft. Specify 1 or True to enable and 0 or False to disable this feature. 
    
    SQMREPORTING="False"
    
    ; Specify a default or named instance. MSSQLSERVER is the default instance for non-Express editions and SQLExpress for Express editions. This parameter is required when installing the SQL Server Database Engine (SQL), Analysis Services (AS), or Reporting Services (RS). 
    
    INSTANCENAME="GROUPDOTLIVE"
    
    ; Auto-start service after installation.  
    
    AGTSVCSTARTUPTYPE="Manual"
    
    ; Startup type for Integration Services. 
    
    ISSVCSTARTUPTYPE="Automatic"
    
    ; Account for Integration Services: Domain\User or system account. 
    
    ISSVCACCOUNT="NT AUTHORITY\NetworkService"
    
    ; Controls the service startup type setting after the service has been created. 
    
    ASSVCSTARTUPTYPE="Automatic"
    
    ; The collation to be used by Analysis Services. 
    
    ASCOLLATION="Latin1_General_CI_AS"
    
    ; The location for the Analysis Services data files. 
    
    ASDATADIR="Data"
    
    ; The location for the Analysis Services log files. 
    
    ASLOGDIR="Log"
    
    ; The location for the Analysis Services backup files. 
    
    ASBACKUPDIR="Backup"
    
    ; The location for the Analysis Services temporary files. 
    
    ASTEMPDIR="Temp"
    
    ; The location for the Analysis Services configuration files. 
    
    ASCONFIGDIR="Config"
    
    ; Specifies whether or not the MSOLAP provider is allowed to run in process. 
    
    ASPROVIDERMSOLAP="1"
    
    ; Startup type for the SQL Server service. 
    
    SQLSVCSTARTUPTYPE="Automatic"
    
    ; Level to enable FILESTREAM feature at (0, 1, 2 or 3). 
    
    FILESTREAMLEVEL="0"
    
    ; Set to "1" to enable RANU for SQL Server Express. 
    
    ENABLERANU="True"
    
    ; Specifies a Windows collation or an SQL collation to use for the Database Engine. 
    
    SQLCOLLATION="SQL_Latin1_General_CP1_CI_AS"
    
    ; Account for SQL Server service: Domain\User or system account. 
    
    SQLSVCACCOUNT="NT AUTHORITY\SYSTEM"
    
    ; Windows account(s) to provision as SQL Server system administrators. 
    
    SQLSYSADMINACCOUNTS="Administrator"
    
    ; The default is Windows Authentication. Use "SQL" for Mixed Mode Authentication. 
    
    SECURITYMODE="SQL"
    
    ; Provision current user as a Database Engine system administrator for SQL Server 2008 Express. 
    
    ADDCURRENTUSERASSQLADMIN="False"
    
    ; Specify 0 to disable or 1 to enable the TCP/IP protocol. 
    
    TCPENABLED="0"
    
    ; Specify 0 to disable or 1 to enable the Named Pipes protocol. 
    
    NPENABLED="0"
    
    ; Startup type for Browser Service. 
    
    BROWSERSVCSTARTUPTYPE="Automatic"
    
    ; Specifies how the startup mode of the report server NT service.  When 
    ; Manual - Service startup is manual mode (default).
    ; Automatic - Service startup is automatic mode.
    ; Disabled - Service is disabled 
    
    RSSVCSTARTUPTYPE="Automatic"
    
    ; Specifies which mode report server is installed in.  
    ; Default value: “FilesOnly”  
    
    RSINSTALLMODE="FilesOnlyMode"
    
    SAPWD=”mypassword”

    ^ That last line is the one that doesn't seem to be working.

    My command line instruction:

    #CABPATH\settingupsql\setup.exe /qs /ConfigurationFile=#CABPATH\settingupsql\ConfigurationFile.ini

    (Note, the CABPATH is something defined with DotNetInstaller. The silent install is able to find the setup.exe and ConfigurationFile.ini just fine.)

    Steps I have taken:

    Checked the local and domain password policy settings on the computer to ensure there is no minimum password length or password complexity required.

    Changed the SAPWD manually after the install and verified that login does work with the specified password.

    I would really appreciate any help in this matter. This is my first installer and bootstrapper, I've been wrestling with it for at least a week, and I think this is my very last problem...



    • Edited by dawsofty Friday, April 20, 2012 3:56 PM
    Friday, April 20, 2012 3:53 PM

Answers

  • I just noticed that the quotation marks around "mypassword" are those weird ones that result from copy-pasting sometimes and seems to elude parsers. I'm going to replace them with the normal quotation marks and see if it works

    ======================

    This was the problem. Everything works now.

    • Marked as answer by dawsofty Friday, April 20, 2012 4:35 PM
    • Edited by dawsofty Friday, April 20, 2012 4:35 PM
    Friday, April 20, 2012 3:57 PM