locked
Unable to connect to store, Cortana and edge browser and store apps though i have connected to wired broadband network. RRS feed

  • Question

  • I just upgraded to windows 10 and I'm unable to use Microsoft Edge it says 

    Hmm, we can't reach this page.

    Try this

    Make sure you’ve got the right URL: https://www.bing.com

    Refresh the page

    Search for what you want

    and I cannot open the Windows 10 store it keeps saying The Server Stumbled We all have bad days refresh the page Error 0x80072EFD.

    But, I am able to connect to internet through Chrome and Internet explorer.

    I am able to connect to internet through edge able to use cortana and connect to store etc., if I connect my LAN cable directly to the system by disconnecting the router.

    How can I fix this?

    Tuesday, August 4, 2015 5:19 PM

Answers

  • Hi,

    Did you mean all is working fine under Wireless network?

    If so, I suggest you update your wired network card driver to check the result. Recently Microsoft pushed some Windows update, please check and install them.

    Also check if you set any proxy, disable it.

    Settings -> Network & Internet -> Proxy

    Meanwhile, navigate your File Explorer to the following directory:

    C:\Users<Insert Username>\AppData\Local\Packages\Microsoft.WindowsStore_8wekyb3d8bbwe\

    Once here, delete the Local Cache folder and try launching the Windows Store again.

    In addition, make sure your region and locale setting correct.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Friday, August 7, 2015 7:43 AM
  • Thanks for your reply but, I have made a clean install and everything is working great.
    • Marked as answer by Karen Hu Sunday, August 9, 2015 2:08 AM
    Friday, August 7, 2015 5:54 PM

All replies

  • Hi,

    Did you mean all is working fine under Wireless network?

    If so, I suggest you update your wired network card driver to check the result. Recently Microsoft pushed some Windows update, please check and install them.

    Also check if you set any proxy, disable it.

    Settings -> Network & Internet -> Proxy

    Meanwhile, navigate your File Explorer to the following directory:

    C:\Users<Insert Username>\AppData\Local\Packages\Microsoft.WindowsStore_8wekyb3d8bbwe\

    Once here, delete the Local Cache folder and try launching the Windows Store again.

    In addition, make sure your region and locale setting correct.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Friday, August 7, 2015 7:43 AM
  • Thanks for your reply but, I have made a clean install and everything is working great.
    • Marked as answer by Karen Hu Sunday, August 9, 2015 2:08 AM
    Friday, August 7, 2015 5:54 PM
  • I have the same issue.  IE11 works (which is what I am using right now), Windows Update works, but MS Edge, Cortana, Store, etc. do not work.  I am hardwired only (no wifi) and do not connect via a proxy.  I've tried a full clean install and this still is happening.  Hoping someone has a solution for this!
    Monday, August 10, 2015 8:02 PM
  • I have the same issue.  IE11 works (which is what I am using right now), Windows Update works, but MS Edge, Cortana, Store, etc. do not work.  I am hardwired only (no wifi) and do not connect via a proxy.  I've tried a full clean install and this still is happening.  Hoping someone has a solution for this!

    You Could create a new thread that focus on your won issue.

    Or tell us what's the exact error message when you attempt to launch these apps?

    You also could turn off the firewall to check the if it block these apps.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Thursday, August 13, 2015 11:43 AM