locked
Vista 64 - Insert a disk - Wont Read Disk RRS feed

  • Question

  • I have recently installed Vista 64bit and then SP1.  Everything was working fine until I installed sp1. From a command prompt and Windows Explorer I cannot read a disk: DVD or CD.  Trying to read the disk from explorer and the command prompt do not even cause the drive to spin up.  The drive works to boot from.  Also from the Computer Management->Disk Management will cause the drive to spin up, and it shows the size of the disk.

    When I had Vista 32bit installed the drive worked just fine.

    Any ideas?
    Monday, February 2, 2009 6:46 PM

Answers

  •  

     

    Hi,

     

    Thank you for your post.

     

    Based on my research, I would like to suggest the following:

     

    Note: Please perform a full system backup first.

     

    1.    Click Start, type regedit in the Start Search box, and then click regedit in the Programs list.

    If you are prompted for an administrator password or confirmation, type your password, or click Continue.

    2.    Locate, and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}

     

    There can be many instances of the registry subkey that is mentioned in step 2. You must make sure that you are in the appropriate registry subkey before modifying the UpperFilters and the LowerFilters values. To verify that you are in the appropriate registry subkey, make sure that the Default data value is DVD/CD-ROM and the Class data value is CDROM.

     

    3.    In the right pane, right-click UpperFilters, and then click Delete.

    4.    Click Yes to confirm the removal of the UpperFilters registry entry.

    5.    In the right pane, right-click LowerFilters, and then click Delete.

    6.    Click Yes to confirm the removal of the LowerFilters registry entry.

    7.    Exit Registry Editor, restart the computer and check if it works then.

     

    Since the issue is related to the hardware, it is also recommend that you contact the manufacture of your DVD drive for technical support.

     

    Hope this helps.

     

    Thanks.


    Nicholas Li - MSFT
    Wednesday, February 4, 2009 9:43 AM
    Moderator

All replies

  •  

     

    Hi,

     

    Thank you for your post.

     

    Based on my research, I would like to suggest the following:

     

    Note: Please perform a full system backup first.

     

    1.    Click Start, type regedit in the Start Search box, and then click regedit in the Programs list.

    If you are prompted for an administrator password or confirmation, type your password, or click Continue.

    2.    Locate, and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}

     

    There can be many instances of the registry subkey that is mentioned in step 2. You must make sure that you are in the appropriate registry subkey before modifying the UpperFilters and the LowerFilters values. To verify that you are in the appropriate registry subkey, make sure that the Default data value is DVD/CD-ROM and the Class data value is CDROM.

     

    3.    In the right pane, right-click UpperFilters, and then click Delete.

    4.    Click Yes to confirm the removal of the UpperFilters registry entry.

    5.    In the right pane, right-click LowerFilters, and then click Delete.

    6.    Click Yes to confirm the removal of the LowerFilters registry entry.

    7.    Exit Registry Editor, restart the computer and check if it works then.

     

    Since the issue is related to the hardware, it is also recommend that you contact the manufacture of your DVD drive for technical support.

     

    Hope this helps.

     

    Thanks.


    Nicholas Li - MSFT
    Wednesday, February 4, 2009 9:43 AM
    Moderator
  • This was not the answer.  :-(  I saw that KB article, I did not have those values in the key, there where no filters defined.  I ended up blowing away the OS and starting over.  So far so good this time.
    Friday, February 6, 2009 1:41 PM