none
Creating a multi-OS USB pendrive in MDT RRS feed

  • Question

  • Hi Community,

    For a customer we need to create a rather unique boot device for offline installation and we're having unexplainable errors.

    Goal:
    To provide  bootable USB pendrive with pre-configured Windows 10 x64 uefi and Windows 7 x86 bios operating systems.

    Environment:
    Server 2016 build: 14393.2368
    MDT build: 6.3.8450.1000
    W10 X64 build: 16299.192 (1709) UEFI
    W7 SP1 x86 BIOS

    Situation:
    We've set the settings.xml file to split the .wim image files to fit on a fat32 drive, and if we build a USB pendrive for either one OS this goes as designed.

    The issue:
    If we create the multi-OS USB pendrive, MDT stops at different places;
    - Cannot find the x86 image
    - File already exist (with no further explanation)
    - Cannot find the x64 image

    We looked at the working directories for MDT and saw that the %appdata%\temp directory is used sometimes and causes the 'file already exist' error, but we cannot explain why MDT is splitting the wim image in the same directory as the deploymentshare\Operating Systems folder (and sometimes removing the original wim file.

    What are we missing or did we stumble across a bug in MDT?

    We are in the position to support both solutions (if possible on one device)

    Thanks in advance!

    Friday, September 21, 2018 12:40 PM

All replies

  • Hello,

    Please try to Update The Deployment Share by navigating to the Deployment Workbench> Deployment Shares> right-click your deployment share and choose to Update Deployment Share. This will ensure all of your media content is copied over to be able to create the ISO as needed.

    Hope this solution will work for you!

    Saturday, September 22, 2018 4:53 PM
  • Hi Jitesh,

    Thank you for your reply. I've updated the workbench before trying to update the media. I did found an interesting find: If "SkipWimSplit" is false (so the software will split the files into FAT32 compatible file sizes) the command fails. If the"SkipWimSplit" is true, the export goes successfully.

    Monday, September 24, 2018 8:06 AM
  • That means Image is Splitted into assigned format.. Have you tried to initiate the same process with New Image? Before Updating the Media I will Suggest you SignOut form account then Re Login to complete the process. 
    Tuesday, September 25, 2018 4:51 PM
  • I've tried this with multiple images, but the strange thing is that the split command sometimes removes the original file, and sometimes not, sometimes fails because the large .wim file is missing and the .swm file is present. Sometimes i need to clear my users TMP folder because the 'file' is already present...
    Monday, October 8, 2018 9:13 AM