none
MDT 2013 Unable to Install .NET Framework 3.5 for Windows 8.1 Enterprise RRS feed

  • Question

  • I'm just starting to create a reference image of Windows 8.1. I'm adding .NET Framework 3.5 in the Task Sequence as a role and it's failing to install. The bdd.log shows

    About to execute command: cmd.exe /c C:\windows\system32\DISM.exe /Online /Enable-Feature /FeatureName:"NetFx3" /Source:"C:\MININT\sources\X64" /LimitAccess /All /NoRestart /logpath:C:\MININT\SMSOSD\OSDLOGS\ZTIOSRole_Dism.log >> C:\MININT\SMSOSD\OSDLOGS\ZTIOSRole_DismConsole.log

    ERROR - NetFx3 role processing with DISM.exe failed, rc = -2146498529

    The ZTIOSRole_DismConsole.log shows

    Enabling feature(s)
    Error: 0x800f081f
    The source files could not be found.

    The ZTIOSRole_Dism has the same errors as well, basically that it cannot find the source. I can see the c:\minnt\sources\x64 folder on the machine. Is there another step to ensure MDT 2013 properly tells the machine it has the files there?


    Orange County District Attorney

    Friday, September 26, 2014 9:26 PM

Answers

  • if you use the install roles and features step you need to add the WindowsSource in your cs.ini file
    • Proposed as answer by oriooff Saturday, September 27, 2014 6:08 PM
    • Marked as answer by Sandy Wood Monday, September 29, 2014 9:19 PM
    Saturday, September 27, 2014 6:39 AM

All replies

  • Have you added WindowsSource=%DeployRoot%\Operating Systems\xxxx to your customsettings.ini?

    Or how do you point out the windows media source files?

    Friday, September 26, 2014 9:41 PM
  • I haven't but perhaps I should. I did try manually installing it from an admin cmd with the dism command and it threw the same error.

    I was using the Install Roles and Features option in MDT>


    Orange County District Attorney

    Friday, September 26, 2014 9:46 PM
  • I had to do this the other day,  I ended up just copying the whole "sources\sxs" folder(~151mb), and added it along with a batch script as an MDT application pointing to the sxs sub-folder as the source.  That worked fine in my testing.  Using the Install Role step also didn't work for me.

    dism /Online /Enable-Feature /FeatureName:NetFx3 /Source:"%~dp0sxs" /LimitAccess

    /Brian


    -BrianG (http://supportishere.com)

    Saturday, September 27, 2014 2:29 AM
  • if you use the install roles and features step you need to add the WindowsSource in your cs.ini file
    • Proposed as answer by oriooff Saturday, September 27, 2014 6:08 PM
    • Marked as answer by Sandy Wood Monday, September 29, 2014 9:19 PM
    Saturday, September 27, 2014 6:39 AM
  • Thanks Brian. I hadn't thought about doing that. Good idea.

    Orange County District Attorney

    Saturday, September 27, 2014 10:59 PM
  • That did the trick. I added WindowsSource to my cs.ini and .NET FW 3.5 installed perfectly.

    Orange County District Attorney

    Monday, September 29, 2014 9:20 PM