none
Help getting project server site as default URL RRS feed

  • Question

  • I have been wanting to learn a little bit about this EPM stuff so I thought what more of a better way than to implement a project site for a litte side project me and a buddy are working on.  I have Sharepoint 2007, TFS 2010 and Project server 2007 all hosted on a single Server 2008 box.  I followed the instructions at juliocasal.com/archive/2009/11/02/team-foundation-server-2010-beta-2-office-sharepoint-server-2007-single-server-installation-part-1.aspx , both part 1 and 2 to setup sharepoint and tfs.  At this point everything works as it should.  I have a default TFS site on port 80 in the end and when I access my server from the outside it proceeds to the TFS site.  Then I didn't have any instruction on installing Project Server 2007, so I install it and then configure it on the port 80 TFS site under its site collection.  After I enable the service and provision the site, if I access http://dankdesk/ it opens the original default TFS site and then if I type http://dankdesk/blockgame it opens to the project site which I want to be my default. 

    Now if I access my URL from the outside, it goes to the default TFS site but if I goto http://www.mysite.com/blockgame it does not goto the project server site.  In the end I just want the project site to be the default site on port 80.  I have been working on this now for 4 days and have uninstalled and reinstalled SQL, Sharepoint, TFS and Project server so man times that I am now hoping someone with some experience will be able to give me at elast some direction and if I'm lucky an answer as to what I am doing wrong.  Any help would be very beneficial.  Thanks in advance!

     Dan

    Wednesday, July 21, 2010 4:25 PM

Answers

All replies

  • Dan:

    You have to decide which site is the default site, you can't have two. So you can have URLS like http://dandesk/tfs or http://tfs.dandesk/ IOW, you need to move the TFS site to a subdomain or a "/something" Like all IIS applications, the mapping to sites sharing the same port is handled by host headers. When you use SharePoint, you control your host headers by creating "Alteranate Access Mapping." You can find lots of infomation about this by searching on that term on Google, and TechNet. You'll need to setup AAM for both internal and external mapping.

     

     


    Gary Chefetz, MCITP, MCP, MVP msProjectExperts
    Project and Project ServerFAQs
    Project Server Help BLOG
    Wednesday, July 21, 2010 8:48 PM
    Moderator
  • Thanks Gary

    The only site in the end that I want is the Project server site, but in going through the steps it has me create the Team Foundation Sharepoint site on port 80.  My buddy is at a remote location and I need him to be able to have access to the team project site that project server creates.  Now in my ventrues with this issue, a couple days ago I did come across sites saying to use the host header.  So When I was setting up the project server I set the host header to my external URL and it worked perfectly when accessing from the outside, however then when I tried to access the project server site internally, I just got a blank page.  Now with your statement above are you saying that I can create an AAM to http://dankdesk/blockgame by typing the address http://blockgame.dankdesk/ ?  Because yesterday I was trying to get AAM working by typing http://dankdesk:80/blockgame and http://dankdesk/blockgame and it kept going to an error screen stating it was an invalid url.

    Wednesday, July 21, 2010 10:41 PM
  • Dan

    Any URL you use must be resolvable. I can't explain why URLs resolve or do not resolve in your environment as I have no access to your DNS. If you want to create subdomains like http://blockgame.mysite.com, you need to add an entry to your Doman DNS record. Likewise, you need to make sure that your network devices can resolve internal URLs.

     

     


    Gary Chefetz, MCITP, MCP, MVP msProjectExperts
    Project and Project ServerFAQs
    Project Server Help BLOG
    Thursday, July 22, 2010 5:21 PM
    Moderator