none
MDT 2013 update 1 Application Installation Script RRS feed

  • Question

  • I'm having difficulty installing applications with MDT. I am fairly new to using this tool and it seems to require a lot of scripting knowledge which I am trying to learn.

    When I can get a .msi file, I haven't had any problem running a silent install. However, .exe files are giving me trouble.

    The setup.exe app I am working with on my test of MDT deployment is the Firefox browser. I am trying to deploy it to Windows 10. It returns an error to me as follows:

    "Application Mozilla Firefox returned an unexpected return code: 2"

    Here's what I have tried:

    1. I have created a new application in MDT, using both the 'Application with Source Files' selection and the 'Application without Source Files or elsewhere over the network' option.

    2. In the working directory, I have tried .\Applications\"Mozilla Firefox", or have tried other file paths where I have the setup.exe located.

    3. After creating the application in MDT, I have created an installation task sequence, selecting only to install one application and pointing it to the MDT Firefox Application I created.

    4. The actual command. This is where I think I may be having my trouble. I have tried numerous commands:

    FirefoxSetupStub42.0.exe -ms

    FirefoxSetupStub42.0.exe /INI=<file path of the ini I created>

    <whole directory path to the setup.exe>\FirefoxSetupStub42.0.exe -ms

    <whole directory path to the setup.exe>\FirefoxSetupStub42.0.exe /INI=<file path of the ini I created>

    5. I have also tried a resource I found that uses a .cmd file which pulls from a .ini for custom settings, a .js, .css, .cfg, etc. This was a SCCM resource so I wasn't sure if it would work with MDT, but I gave it a try.

    With this, I copied all these files (.cmd, .cfg, .js, .css, the setup.exe, etc.) all to the working directory and out the command to direct to the .CMD file. I have the .CMD file script posted below.

    With all of this, I have tested the deployment by running the following commands:

    net use \\<servername>\deploymentshare$ user:<domain\username>

    cscript \\<servername>\deploymentshare$\Scripts\LiteTouch.WSF

    The LiteTouch UI opens up and I have successfully deployed the Win10 OS I put on it and deployed the AdobeAcrobat .msi app I put on there, so it seems that MDT and the LiteTouch.wsf are working fine, but it is my scripting on this setup.exe install.

    Any ideas???

    .CMD file script:

    @echo off
    REM==========================================
    REM Install FireFox 42.0
    REM==========================================
    REM Date   : 19 October 2015
    REM Author : www.itsupportguides.com
    REM .
    REM Script Details:
    REM --------------
    REM  This script will:
    REM       + silently install or upgrade Firefox WITHOUT Firefox being the default browser
    REM       + Disables the 'Automatically check for updates' option
    REM       + Disables the 'Always check to see if Firefox is the default browser on startup' option
    REM       + Deletes desktop icon
    REM       + Disables the Import Wizard
    REM       + Works for Windows XP / 7 /8 32-bit and 64-bit
    REM .
    REM===========================================
    echo Installing Firefox - Please Wait.
    echo Window will close after install is complete
    REM Installing Firefox
    "%~dp0FirefoxSetupStub42.0.exe" -ms
    REM Install 32-bit customisations
    if exist "%programfiles%\Mozilla Firefox\" copy /Y "%~dp0override.ini" "%programfiles%\Mozilla Firefox\browser\"
    if exist "%programfiles%\Mozilla Firefox\" copy /Y "%~dp0mozilla.cfg" "%programfiles%\Mozilla Firefox\"
    if exist "%programfiles%\Mozilla Firefox\" copy /Y "%~dp0local-settings.js" "%programfiles%\Mozilla Firefox\defaults\pref"
    REM Install 64-bit customisations
    if exist "%ProgramFiles(x86)%\Mozilla Firefox\" copy /Y "%~dp0override.ini" "%ProgramFiles(x86)%\Mozilla Firefox\browser\"
    if exist "%ProgramFiles(x86)%\Mozilla Firefox\" copy /Y "%~dp0mozilla.cfg" "%ProgramFiles(x86)%\Mozilla Firefox\"
    if exist "%ProgramFiles(x86)%\Mozilla Firefox\" copy /Y "%~dp0local-settings.js" "%ProgramFiles(x86)%\Mozilla Firefox\defaults\pref"

    • Moved by Bill_Stewart Friday, December 4, 2015 3:10 PM Move to more appropriate forum
    Friday, December 4, 2015 3:01 PM

All replies