locked
Management Studio 2005 NT Login Domain Settings RRS feed

  • Question

  • I run from a local machine and I am trying to use my NT login to connect to my Server based Database.  When I use the NT Login selection, the User Name is prepopulated with my local domain, and it is grayed out, not allowing me to enter the correct network domain. As a result I cannot connect and receive a login error.

    Is there a setting on the local machine that will remove the grayed out login and let me enter the correct domain?

    Thanks

    Tuesday, November 9, 2010 2:50 PM

Answers

  • No, it is a Windows feature.  Right click on SQL Server Management Studio, then choose "Run as...".   You will have to change from "Current user" to "The following user:" then type in the other login and password.

    RLF

    • Marked as answer by DaveKStLMo Wednesday, November 10, 2010 4:58 PM
    Wednesday, November 10, 2010 4:23 PM

All replies

  • Hello,

    When you are using "NT Login" then you login with your current windows account, there wouldn't be a need to enter your password, because you are already identified as a valid windows user.

    If you can't logon to SQL Server / get an error message, then because your Windows account don't have access rights to the SQL Server ... or you may used a wrong server name. What's the exact error message you get?


    Olaf Helper ----------- * cogito ergo sum * errare humanum est * quote erat demonstrandum * Wenn ich denke, ist das ein Fehler und das beweise ich täglich http://olafhelper.over-blog.de
    Tuesday, November 9, 2010 3:19 PM
  • Well, using integrated security ("NT Login") means that you use the user that you are currently logged in with... The only way to change that user and use one from a different domain is running the management studio under this account. (Using Run-As Different User). This only works within trusted domain environments though. I have already filed a Feature Request via Connect to change that, it's pretty annoying at times...

    Lucifer

    • Proposed as answer by SQLWork Tuesday, November 9, 2010 3:57 PM
    Tuesday, November 9, 2010 3:21 PM
  • Is the "Run AS" a setting in Management Studio?

     

    Dave

    Wednesday, November 10, 2010 3:29 PM
  • No, it is a Windows feature.  Right click on SQL Server Management Studio, then choose "Run as...".   You will have to change from "Current user" to "The following user:" then type in the other login and password.

    RLF

    • Marked as answer by DaveKStLMo Wednesday, November 10, 2010 4:58 PM
    Wednesday, November 10, 2010 4:23 PM
  • You are my hero!!!!!!!!!

    Thanks

    Wednesday, November 10, 2010 5:00 PM