none
SCCM client icon showing with question mark in management console | SCCM 2016

    Question

  • recently we have installed SCCM 2016 . we are able to push client package to the system and its showing with question mark however client package is showing as Active. also we are unable to deploy any application to the client system.



    • Edited by Syam_ Monday, December 26, 2016 7:56 PM
    Monday, December 26, 2016 7:55 PM

Answers

  • Hi all 

    problem has been resolved. i have done the following

    Right click on client > and click on approve . 

    now the clients is showing with green tick mark and i am able to deploy the application now 

    • Marked as answer by Syam_ Tuesday, December 27, 2016 7:49 PM
    Tuesday, December 27, 2016 7:48 PM
  • Had the same problem. This in my case was problem with "notifications".

    You should examine the following log files in order to find the source for this error:

    <ConfigMgrInstallDir>\logs\bgbmgr.log

    <ConfigMgrMPInstall>\logs\BGBServer.log

    <ConfigMgrInstallDir>\logs\BgbHttpProxy.log

    <ConfigMgrMPInstall>\logs\BgbSetup.log

    <ConfigMgrMPInstall>\logs\bgbisapiMSI.log

    Double check "Management Point properties" in "Management Point Database" Tab - try option "use the site database". 

    more info here:
    https://blogs.technet.microsoft.com/scotts-it-blog/2014/09/29/incorrect-deployment-of-database-replica-in-sccm-2012-may-cause-client-fast-channel-notification-problems/

    Wednesday, October 31, 2018 8:48 AM

All replies

  • If a client is installed but no data is yet available a grey question mark will appear. If a client is installed and online it will appear as in the screenshot above with a white tick in a green circle.

    Cheers Paul | http://sccmentor.com

    Monday, December 26, 2016 8:07 PM
    Moderator
  • Hi Paul

    Thanks for your replay.

    could you please explain me little more about this .i am sorry, what you mean by Data availability ?. i have installed this client two days back . also i am unable to push applications please see the below screen shot since last one day its showing as the same.

    Monday, December 26, 2016 8:34 PM
  • check your boundaries

    Cheers Paul | http://sccmentor.com

    Monday, December 26, 2016 9:12 PM
    Moderator
  • Hi paul,

    i have verified boundaries and its looks fine. any other suggestion. could pleas tell me about Data availability which you have mentioned in your first post  .

    Monday, December 26, 2016 10:06 PM
  • Hi,

        You can try to examine logs on your clients to see if there're any registration or communication issues between your clients and the MP (ClientIDManageStartup.log, CCMMessaging, LocationServices.log, etc).

    Regards,

    Jimmy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Tuesday, December 27, 2016 9:31 AM
    Moderator
  • Hi all 

    problem has been resolved. i have done the following

    Right click on client > and click on approve . 

    now the clients is showing with green tick mark and i am able to deploy the application now 

    • Marked as answer by Syam_ Tuesday, December 27, 2016 7:49 PM
    Tuesday, December 27, 2016 7:48 PM
  • Hi,

        Okay, thanks for the sharing!

    Regards,

    Jimmy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, December 28, 2016 1:33 AM
    Moderator
  • If you have your hierarchy set up to approve clients in trusted domains automatically then this shouldn't be happening. Take a look at the following KB article (for 2007 but still relevant) to troubleshoot this problem.

    https://blogs.technet.microsoft.com/configurationmgr/2010/01/20/how-it-works-automatic-client-approval-in-configuration-manager-2007/


    Cheers Paul | http://sccmentor.com

    Wednesday, December 28, 2016 10:36 AM
    Moderator
  • Hi Paul, In my case it was enabled.
    Thursday, December 29, 2016 6:40 AM
  • I'm have a similar issue with Linux clients, no issues for windows clients.  Is this normal?

    <mytubeelement data="{"bundle":{"label_delimitor":":","percentage":"%","smart_buffer":"Smart Buffer","start_playing_when_buffered":"Start playing when buffered","sound":"Sound","desktop_notification":"Desktop Notification","continuation_on_next_line":"-","loop":"Loop","only_notify":"Only Notify","estimated_time":"Estimated Time","global_preferences":"Global Preferences","no_notification_supported_on_your_browser":"No notification style supported on your browser version","video_buffered":"Video Buffered","buffered":"Buffered","hyphen":"-","buffered_message":"The video has been buffered as requested and is ready to play.","not_supported":"Not Supported","on":"On","off":"Off","click_to_enable_for_this_site":"Click to enable for this site","desktop_notification_denied":"You have denied permission for desktop notification for this site","notification_status_delimitor":";","error":"Error","adblock_interferance_message":"Adblock (or similar extension) is known to interfere with SmartVideo. Please add this url to adblock whitelist.","calculating":"Calculating","waiting":"Waiting","will_start_buffering_when_initialized":"Will start buffering when initialized","will_start_playing_when_initialized":"Will start playing when initialized","completed":"Completed","buffering_stalled":"Buffering is stalled. Will stop.","stopped":"Stopped","hr":"Hr","min":"Min","sec":"Sec","any_moment":"Any Moment","popup_donate_to":"Donate to","extension_id":null},"prefs":{"desktopNotification":true,"soundNotification":true,"logLevel":0,"enable":true,"loop":false,"hidePopup":false,"autoPlay":false,"autoBuffer":false,"autoPlayOnBuffer":false,"autoPlayOnBufferPercentage":42,"autoPlayOnSmartBuffer":true,"quality":"default","fshd":false,"onlyNotification":false,"enableFullScreen":true,"saveBandwidth":false,"hideAnnotations":false,"turnOffPagedBuffering":false}}" event="preferencesUpdated" id="myTubeRelayElementToPage"></mytubeelement><mytubeelement data="{"loadBundle":true}" event="relayPrefs" id="myTubeRelayElementToTab"></mytubeelement>

    • Edited by Bhanu_P Thursday, March 23, 2017 12:11 PM
    Thursday, March 23, 2017 12:08 PM
  • If they are not in trusted domains that Configmgr manages then yes

    Cheers Paul | http://sccmentor.com



    Friday, March 24, 2017 3:07 PM
    Moderator
  • You could be super gung-ho about this and choose the bottom option but I wouldn't recommend this


    Cheers Paul | http://sccmentor.com

    Friday, March 24, 2017 3:11 PM
    Moderator
  • Hi Syam,

    When i try to approve the client as per the above. Approve option is grey out. Can you please help me to fix this problem ... thank you

    Sunday, June 25, 2017 6:32 PM
  • Approve is grayed out for me as well.

    Darel Pedersen

    Thursday, August 3, 2017 4:45 PM
  • Where do I go to find the hierarchy settings properties shown in the screen shot? 

    Darel Pedersen

    Thursday, August 3, 2017 4:52 PM
  • Darel, go to Administration -> Site Configuration -> Sites -> Click on your site and it will show up in the menu on the top of the console.
    Friday, September 22, 2017 9:13 AM
  • Had the same problem. This in my case was problem with "notifications".

    You should examine the following log files in order to find the source for this error:

    <ConfigMgrInstallDir>\logs\bgbmgr.log

    <ConfigMgrMPInstall>\logs\BGBServer.log

    <ConfigMgrInstallDir>\logs\BgbHttpProxy.log

    <ConfigMgrMPInstall>\logs\BgbSetup.log

    <ConfigMgrMPInstall>\logs\bgbisapiMSI.log

    Double check "Management Point properties" in "Management Point Database" Tab - try option "use the site database". 

    more info here:
    https://blogs.technet.microsoft.com/scotts-it-blog/2014/09/29/incorrect-deployment-of-database-replica-in-sccm-2012-may-cause-client-fast-channel-notification-problems/

    Wednesday, October 31, 2018 8:48 AM
  • Question mark icon trouble solved after months of analysis together with MPS (in our case).

    Initial point
    After OSD always the same couple of computer objects appear with question mark icon.

    The workaround was (for long time): delete smscfg.ini and restart service ccmexec.

    Now we found a final solution: delete the computer object in AD and recreate it. After a new OSD the trouble of question mark icon are gone.


    Thursday, November 8, 2018 2:20 PM