none
IE9 download manager will not display "Open" option (only "Save" and "Cancel" is displayed) for downloading HTML documents.

    Question

  • Hi,

    When our website users click on an html attachment embedded on a web-page in IE9, the download manager will not display the "Open" option. It will only display "Save" and "Cancel" which our users don't like, having to save the html document in a folder to open it. Whereas, when downloading attachments like pdf, word etc. all three options are displayed. 

    Is there any setting to tweak , which will display all the 3 options for HTML attachments as well?

    Sunday, October 6, 2013 7:31 AM

Answers

All replies

  • Hi,

    It seems that there has nothing to do with IE 9.

    However, I suggest you test to set file associations.

    1. Locate to Internet Option.
    2. Click Programs tab, and choose Set associations.
    3. Select the extension .html to open by default, and then click Save.

    Thanks!

    Tuesday, October 8, 2013 11:38 AM
    Moderator
  • Hi,

    Thanks for your response. I checked the Internet options in my machine and found that .html file was already associated to open with "Internet Explorer". So this could not be an issue. 

    Thursday, October 10, 2013 12:48 PM
  • Hi,

    As you know, the Open-Save-Cancel dialog box helps you prevent your computer from affecting by virus while downloading.  So I suggest you test to reset all zones to a lower level temporarily and then please attempt to download this html attachment again.

    However, since you can normally download the other documents, I suspect there is some restriction in the website which you are trying to view. I recommend you to contact the administrator of that website if possible.

    could you please send me the link of the website from where you are trying to download the html attachment?

    Thanks!


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.


    Monday, October 14, 2013 2:59 AM
    Moderator
  • I am experiencing a similar problem. Changing all zones to low level does not resolve the issue. The website is built by myself and there is not any restrictions that could cause this behavior. For the detailed description of the issue, please refer to the question I raised in the Microsoft Community. Since I am not allowed to paste the link here, please search title "IE 10 on Windows 8 does not offer the "Open" button in the Notification Bar after downloading a html file" there.

    There is also a test html link you could try.

    Thanks.



    Thursday, November 28, 2013 8:56 AM
  •  .html file was already associated to open with "Internet Explorer". So this could not be an issue. 

    A problem is that what is being received may not be detected as an ".html file".  E.g. there is a process called MIME sniffing which goes on first.  Use the Developer Tools, Network Capture tool to check on this possibility.  Also, there is a Security option (in the Miscellaneous section) which can be used to try to avoid it.  However, I don't know if that will change your particular symptom too.



    Robert Aldwinckle
    ---

    Thursday, November 28, 2013 5:34 PM
    Answerer
  • I know this is a 3 year old post, but I was having this issue when one of my junior technicians updated group policy. I came across this page and saw no solution, but I did eventually find one elsewhere and I thought i'd post it here in case someone else needs it.

    Real simple:

    Tools > Internet Options > Advanced tab > scroll down to Security > you will find an option "Do not save encrypted pages to disk".  Take the checkmark out and that should fix this immediately (no need to restart IE or reload the page).

    I'm in IE11, but I'm sure this is the same on all versions listed above.


    Monday, June 6, 2016 4:54 PM
  • Thanx very much Isaac, I had this issue too, and your solution really helps.
    Thursday, September 8, 2016 7:08 PM
  • Thank you IsaacShloss! Works also with .msg files.
    Thursday, November 30, 2017 2:49 PM
  • Hi Isaac, is disabling this setting a cyber security risk?

    Ravinder Jamgotre

    Tuesday, May 8, 2018 10:58 AM