none
Site collection che non eredita le impostazioni della web application

    General discussion

  • Ciao a tutti,

    ho creato un nuovo site collection sotto un'esistente web application. In particolare ho anche creato un nuovo DB su un diverso HD che ho poi agganciato a questo site collection. Il problema è che non riesco a modificare il limite massimo della dimensione dei file  in upload, che ho letto viene ereditato dalle impostazioni della web application. Nella mia web application ho un limite di 1 TB e in effetti per l'altro site collection non ho problemi.

    Come faccio ad incrementarla anche per questo nuovo site?

    Grazie

    Ciro

    Wednesday, July 16, 2014 1:17 PM

All replies

  • Ciao Ciro,

    che problema o errore ti da la site collection?

    Hai verificato che non siano impostate quote sul sito?

    Hai spazio disco sufficiente nell'unità in cui hai il file di database? Il db è configurato correttamente per quanto riguarda l'autogrow?

    Fabio

    Thursday, July 17, 2014 9:03 AM
  • Ciao Fabio,

    la site collection funziona regolarmente. In particolare quando ho iniziato a migrare i dati da una sezione della "vecchia" site collection alla nuova mi sono accorto che incontrato il primo file più grande di 50 Mb, la copia si interrompeva. Ho riconosciuto l'errore nel limite di upload del file che però per un site collection non è configurabile.Ho creato un nuovo DB su un nuovo HD di 800 Gb, non penso ci siano limiti sul DB.

    Come vedi sotto non dovrebbero esserci quote impostate

    Thursday, July 17, 2014 10:08 AM
  • Ciao Fabio,

    la site collection funziona regolarmente. In particolare quando ho iniziato a migrare i dati da una sezione della "vecchia" site collection alla nuova mi sono accorto che incontrato il primo file più grande di 50 Mb, la copia si interrompeva. Ho riconosciuto l'errore nel limite di upload del file che però per un site collection non è configurabile.Ho creato un nuovo DB su un nuovo HD di 800 Gb, non penso ci siano limiti sul DB.

    Come vedi sotto non dovrebbero esserci quote impostate


    Thursday, July 17, 2014 10:10 AM
  • Ciao Fabio,

    per l'autogrowth ho utilizzato le stesse impostazioni del DB esistente, ovvero: 1 Mb, unrestricted growth.

    Thursday, July 17, 2014 10:15 AM
  • Se sono figlie della stessa web application la seconda site collection ha lo stesso limite in upload della prima.

    Quando ti si blocca il caricamento, riesci ad avere visibilità del messaggio d'errore?

    Se il file ha una dimensione inferiore al limite ipostato verifica che non sia impostata una dimensione massima del file di db (non darlo per scontato).

    Fabio

    Thursday, July 17, 2014 10:20 AM
  • Ciao Fabio, grazie per la tua disponibilità

    Allora ho verificato e non mi sembra ci siano limiti di dimensione del DB su sql. Ho riprovato a lanciare una nuvoa copia di file, ed ecco un nuvo errore, ti allego il messaggio:

    Friday, July 18, 2014 2:17 PM
  • nel frattempo ho trovato questo setup relativo al template ed eliminato.
    Friday, July 18, 2014 2:43 PM
  • Non vedo se hai allegato qualcosa.

    Comunque questo potrebbe esserti d'aiuto.

    Fabio

    Friday, July 18, 2014 2:48 PM
  • Domanda: mi sembra che il caricamento tu lo faccia tramite esplora risorse, hai provato direttamente da browser?
    Friday, July 18, 2014 2:50 PM
  • ecco nuovamente l'errore di  superamento del limite di dimensioni massime
    Friday, July 18, 2014 2:52 PM
  • Domanda: mi sembra che il caricamento tu lo faccia tramite esplora risorse, hai provato direttamente da browser?

    Fabio!!! grazie, tramite browser ha caricato il file!!! ma perchè c'è questa differenza di comportamento?

    Grazie ancora!!!

    Ciro

    Friday, July 18, 2014 3:32 PM
  • ciao,

    stamane nuovamente esiste il problema, non riesco a caricare file di più di 50 Mb.

    il problema è che comunque dovendo trasferire dal "vecchio" site collection al nuovo migliaia di file, sono molto limitato perchè più di 100 file alla volta tramite browser non è possibile trasferire. Esiste un altro modo?

    Grazie in anticipo

    Ciro

    Monday, July 21, 2014 8:19 AM
  • Puoi provare con un tool di terze parti.

    Hai avuto risconto dal link che ho postato sopra?

    Tuesday, July 22, 2014 7:30 AM
  • Hai verificato che l'impostazioni di limite della webapplication non sia di 50MB? (o comunque prova a reimpostarlo).
    Per farlo vai sulla central admin -> Application Management -> Manage web applications -> Selezioni la tua webapplication -> General Settings. Qui aumenti la proprietà "Maximum upload size" fino ad un massimo di 2047 MB (il limite massimo). 
    Fatto questo riprova a caricare i file.

    NB: Per i trasferimenti multipli dovrebbe essere considerata la somma del peso. Quindi non caricare più di XMB alla volta (dove X è il tuo limite).

    Successiva modifica il seguente parametro nel webconfig della tua applicazione

    <httpRuntime maxRequestLength="51200" />

    con

    <httpRuntime maxRequestLength="51200" executionTimeout="999999" />

    Tuesday, July 22, 2014 12:55 PM