none
Synchronizing team project 2010 and enterprise project 2007 issues RRS feed

  • Question

  • Hello,

    I have integrated my TFS 2010 SP1 with Project Server 2007 SP2. I have registered by team and enterprise projects. I have created tasks in my project plan and saved and published to the project server. I facing two problems when synchronising data with team project:

    1. None of child tasks in the plan are getting published to team project even though the 'Publish to team project' has been set to yes for all parent and child tasks.

    Same is the case when I try to synchronise from team project to enterprise project. The tasks that have a 'Child' link with other tasks are not getting published to project server and hence to project plan.

    2. Once the enterprise project is published to the team project, resync-ing with the team project gives me a list of errors as shown in the image below. [The first publish happens fine except for the above issue]

    For each task, it gives me two/three errors as follows:

    a. One team foundation owner required - even though the resource is selected for the task and the resource has been added to the team project members group.

    b. Link error in publish to team project with the message - TF241011: Project has reset the value for the Publish to Team Project column to Yes. You cannot change the value for Publish to Team Project to No after the task has been synchronized to Team Foundation Server. To remove this task from being synchronized, close this dialog, delete the current task, and then re-create the task and set the Publish to Team Project to No before you publish the project plan.

    I have not touched the column and I do see the value as Yes for all tasks. I am not sure why this message is appearing.

    c. Invalid work-item type: Cannot change the work item type once it is published.

    b and c (above) are just messages and are auto-corrected. I set the value of a (above) for all tasks and still the Save and Publish button is not enabled.

    Any idea why this is happening? And what I can do to overcome this?

    Thanks.

    Shilpa 

    
    Monday, October 28, 2013 8:56 AM