locked
Vista bug with recognizing app discs RRS feed

  • Question

  • I'm using RTM and have run into at least one pretty major bug. For some reason, DVD's or CD's (such as application install CD's), simply aren't recognized at all when put in the DVD tray. Autorun does nothing, and if you try and open the disc Vista spits out a 'how would you like to prepare this blank disc' message. There's no way to get into it. I found at least one other guy with the same problem:

    http://www.msfn.org/board/index.php?showtopic=89575

    Anyone else come across this?


    It has to be a Vista problem, as I have two drives (a DVD recorder and a CD writer), and the same problem occurs with the disc in either drive, plus of course it's happening to other people :)

    Thanks

     

    Saturday, January 20, 2007 2:23 AM

All replies

  • I can confirm this behaviour.

    If I insert a DVD video recorded onto a DVD-R, I get the "How would you like to prepare this blank disc" message in any application dialog that tries to open the DVD drive letter.

    However, there is nothing wrong with the disc, as Windows Media Player will play the disc in the same Vista installation.

     

    Friday, January 26, 2007 8:25 AM
  • Thanks Greg, glad it's not just me :)
    Friday, January 26, 2007 9:43 PM
  • This is a driver problem, I have it and I'd just used the drive to install Vista.  The computer will boot from  a CD.  Some help from Microsoft would be appreciated.

    Tuesday, January 30, 2007 10:33 PM
  • Now that Vista has been released to the general public, I would certainly hope to see a fix for this problem soon, as there are going to be a hell of a lot more people experiencing the same issue very soon.
    Tuesday, January 30, 2007 11:37 PM
  • I've just fixed this on my pc, the Region setting was blank. Go to Disk Manager in Computer Management and right click the DVD drive. In properties, change the Region to the correct one (2= UK, 1=USA).

    You can only do this a limited number of times for a specific drive.


    Wednesday, January 31, 2007 3:08 PM
  • I have no region tab in the properties unfortunately :)

    This is really starting to get on my nerves now!  I need to update my GPS and can't bloody install the application as Vista just wants to format the application CD!   Come on MS, give us a patch.
    Saturday, February 10, 2007 11:04 PM
  • Same problem here, lite on drive, 1635S

    Solved the problem, by deinstalling AnyDVD.
    Thursday, February 22, 2007 9:38 PM
  • I don't have AnyDVD installed ;)
    Friday, February 23, 2007 6:24 AM
  • I too am having this issue. Every cd I own does this - my msdn disks, my office cd's, etc.

    As a workaround, the command prompt can see the drive just fine.  Drop into the command prompt ('run' -> 'cmd') and access your drive old-school style.  What is funny is when I do this to run the setup program on a cd, the installer software can get to the drive fine too.  It is just an explorer shell thing I guess.

    I'm actually curious to let vista have its way and try to format one of these disks. Just to see what happens :-)

    Here is my device:
    PIONEER DVD-RW DVR-111L ATA Device

    Driver Strong Name:
    cdrom.inf:cdrom_device.NTx86:cdrom_install:6.0.6000.16386:gencdrom

    Hardware ID's:
    IDE\CdRomPIONEER_DVD-RW__DVR-111L________________8.29____
    IDE\PIONEER_DVD-RW__DVR-111L________________8.29____
    IDE\CdRomPIONEER_DVD-RW__DVR-111L________________
    PIONEER_DVD-RW__DVR-111L________________8.29____
    GenCdRom





    Friday, February 23, 2007 9:47 PM
  • Hi there,

    I had a similar problem with no Region Tab in my DVD RW drive. I remembered that I had made this drive region free. So as off chance I used K-Probe to check my drive and sure enough there was no RCP enabled. So i re-enabled RCP and then I had my Region Tab back:)

    So now I can play DVD's again..

    This used to be fine under XP MCE 2005, but I can only think that there are some tighter DRM checks with Vista..

     

    Monday, February 26, 2007 6:04 AM
  • The same thing happened to me after installing VMware.  By default, VMware disables autorun upon installation due to possible conflicts with some drives. Go to HKEY_LOCAL_MACHINE\System\CurrentControlSET\Services\CDRom, and look for the "Autorun" key.  If its value is set to "0", set it to "1" and reboot.  This fixed my problem; I hope it works for others.
    Thursday, March 1, 2007 1:12 AM
  • Bingo!  I forgot I installed VMWare.

    For Google:

    If you constantly get "Prepare blank disc" and Windows Vista tries to format all your CD's, DVD's, or CD-ROM's then this thread might solve your problem.

    Thursday, March 1, 2007 2:25 AM
  • What happened when I let it have it's way is that the "Estimating time to finish" message box never closed until forced  to by Task Manager.

    It is truly disconcerting to see a computer demand to format the media it was installed from on the grounds that the media are blank.
    Thursday, October 18, 2007 5:44 PM
  • Yes, It worked for me too. Impressive. ThanQ very much.
    Friday, December 28, 2007 6:24 AM
  • I also had this issue after installing VMWare. Thank you for the fix, it worked and now Vista will allow me access to my discs again Smile

    Saturday, January 5, 2008 5:30 PM
  •  KevinGT wrote:
    The same thing happened to me after installing VMware.  By default, VMware disables autorun upon installation due to possible conflicts with some drives. Go to HKEY_LOCAL_MACHINE\System\CurrentControlSET\Services\CDRom, and look for the "Autorun" key.  If its value is set to "0", set it to "1" and reboot.  This fixed my problem; I hope it works for others.



    Thanks a lot for the solution, but i want to add something, it's not required reboot computer for solve it, instead of you can kill explorer.exe process and you get the same result.
    Sunday, June 29, 2008 6:20 PM