none
DPM Storage Pool failed or not found Disk Error RRS feed

  • Question

  • Hey Guys,

     

    Tried searching but could not find anything like what I am experiencing.

    I'm running Server Standard 2008 SP2.  DPM 2007 V2.0.8793.0

    I am getting this error: The last recovery point creation failed for the following reason: (ID: 3159)
    Cannot access volume on the replica of  Managers Storage Group on exch01.domain.local. (ID: 92)

    Looking at DPM UI and then DPM Storage Pool I am getting Disk Failed or Disk Not Found errors.

    Tried rescanning but it just goes on for hours and hours and hours. I had to kill the process to allow for troubleshooting.

    I'm new to DPM so it's all at this point a lot of reading and trying to piece together the puzzle.
    But I read that if I remove the storage pool I would need to add it again and it would format the storage pool disk.
    For obvious reasons that's not the preferred fix here as I have months of backups on the disk.

    This was all working fine until recently. The only change was some windows updates that were installed.
    There is also no firewall between DPM and Storage Pool Disk.  Both are behind the firewall.

    Any suggestions or ideas would be greatly appreciated.

    Thank you

    p.s
    Merry Christmas everyone :0)

     

    Wednesday, December 22, 2010 10:36 PM

All replies

  • Forgot to add, the missing shows up with errors in Disk Management but it locks ups.
    I can't do anything, I end up killing the application process.

    It is a Dynamic Disk, I was told that this was a bad idea as it caused problems.

    Wednesday, December 22, 2010 10:39 PM
  • Hi,

    Please update the DPM server to the latest QFE build 8868 by installing KB 2250436 - there were some disk performance enhancements post Sp1 included in that fix.

    DPM requires Dynamic disks, so if the dynamic disk has problems, you need to fix that before DPM "missing disks" will get resolved.

    Instead of using disk management, use diskpart.exe commands to rescan and reactivate any at risk disks.

    If you have any trouble getting the dynamic disk healthy, please open a thread in the Windows forum.


    Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Wednesday, December 22, 2010 11:49 PM
    Moderator
  • Hi,

    Please update the DPM server to the latest QFE build 8868 by installing KB 2250436 - there were some disk performance enhancements post Sp1 included in that fix.

    DPM requires Dynamic disks, so if the dynamic disk has problems, you need to fix that before DPM "missing disks" will get resolved.

    Instead of using disk management, use diskpart.exe commands to rescan and reactivate any at risk disks.

    If you have any trouble getting the dynamic disk healthy, please open a thread in the Windows forum.


    Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    So I updated as per the KB article.

    Now nothing is working right. >_<

    Network and sharing center won't load, the DPM manager won't load, the server manager won't collect data in any category.

    Strange thing is I can ping and tracert, so I know i'm on the network, but DPM doesn't seem to think so.

    Ideas?

     

    thanks

    :UPDATE:

    And just like that I'm a liar. x|
    After 2 reboots and an MMC exception error.
    Now it all works....

    I'll post an update on how my dpm issues are going in a bit.
    Back to the original problem.

    Monday, December 27, 2010 10:18 PM
  • DPM requires Dynamic disks, so if the dynamic disk has problems, you need to fix that before DPM "missing disks" will get resolved.

    Instead of using disk management, use diskpart.exe commands to rescan and reactivate any at risk disks.

    If you have any trouble getting the dynamic disk healthy, please open a thread in the Windows forum.


    Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    In other words, if convert dynamic disk to basic disk, the DPM problems can be resolved? I think so but I do not know whether it is correct.

    no, I don't want to use basic disks at this point. Also, mike says dynamic disks are required.

    But thank you for your suggestion.:)

    Monday, December 27, 2010 10:20 PM
  • So I installed the update but the DPM Manager isn't showing that it actually took.
    I've still got the old version number. I ran the update from the CMD line with the -skipdbbackup switch.

    Am I missing something?

    Monday, December 27, 2010 10:36 PM
  • Yeah... that was a mistake.

    Never should have installed that update.
    Everything is going haywire... >_>

    None of the MMC snap ins are working.

    Diskpart doesn't even work..... I'm going to see if I can
    remove that update..

    For anyone else reading this thread, don't install HotFix 2250436.

    It's nothing but problems.

    Monday, December 27, 2010 11:29 PM