none
remote administration using steady state RRS feed

  • Question

  • hello,
    right now me and my colleagues use remote control program to troubleshoot users computer at the branch office.
    to keep the connections up when logging of the user's accounts we add the DWORD KeepRasConnections on HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon.
    before i installed steady state on user computers, the key worked perfectly, but after steady state was installed,
    everytime i logoff the user's account the dial up connection were terminated.
    anybody can give the answer why this problem happens?

    by the way, the computers on the branch office is using steady state 2.0 with windows XP SP 2 with dial up phone connections

    thanks before
    Friday, December 7, 2007 8:47 AM

Answers

  • thanks shawn, i found the answer to the problem already. i should've used string instead of DWORD in creating the KeepRasConnections key, the key works perfectly now.


    Thank You for the reply


    Thursday, December 13, 2007 4:31 AM

All replies

  •  

    Hi Randy,

     

    What's the name of the remote control program?

    Did this issue also occur when logging on with an administrator account?

     

    If this issue doesn't occur within an administrator account from the remote side, it can be caused by some restrictions. You can create a new account and then configure “No Restrictions” to test.

     

    I also suspect this issue is related to Fast User Switching. As you may know, Fast User Switching is disabled by SteadyState. Users must manually log off from their current session before another user can logon. To test this, you can disable Fast User Switching on a test machine and then check the RAS connection. You can configure Fast User Switching from Control Panel -> User accounts or the following registry key:

     

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\CurrentVersi on\Policies\System]

     

    Create a DWORD value, valuename "DisableFastUserSwitching", set its 'value data' to 1

     

    Best Regards,

    Monday, December 10, 2007 3:09 AM
  • thanks shawn, i found the answer to the problem already. i should've used string instead of DWORD in creating the KeepRasConnections key, the key works perfectly now.


    Thank You for the reply


    Thursday, December 13, 2007 4:31 AM
  • Thank you for posting the result!

     

    If any SteadyState related issue is encountered in the future, feel free to post here.

     

    Regards,

    Friday, December 14, 2007 2:17 AM