locked
windows 7 BSOD 'Bugcode_USB_DRIVER' linked to 'UsbHub.sys' (Caused by driver/address) & 'ntoskrnl.exe' (Crash Address): proving a serious problem! :( RRS feed

  • Question

  • Hi,


    I have a windows 7 Home Premium (service pck 1) ASUSTeK computer (four GB RAM, Intel R processor) Sixty-Four bit. From the Subject title I'm having BSOD problems and lots of them (started on 29/12/2016 but I hadn't installed new hardware or software), I tried troubleshooting it myself for over a week now using many Microsoft forums but to no avail!


    It crashes quite randomly, but mainly after it's been left to go to sleep, or even if it dims the screen to save battery! I couldn't recreate it in safe mode, tried scans, updating USB stuff from Computer Management, and windows updates are fine.

    It's very important that I use my laptop as I'm a Fourth year at university trying to write my dissertation!

    Thanks in advance.

    https://1drv.ms/u/s!Av6x2E0Wr5iEgQMPIqbN1EqRCw_y  (My Skydrive Link to compressed Minidump file of BSOD crashes)

    https://1drv.ms/u/s!Av6x2E0Wr5iEgQTusn0d2p6RlU6z     (My Skydrive Link to compressed 'Errors' Events file--too many of them--ignore 'Bonjour servce' ones)

    https://1drv.ms/u/s!Av6x2E0Wr5iEgQbJG1_BYzlT0csD       (My Skydrive Link to compressed 'Critical Errors' Events file--Last 6 relevant)


    Info: 

    Problem signature:
      Problem Event Name: BlueScreen
      OS Version: 6.1.7601.2.1.0.768.3
      Locale ID: 2057

    Additional information about the problem:
      BCCode: fe
      BCP1: 0000000000000008
      BCP2: 0000000000000006
      BCP3: 0000000000000005
      BCP4: FFFFFA8008D66B20
      OS Version: 6_1_7601
      Service Pack: 1_0
      Product: 768_1

    BlueScreenView information (I have five more record similar to this from recent crashes!)


    011117-44803-01.dmp 11/01/2017 02:08:02 BUGCODE_USB_DRIVER 0x000000fe 00000000`00000008 00000000`00000006 00000000`00000005 fffffa80`08d66b20 usbhub.sys usbhub.sys+12a5c x64 ntoskrnl.exe+70400 C:\Windows\Minidump\011117-44803-01.dmp 2 15 7601 343,760 11/01/2017 10:19:00






    • Edited by HamishAsus Wednesday, January 11, 2017 2:56 PM
    Wednesday, January 11, 2017 11:31 AM

All replies

  • It may help to look at the minidump files from the blue screen crashes.

    Can you zip up the minidump files in the C:\Windows\Minidump folder and make available (provide link) via a public folder on OneDrive or similar site?

    Here's a link on using OneDrive::

    http://windows.microsoft.com/en-ca/onedrive/share-file-folder

    If you have problems zipping the minidump files copy the minidump files to another location such as a folder on the Desktop

    Also, you do not necessarily have to zip up the minidump files, you can upload them one at a time.

    Wednesday, January 11, 2017 2:48 PM
  • Hi,

    here is a link: https://1drv.ms/u/s!Av6x2E0Wr5iEgQMPIqbN1EqRCw_y  (My Skydrive Link to compressed Minidump file of BSOD crashes). I've looked at them already using 'Bluescreenview', the info from it is above.

    is .rar file the right compression file?

    Wednesday, January 11, 2017 3:04 PM
  • Im not sure how to compress the folder other than making the .rar file, and my computer didn't let me upload the folder as normal... also the problem is worsening as it just crashed 10 minutes ago which it wouldn't do unless it was going to sleep or waking up! I'm a little worried now :(
    Wednesday, January 11, 2017 4:26 PM
  • .rar file is fine.

    The minidump files did not show a third party driver as causing the issue so the issue may be with the usbhub.sys itself:

    BUCKET_ID:  X64_0xFE_usbhub!UsbhHubProcessChangeWorker+ec

    Can you install the following hotfix for the usbhub.sys and see if it helps any:

    https://support.microsoft.com/en-us/kb/2895729

    There is a link at the top of the article to request the hotfix.

    Also, can you run the following utility from Intel and see if it picks up any driver updates:

    https://downloadcenter.intel.com/download/24345/Intel-Driver-Update-Utility

    Also, make sure the Driver Verifier is "off":

    Windows Key + R > type verifier.exe in the "Open" box > OK > Delete existing settings > Finish

    • Marked as answer by HamishAsus Friday, January 20, 2017 12:32 AM
    • Unmarked as answer by HamishAsus Wednesday, January 25, 2017 11:21 PM
    Wednesday, January 11, 2017 9:11 PM
  • Hi,

    Thank you for the reply! Is the 'ntoskrnl.exe' something important (highlighted/mentioned by the minidump file?)? Verifier off now, I put it on recently as suggested to aid with the problem (it didn't).

    Re the hotfix; are you confident it couldn't possibly cause other problems? (In my troubleshooting searches I came across this and another hotfix (dated 2009) but they had disclaimers about possibilities of issues if I didn't have the specific problem the fix was intended for (I wasn't sure because I'm not an expert at system troubleshooting) so I left them aside to be safe.)

    Thank you.

    Thursday, January 12, 2017 1:04 AM
  • I believe the hotfix has a good chance of solving the issue as even the Driver Verifier enabled dump file showed the same error and the error appears to be related to the system powering down (mentioned in the hotfix article):

    BUCKET_ID:  X64_0xFE_VRF_usbhub!UsbhHubProcessChangeWorker+ec

    But the problem could be elsewhere so if the crash keeps occurring post back with the resulting minidump file(s).

    BlueScreenView references the ntoskrnl.exe but the ntoskrnl.exe is not causing the crash.

    Thursday, January 12, 2017 2:12 AM
  • Okay thank you. I'll backup my computer then install the hotfix and get back to you.

    I installed the Inter r utility, but it looked like it couldn't find updates (there was a box saying so). I wasn't sure how to use it but clicking 'scan' for updates was the main interaction and it produced the text below: 'These drivers are Intel generic drivers. They do not include customizations that your manufacturer might have added to optimize your computing experience.' Under the title 'Latest drivers'. I couldn't find any other options.

    (ps, thank you for helping me!)

    Thursday, January 12, 2017 3:28 PM
  • You're welcome for the help.

    Let us know how it goes.

    Thursday, January 12, 2017 11:39 PM
  • Hi,

    We haven’t heard from you for a couple of days, have you solved the problem? We are looking forward to your good news.

    Best Regards,

    Tao


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, January 16, 2017 1:54 AM
  • Hi there,

    Sorry for the delay; I think so yes! Eight days without windows crashing at all has been the longest time so far, fingers crossed it's fixed for good! Thank you very much 'auggy' for the help! I think the hotfix you suggested did the trick, but what was curious was that a message appeared straight after the install stating that windows had stopped an 'unknown usb device' because it reported problems with it, yet I had nothing plugged in! 

    I'd have liked to knowhat may have caused the problem and if it could have been avoided (as I spent over 2 weeks researching before I asked online for help due to my lack of results!)

    Thanks again! I'll be sure to post again if anything strange like this happens :)


    Friday, January 20, 2017 12:30 AM
  • You're welcome. Thanks for the follow-up.
    Saturday, January 21, 2017 5:44 PM
  • Hello again, speaking of posting, here I am :( windows crashed again this evening with the same 'USBDRIVER' message, except that a full 12 days had gone by without any.. crashed as I was bringing up a few extra tabs in google chrome, didn't even load them (two 'Seriescraving' tabs), annoying that it seems to do it whenever it wants now and not just entering/leaving sleeping mode.

    would really appreciate some help again, it's been a stressful start to my term!

    Below is a list of my Minidump files again (the recent ones and earlier few)with two extra files named 'item' and the date of the crash because the most recent two had mention of two different files and thought I'd include them in case they'd be helpful somehow.

    https://1drv.ms/f/s!Av6x2E0Wr5iEgR7N-pGdotXFfAy1

    Let me know if you can access them okay? Thank you.

    Wednesday, January 25, 2017 11:35 PM
  • Can you provide the actual minidump files from the latest crashes.

    Also, can you also provide the following file which has more information on the crash:

    C:\Windows\MEMORY.DMP

    The memory.dmp file will be quite large, you could zip and compress the memory.dmp file with a third party application such as 7-Zip.


    • Edited by auggyMVP Thursday, January 26, 2017 6:34 PM
    Thursday, January 26, 2017 6:34 PM
  • Hi, okay sorry about that.

    Last time you said .rar files were okay? I have a program for making them. Below is a link to the memory.dmp and new minidump file (I wasn't allowed to convert the individual files so I had to do the whole folder for it to work, but it should show dates for recent crashes?: from 10/01 to 11/01 up to yesterday 25/01 and today 26/01).

    https://1drv.ms/f/s!Av6x2E0Wr5iEgSCvxnavPGz-y0lu

    Let me know if it's okay, or if I need to make the zip files instead? Are there free programs for compressing files to .zip? Thank you.

    Thursday, January 26, 2017 8:21 PM
  • .rar  is fine.

    The error appears to be similar to previous errors.

    There was an older different error, that appears to be a few years ago, that showed the iusb3hub.sys was the cause and the same driver version appears to be installed now.

    The iusb3hub.sys is an Intel USB 3.0 driver so try updating that driver (to 1.0.10.255):

    https://downloadcenter.intel.com/download/21129/USB-3-0-Driver-Intel-USB-3-0-eXtensible-Host-Controller-Driver-for-Intel-7-Series-C216-Chipset-Family?product=65855

    Also, update the Realtek card reader driver (to V10.0.370.125):

    http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=15&PFid=25&Level=4&Conn=3&DownTypeID=3&GetDown=false

    Also, try running the following utility from Intel and see if it picks up any more driver updates:

    https://downloadcenter.intel.com/download/24345/Intel-Driver-Update-Utility

    Friday, January 27, 2017 1:24 PM
  • Hi there,

    Right okay, if it was back in 2013 or 2014 that was when I got the laptop I think. That's me done those two updates, and the Intel driver utility but it couldn't update anything, saying it couldn't find my drivers or something.

    I'll let you know how it goes; I'm guessing the only way I can tell if it's fixed or not is if it crashes? Thank you for helping again! :)

    Saturday, January 28, 2017 12:30 AM
  • OK, yes if there is further crashes please provide the resulting minidump file(s).
    Saturday, January 28, 2017 2:08 PM
  • Hi there,

    Im back again, unfortunately windows crashed again, this evening at 5:43pm. I've pasted the link to my rar minidump file again, with the new crash from today in it hopefully.

    Im not getting any extra/new information from BlueScreenView, but I can say that when it crashed this time, all I had was a black/dark screen, with lines down it on one side (there was no normal 'bluescreen error page'). I have these dark screens alongside the bluescreen crashes-i think they're the same crash, but they also occur when I switch the computer on (don't stay stuck, but lag a little while the computer is trying to boot..).

    May I have some other problem, with Booting maybe? Is there any info in 'Event Viewer' that may help? Thank you.

    https://1drv.ms/u/s!Av6x2E0Wr5iEgSEZ60GEVnWSfp7O

    Wednesday, February 1, 2017 11:11 PM
  • Can you provide the following information which may help determine any issue(s):

    Windows Key + R > type msinfo32 in the "Open" box  > OK > File > Save > then save as an .nfo file

    Then make the resulting .nfo file available via OneDrive.

    Also, can you do the following:

    Windows Key + R > type eventvwr in the "Open" box > OK > expand "Custom Views" and then right-click "Administrative Events" > select "Save all events in Custom View As" and save as an .evtx file

    Then make the resulting .evtx file available via OneDrive.

    Friday, February 3, 2017 1:39 AM
  • Hi there,

    Right okay, that's me saved and uploaded those two files, I've pasted the link below. Thank you.

    https://1drv.ms/f/s!Av6x2E0Wr5iEgSQBsgjwGibwro1v

    Friday, February 3, 2017 1:35 PM
  • There is this repetitive error in the Event Logs from "Source" "Disk":

    The driver detected a controller error on \Device\Harddisk1\DR1

    Can you open Disk Management and in the lower window what is "Disk 1" ?

    Saturday, February 4, 2017 2:41 PM
  • I had a look and all I have is 'Disk 0': 'Healthy (EFI System Partition)', 'OS (healthy, Boot etc)', 'Data (healthy primary partition)' and 'healthy (recovery partition)'. How else could I find 'Disk 1'?

    Last time I looked there were all sorts of repeating 'warning' errors and other strange errors, I think the crashes were always labelled 'critical error' though.  But a lot didn't make much sense to me and I don't know how to fix them (if they need fixing).

    Sunday, February 5, 2017 1:16 AM
  • Can you try the following:

    Right-click the Start button > Command Prompt

    Then at the Command Prompt type the following and press "Enter":

    diskpart

    Then at DISKPART> type the following and press "Enter"

    list disk

    What is the output of the list disk command?

    Is there a Disk 1?

    Sunday, February 5, 2017 6:41 PM
  • Hi,

    The output is: 'Disk 0, online, 698GB, 0B free, dyn, gpt *'

    No disk 1 :/

    Sunday, February 5, 2017 7:05 PM
  • Can you see if you can install the following driver update from Intel (download and run the setuprst.exe :

    https://downloadcenter.intel.com/download/23496/Intel-Rapid-Storage-Technology-Intel-RST-RAID-Driver

    Tuesday, February 7, 2017 10:52 PM
  • Okay, do I want the 2016 version or the 2013 version?

    Also what exactly does it do/is it for? A 'RAID' driver? Thanks :)

    Thursday, February 9, 2017 12:46 AM
  • Version 12.9.0.1001 appears to be the latest for the chipset.

    Setup should install an updated SATA Controller driver and there is some evidence in the Event Logs that would be of benefit.

    Thursday, February 9, 2017 5:04 PM
  • Okay, but at the top it says 'a newer version of this software is available..' ?

    Below is a link to the 2016 version it mentions; Version: 15.2.0.1020 (Latest) Date: 10/20/2016

    https://downloadcenter.intel.com/download/26361/Intel-Rapid-Storage-Technology-Intel-RST-RAID-Driver

    Or is this not suitable for my 'chipset'? Thank you.

    Saturday, February 11, 2017 12:26 AM
  • According to the Hardware Ids the newer versions are not compatible.
    Sunday, February 12, 2017 4:35 PM
  • Hi there,

    Apologies for the very late reply, i've been unwell recently (and busy with deadlines). So I didn't download the intel raid driver until a week or two ago, but i'm uncertain it worked properly.

    I have an 'intel' folder with 'intel centre' and 'intel rapid storage technology' and 'updates', running them didn't achieve much. I also have an 'intel raid driver-x64' folder in 'my downloads' but there wasn't a 'run program' file that would work to install it; all i had was the general 'setup' program from the website that installed the above. Do you think it installed? How do I check?

    I've been having a handful of crashes as well unfortunately. I've noticed two things; 1.) my computer fan was working overtime once when it crashed (over-heated?). 2.) Windows occasionally complains about an 'unrecognised device' attached to a usb port that has 'malfunctioned' (but disabling/updating it didn't work and my most regular usb is my wireless mouse that seems to work fine).

    Thanks again for your help, and sorry it's proving so impossible to fix! 

    Thursday, March 2, 2017 1:01 PM
  • Can you provide the latest minidump files and also an updated .nfo and .extx file.
    Saturday, March 4, 2017 1:51 AM
  • Sure thing, how do I do the last two; .nfo and .extx files (i don't remember these..)? Thank you.
    Saturday, March 4, 2017 11:46 PM
  • Here you go:

    Windows Key + R > type msinfo32 in the "Open" box  > OK > File > Save > then save as an .nfo file

    Then make the resulting .nfo file available via OneDrive.

    Also, can you do the following:

    Windows Key + R > type eventvwr in the "Open" box > OK > expand "Custom Views" and then right-click "Administrative Events" > select "Save all events in Custom View As" and save as an .evtx file

    Then make the resulting .evtx file available via OneDrive.

    Sunday, March 5, 2017 12:45 AM
  • Hi there,

    Sorry for the delay; https://1drv.ms/f/s!Av6x2E0Wr5iEgSV0NloqU62QQniY

    is a link to the 10-03 folder with the three files.

    https://1drv.ms/f/s!Av6x2E0Wr5iEgSmcbvNxTOpzV1CU is another link to the files themselves just in case.

    Thank you.

    Friday, March 10, 2017 12:14 PM
  • Hello again,

    So a bit of info i've scrounged not from crashes but from the 'unrecognised usb device' and 'malfunctioned usb device' messages: when I uninstall them, usually named 'USB Composite device' in bold, and then the computer installs them again (by itself), the two names it shows are "USB Composite device" and under that "ASUS USB 2.0 WebCam".

    Because these messages regularly appear before and after crashes, do you think it worth uninstalling/updating software for the ASUS Webcam (or something similar)? I don't know what the Admin Events are showing up for warnings and errors (they seem to show lots that i don't understand), but it may be worth investigating ?

    Thank you.

    Friday, March 10, 2017 6:19 PM
  • Yes, it may be worth a try to uninstall the ASUS software.

    Also, the aswHdsKe.sys shows up as an unloaded driver in the latest crash. The aswHdsKe.sys is an Avast driver so I might also suggest to temporarily uninstall Avast and use alternative security software such as Microsoft Security Essentials.

    Saturday, March 11, 2017 5:21 PM
  • Okay I'll try that then.

    Less keen about uninstalling Avast because it's paid for but maybe I will anyway..

    Anything else? I'm a little concerned that the fan/computer has 'overheated' twice now (it doesn't reload when this happens); the strange thing is that it's happened both times while the computer wasn't actually 'on', but in sleep mode.. the computer is very warm underneath and the fan vent spits out lots of really warm air, which im sure isn't normal!

    What could possibly be causing this? :p

    Thank you.

    Sunday, March 12, 2017 12:02 AM
  • The overheating could be a result of dust build up so, if you haven't already, you could try cleaning the vents, etc.
    Monday, March 13, 2017 12:40 PM