locked
Able to upload in FTP using Windows Explorer in Win7 but not in WinXP RRS feed

  • Question

  • Hi All,

    This is weird but I hope some could give an idea.

    Users is using WinXP, they able to upload small size of zip file to FTP without any problem but larger than 30mb will get error "timeout". Another weird thing is that no problem at all when using Win7, no matter how big the size..ie 1GB.

    My guess might be some patch installed but dont know what it is. Due license issue, we still use WinXP.

    Any ideas please.

    Friday, July 12, 2013 8:03 AM

Answers

All replies

  • Can you ping the destination ID continuously using :

    ping xx.xx.xx.xx -t

    and check if there are any drops in packets?


    Arnav Sharma | Facebook | Twitter Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Friday, July 12, 2013 2:34 PM
    Moderator
  • Hi Arnav,

    Yes, we did that already and there's an always an RTO. We tested in different network server located in different location (Sydney, Philippines and even to the servers located at same site) and all have RTO but still able to upload files no matter how big it is.  Network Team had mentioned due to TCP retransmission features it should be no problem.

    So we are just really curious why it wont continue on WinXP but on Win7 (located on same site, same network, same account) everything was fine.

    Any idea?

    Monday, July 15, 2013 2:59 AM
  • Hi,

    my guess is this might not be related to the OS, but to internet explorer settings. More specific there is an option to use Passive FTP or not in advanced settings.

    In background, windows explorer uses IE to ahndle the ftp trafic.


    MCP/MCSA/MCTS/MCITP

    Monday, July 15, 2013 8:51 AM
  • Yes, agreed. Not an OS issue.

    Arnav Sharma | Facebook | Twitter Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Monday, July 15, 2013 3:22 PM
    Moderator
  • Hi Sen,Arnav.

    Yes. We are aware of the Active and Passive settings. The fact that both OS are using Windows Explorer then that means they are using Active Connections. When passive you either upload file thru cmd or third app (filezilla) but this is not supposed to be. It is more user friendly when using windows explorer. Just curious why it is working on Win7 but not on XP.

    Any ideas?

    Wednesday, July 17, 2013 7:37 AM
  • Hi,

    Active and passive FTP refers to the way ports are assigned for the actual transfer. It has nothing to do with the app used in background, that is always internet explorer when users browse using windows explorer.

    For more details about active and passive ftp refer to http://en.wikipedia.org/wiki/File_Transfer_Protocol

    I would still advise to check the internet explorer settings on both a functioning and a malfunctioning client.

    If these are alike, you should ensure stable network connectivity. Make sure cabling is allright, drivers are up to date and not to use wireless.


    MCP/MCSA/MCTS/MCITP

    Wednesday, July 17, 2013 8:05 AM
  • Hi Senne,

    Appreciate for keeping this updated. We used below link, we changed and revert and same issue with XP.

    Both are using IE8. Is there any other setting that you recommend to check?

    http://support.microsoft.com/kb/323446

    Wednesday, July 17, 2013 8:20 AM
  • Hi,

    I have no clear answer for your issue. I would recommend checking on network stability. it might be an option to use an alternative ftp client to test the needed configuration and/or stability. IE does not support ftp resume as far as I know; most third party ftp clients do: you will ahve to check the transfer deatils to find out what happens during a transfer. Also a netwotk monitoring tool can be handy.

    I would recommend to start with driver updates for the NIC.  You could also attempt playing with tcp offloading/tcp chimney settings to improve stability on the connection. http://blogs.technet.com/b/networking/archive/2008/11/14/the-effect-of-tcp-chimney-offload-on-viewing-network-traffic.aspx
    http://msmvps.com/blogs/acefekay/archive/2009/08/20/tcp-chimney-and-rss-features-may-cause-slow-file-transfers-or-cause-connectivity-problems.aspx

    Note Vista and up do have an optimized tcp/ip stack, that has better performance and stability and has improved support for hardware acceleration. Tweaks like tcp chimney settings are usually not needed on these more recent OS's.


    MCP/MCSA/MCTS/MCITP

    Monday, July 22, 2013 9:53 AM
  • Hi All,

    This was resolved already in the past month but forgot to post it here.

    Here's the link the solves the problem.

    http://technet.microsoft.com/en-us/library/cc938205.aspx

    • Marked as answer by ChouyAwesome Tuesday, September 24, 2013 6:08 AM
    Tuesday, September 24, 2013 6:08 AM