locked
External Users prompted for username and password constantly on WSS 3.0 RRS feed

  • Question

  • Hi all,

    My environment is:
    ServerA: WSS on Windows Internal Database
    ServerB: DMZ with ISA Server 2006

    WSS site is accessed internally and externally using a FQDN https://sharepoint.domain.com configured using Alternate Access Mappings.
    Internal URL                             Zone        Public URL
    http://sharepoint.domain.com    Default      https://sharepoint.domain.com
    https://sharepoint.domain.com   Default      https://sharepoint.domain.com

    This site is then published via ISA Server externally using forms-based authentication.

    When an external user (on a non-domain PC) accesses the site from a Windows 7 machine, it opens the ISA Server login screen and they can log in and view the site (as expected) using a domain login account (Not their local windows account)
    They can move around between subsites, lists and libraries, though when they attempt to view a document, it then prompts for their username and password again (Windows Security box, NOT ISA screen)
    It will ask at least twice before it downloads the file.

    Is it possible to configure something (either in ISA Server or SharePoint Config) to stop this repeated prompting for username/password?

    I was hoping there would be something server-side to fix this, as there are a few external users needing to access our site, who are not accessing it from a domain PC.

    Please let me know if you require more information. I always seem to leave something out :)

    NOTE: I have been told that the same thing happens with Windows 7 on domain PCs externally too. I have been unable to verify this personally as I do not have a Windows 7 domain PC to test it on.

    • Moved by Mike Walsh FIN Tuesday, August 16, 2011 9:25 AM admin q not general (From:SharePoint - General Question and Answers and Discussion (pre-SharePoint 2010))
    Tuesday, August 16, 2011 5:02 AM

Answers

  • Hi ,

     

    I understand that when your user log in a ISA server to browser the SharePoint Site using external url, they need to input their user name and pass words some times .

     

    You can enable the single-sign-on in the ISA server. Single sign on (SSO) enables users to authenticate once to ISA Server, and then access all of the Web servers with the same domain suffix that ISA Server is publishing on a specific listener, without reauthenticating.

     

    For detailed information ,please refer to this site:

    Authentication in ISA Server 2006: http://technet.microsoft.com/en-us/library/bb794722.aspx

     

    Thanks,


    Entan Ming
    Thursday, August 18, 2011 4:34 AM
    Moderator
  • Hi,

    I had a problem that looks like yours and is now solved.

    Check out My post.

    Quick link wich helped me a lot: http://support.microsoft.com/kb/198116

    Regards.


    Thursday, August 18, 2011 10:07 AM

All replies

  • Hi ,

     

    I understand that when your user log in a ISA server to browser the SharePoint Site using external url, they need to input their user name and pass words some times .

     

    You can enable the single-sign-on in the ISA server. Single sign on (SSO) enables users to authenticate once to ISA Server, and then access all of the Web servers with the same domain suffix that ISA Server is publishing on a specific listener, without reauthenticating.

     

    For detailed information ,please refer to this site:

    Authentication in ISA Server 2006: http://technet.microsoft.com/en-us/library/bb794722.aspx

     

    Thanks,


    Entan Ming
    Thursday, August 18, 2011 4:34 AM
    Moderator
  • Hi,

    I had a problem that looks like yours and is now solved.

    Check out My post.

    Quick link wich helped me a lot: http://support.microsoft.com/kb/198116

    Regards.


    Thursday, August 18, 2011 10:07 AM