locked
Various issues installing/uninstalling Office 2013 App-V version RRS feed

  • Question

  • We have Office 2007 on our Win7 workstations and installing Office 2013 App-v on top of it is supported according to this MS article. However, we are coming across some issues (some related to office 2007 being on the machine some not) as below, and was wondering if anyone else is encountering them or has suggestions on how to address them. We having App-V 5.0 SP2 and Office 2013 is downloaded using ODT as described in this article.

    1. Installing Office 2013 64 bit App-V is causing excel 2007 add-ins to fail. 32 bit version does not however. Shouldn't App-V office be bubbled and not affecting other applications installed on the computer?

    2. Installing Office 2013 32 bit App-V takes over the file associations and causes office 2007 apps to perform a quick setup when launched the first time after the installation which brings back their association. Same questions as 1, shouldn't app-v version be isolated from the other applications? After the mini setup runs, when opening an xlsx doc, excel opens but without the document. 

    3. Uninstalling Office 2013 App-V package fails. It's detecting that a virtual process is still running, and checking which virtual processes are running on the machine, I see ucmapi.exe (lync 2010 process - application physically installed on the machine) and explorer.exe (this one doesn't appear all the time), both of which are non-virtual processes. After killing those processes the uninstallation still fails with error 0x87D0128F: The App-V sftmime command returns failure (even though the package does not show as in use nor any app-v virtual processes are running. No user or global pending switches ON in the package details either). The package shortcuts are removed however. Running the uninstallation one third time, the package shows as uninstalled, though the actual files (under c:\programdata\microsoft\appv directory) are still there. This issue happens regardless of whether office 2007 is installed or not.

    4. How can Office 2013 be activated from within the app-v package itself using the volume license key? Using the following attribute in configuration.xml doesnt seem to work: <Product ID="ProPlusVolume" PIDKEY="XXXXX-XXXXX-XXXXX-XXXXX-XXXXX"> 






    Tuesday, January 28, 2014 3:06 PM

Answers

All replies

  • Hello,

    1. Depends on why it fails. Without understanding the reason behind the failure we could of course guess. Perhaps you could investigate it a bit more and state why the add-in fails?

    2. If this only effects Word - see this article;

    http://jervisdabreo.com/thetechcorner/fix-for-microsoft-office-configuring-problem/

    If this effects something else;

    Most likely there is a conflict within something natively installed on the machine - such as a file type association?

    3. App-V 5.0 SP2 can handle the fact that a process is currently locking a package, it will simply process the changes later. However, SCCM 2012 R2 doesn't yet support that. And the generated MSIs doesn't handle it very well. The changes will still be processed at next reboot / logon

    See this article; http://www.applepie.se/app-v-5-0-sp2-and-pending-removal-update

    4. I would assume that you would use KMS / VAMT to activate Office with a volume edition.

    Isn't this the case?


    Nicke Källén | The Knack| Twitter: @Znackattack

    Tuesday, January 28, 2014 3:24 PM
  • We are looking into those issues, but my expectation was that the App-V package would be in a bubble, and not affecting other applications. It's downloaded using the MS ODT and not customized in any way except for the publishing of applications in SCCM (ex: excluding outlook, etc..). If we manually try to open the appv file in the sequencer to see what's in the package and modify the FTAs we get "devirtualizer has stopped working" error with the faulty module showing as kernelbase.dll in the eventlog. This is using the "Update" option. The "Edit" option works, but does not give access to the FTA tab. Tried installed .NET 4.5 on the sequences machine in case that makes a difference but it didn't

    As for the activation, we use the license key inside our package, and don't use KMS for office activation though that doesn't seem to work in App-V package using the PIDKEY XML attribute 



    • Edited by F.Dagher Tuesday, January 28, 2014 6:20 PM update
    Tuesday, January 28, 2014 6:01 PM
  • Hello,

    Office 2013 / 365 generated packages are never recommended to be opened with the sequencer, and only manipulated through the XML-based config-files. (this is indirectly mentioned under the feature of a office 2013 app-v package section in the links you posted)

    File Type associations, along with new many integration features will make changes so that the user can interact with the application seamlessly. These integration features impacts the system, and thereby any other application that is installed.(and this is mentioned under the microsoft office integration with windows in the link you posted earlier).

    I would suspect that you are using MAK as licensing method, you can use VAMT to manage that. See this link;

    http://www.microsoft.com/en-us/download/details.aspx?id=11936


    Nicke Källén | The Knack| Twitter: @Znackattack

    Tuesday, January 28, 2014 6:41 PM
  • We tried to open them hoping to better understand how they're affecting other applications and jumping out of their supposed "bubble". Issues with 2007 still occurring when 2013 appv is installed (with word, outlook, etc...).

    Yes we are using a MAK key for activating the traditional office package, and was hoping we can do the same in App-V without having to install any additional components.

    Wednesday, January 29, 2014 2:51 PM
  • Hello,

    The "bubble" issues are actually virtual extensions. If you want to - you can edit the deployment / user config-files and disable them. Of course - the useability goes down the more virtual extensions you disable.

    For example;

    You could remove all file type associations or shortcuts.

    As you haven't found a root cause for your issues - deciding what virtual extensions to disable is of course a guessing game on your end.

    See this tool to assist with the task;

    http://virtualengine.co.uk/vet/ace/

    See the TechNet documentation;

    http://technet.microsoft.com/en-us/library/jj713466.aspx

    If you don't want integration with the operating system - App-V 5 presents a more tedious task of disabling that as it enables a seamless user experience as the primary deployment option.

    VAMT is used to manage activation and not something you deploy onto end-Points. See this video, which discuss the topic of Office 2010.  Most likely - you can gain insight via this video to understand where to begin.

    http://blogs.technet.com/b/odsupport/archive/2010/08/06/managing-office-2010-activations-using-the-volume-activation-management-tool-vamt-2-0.aspx


    Nicke Källén | The Knack| Twitter: @Znackattack

    Wednesday, January 29, 2014 3:07 PM
  • Thanks for suggesting the tool, which is actually very nice! But for some reason it does not open office 2013 config XMLs (throws .NET errors - even after shrinking the default 4MB office XML file to a few KBs - incase size was the issue). So I went through the rigorous process of manually editing the user and machine XMLs using an XML editor, disabling COM, URLPROTOCOLS, File Associations, Objects and AppPaths and the package finally seems to be running indeed isolated (for a big price of course - and COM of course has to eventually be enabled but maybe set it "isolated" instead of "integration" mode). But even with the disabling of all those subsystems, when i run get-appvvirtualprocess I see explorer running. Is that a virtual process? why is it tied to office?

    Also, it's not clear to me the need nor the functionality of VAMT. The configuration xml documentation references PIDKEY as the attribute to use inside configuration.xml to insert the MAK there but for some reason the appv office package still launches not activated.

    By the way, have you worked on Office 2013 App-V package yourself? If so, how's your experience with it so far?

    Wednesday, February 5, 2014 4:43 PM
  • Hello,

    Explorer.exe is probably a SP2-feature, which at this time only can be disabled by removing it from the allowed processes to virtualize or disable the EnablceDynamicVirtualization entirely


    Nicke Källén | The Knack| Twitter: @Znackattack

    Thursday, February 6, 2014 6:49 AM
  • We seem to be experiencing similar file extension issues with Office 2013 App-V installed on a Win 7 client with a local installation of Office 2007. We are also seeing Office 2007 go into repair on launch and Office files failing to open when double clicking from explorer.  If for example Excel 2013 is open, then double clicking an xlsx will open the file in the existing instance of Excel 2013...otherwise it will fail to open.

    We are using standard install of Office 2013 created via ODT with no customisations applied in the configuration xml. Has anybody else seen this?

    Friday, February 7, 2014 12:28 PM
  • A new version of ODT has been released as of the 25th of February and is available for download here. If you create the package with this new revision of ODT is the behavior of your environment changed?

    Brandon
    MDOP on the Springboard Series on TechNet


    Tuesday, March 4, 2014 3:21 PM
    Moderator