usb not recognized Windows XP Media Center Edition w/ SP3


  • Re-posting from vista forums to SP3 forum:


    I  updated my PC with Windows XP Media Center Edition SP3 couple of weeks ago and now it looks like my USB Devices are not recognized anymore. I have checked the BIOS, checked the registry and they all seem to be fine. The USB devices that I am trying to use works on my other computer, it just seems to be on this one only. I am just checking if there are other folks running into same issue that I am having and how it was resolved. Any suggestions or input is really appreciated.


    It has been couple of months, I have installed chipset, updated bios, worked with Dell for 4 hours ( I paid almost $240 ), uninstalled SP3, installed new drivers, updated registery and still no luck. The only think I have not done is re-format the hard drive and I am not sure if that is the only solution. I really do not know what SP3 includes, I do not see any changes, the pc is actually slower than it used to be. The new fixes really sucks. Maybe MS should have someone program here and not outsource to some cheap country for Service Packs. This has been really a learning process for me, next time I am buying Apple OS or Linux.. I am done with MS and all the surprises. It is really disappointing.

    Tuesday, August 19, 2008 7:20 PM

All replies

  • It would be helpful to know:


    - the identity of the USB devices that have stopped working;

    - what anti-virus/anti-malware applications were active at the time SP3 was installed.


    Tuesday, August 19, 2008 9:57 PM



    I have tried four usb jump drives from lexar, memorax, toshiba and external hard drive from maxtor ( seagate ). Norton Corporate Edition is the anti-virus application active at the time SP3 was installed.


    Please note: the jump drives and the external hard drive used to work on this computer before and it still works on other computers.





    Wednesday, August 20, 2008 2:23 PM
  •  usbtrouble wrote:
    I have tried four usb jump drives from lexar, memorax, toshiba and external hard drive from maxtor ( seagate ).

    So, is it only storage devices that are affected?  What about USB peripherals which are not storage devices, e.g. mice or keyboards - do they work?

    Norton Corporate Edition is the anti-virus application active at the time SP3 was installed.

    That might be a problem.  Please download the fix from and run it in Safe Mode, as described in the KB article.  This has no ill-effects if the issue is not relevant.


    If the problem still exists, navigate to the hidden folder C:\Windows\Inf, locate the file usbstor.inf, right-click on usbstor.inf and choose "Install".  See what happens.


    You can use control panel "Folder Options", tab "View" to turn on the viewing of hidden folders.

    Wednesday, August 20, 2008 3:35 PM
  • Evening question are you using the latest driver available from your manufacter? Microsoft? Logitech? etc?


    Usb issues are an old subject. just pointing this out. Not being critical. Did you look at the connections at your computer port and the key drives you are attempting to use? any dirt? rubber eraser works miricales, or isopropel alchohol might also help out here.


    But more then likely your dot net 1.1 sp1 install from micrsoft downloads will help out a bit here.



    Next setting clearing out the softwaredistribution folder

    2) click on start, run, enter the letters "cmd"

    paste the following lines into your command box


    net stop wuauserv

    rmdir c:%windir%\SoftwareDistribution

    regsvr32 wups2.dll

    net start wuauserv





    3) Other problems can be cause by the lack of windows installer 4.5 being installed in Sp3


    4) Please disconnect all devices from USB ports until you are done with the next step. If you can use the PS/2 to the keyboard, and mouse. What we are going to do is reset all the USB stack settings so we do not have to re-install the devices you have.


    5) Click on start, control panel, folder options, niew and set the following

    move the click on do not show hidden files and folder to


    show hidden files and folders

    then click on hide protect operating system files (Recommended) and clear it.

    Any time it ask(s)s for (okay or yes) click on it.


    now click on my computer

    click on c:\windows

    now on the \inf folder


    6) Now right Click on the usb.inf and install this .inf.

    Just to save grief rebooting here will help out.

    7) Now reconnect the other usb devices one by on. It should recognize them now.  Give your system about 30 seconds before connecting each device.


    Some times devies are associated with only one port as mention in the last hypertext link listed below. Whats happening is unique serial numbers are not included by a manufacter. And placing it into another port can confuse Xp.



       I know there are alot of steps listed here but what we are doing is 1) fixing a problem with dot net 1.1 and making sure the proper services are available for Xp. 2) clearing the softwaredistribution folder used by Back ground intelligent transfer.(Version 2.5) and from Sp3. The extra step is in case thee is a left over Microsoft update problem(regsvr32). This is a cold boot problem left over by immediately installing Sp3. 3) Using the latest installer available from Microsoft. 4) Figuring out if any other device is causing a problem IE powered hub these can fail eventually. 5) Showing hiden files and folders 6) Clean installing the usb device driver and reseting the Usb stack. and re detecting the USB devices one by one. Any errors after connection will show up at this step. Please note any errors or any problems in the setupapi.log or the event viewer log.


    Trouibleshooting start up problems






    Thursday, August 21, 2008 10:42 AM
  • Robin,


    1. The only affected devices are storage device, keyboard, mouse, scanner etc works.

    2. Installed fix 953979.... did not work

    3. installed usbstor.inf ..... did not work


    Going to try next suggestion by keith


    Thanks for the information and your time. Please let me know if you would like me to try something else.





    Friday, August 22, 2008 5:17 AM
  • Keith,


    First of all, thanks for taking your time to respond to my issue. 



    used my keyboard on the usb port... works, bought new sony usb flash drive.. does not work including my other usb storage devices... all I get is "no drivers are installed for this device message".


    Bought ps/2 keyboard just to follow your steps. I did all the steps you mentioned and still my storage devices are not recognized.


    Is there any log files, event files that I can attach with this post so you can help.





    Friday, August 22, 2008 5:52 AM
  • I bought another usb keyboard and I am getting one new problem.  the driver installation loops, i.e., after finishing installing the driver, windows again prompts for new hardware found and the installation message box come out again and again. The keyboard is microsoft keyboard.








    Friday, August 22, 2008 7:36 PM