none
WDS2010 - PXE-E55 ProxyDHCP service did not reply to request on port 4011 RRS feed

  • Question

  • Hello - I have read through just about every thread with no luck. My imaging server was working perfectly fine up until a a couple days ago. Now, when I try to PXE boot I get the error "PXE-E55 ProxyDHCP service did not reply to request on port 4011". No configuration changes have been made to the server.

    I do not believe I am using DHCP because in the Multicast settings it specifies a range of IPs. I am not using the Auto-Add policy. It is set to Answer clients. I have stopped and started WDS services as well as reboot the server. Even disabled the firewall to see if that did anything. Not sure what else to try.

    Here is my configuration:

    CONFIGURATION INFORMATION FOR SERVER
    [-----------------------------------------------------------------------------]


    Server Authorization:
         Authorization state: Not Authorized

    Answer Policy:
         Answer clients: Yes
         Answer only known clients: No
         Response delay: 0 seconds

    Active Directory Use Policy:
         Preferred DC:
         Preferred GC:
         Prestage devices using MAC: No
         New computer naming policy: %61Username%#
         Domain search order: Global Catalog Only
         New computers join domain: Yes

    New Computer OU:
         OU type: Server Domain
         OU: CN=Computers,DC=domain,DC=rpcs,DC=org

    DHCP Configuration:
         DHCP service status: Not Installed
         DHCP option 60 configured: <Not Applicable>

    PXE Bind Policy:
         Use DHCP ports: Yes
         Rogue detection: Disabled
         RPC port: 5040

    Interface Bind Policy:
         Policy: Exclude Registered
         Registered interfaces:

    Boot Program Policy:
         Known client PXE prompt policy: OptIn
         New client PXE prompt policy: OptIn
         Allow N12 for new clients: <Not Applicable>
         Architecture discovery: Enabled
         Reset boot program: No
         Default boot programs:
             x86  - boot\x86\pxeboot.com
             x64  - boot\x64\pxeboot.com
             ia64 - boot\ia64\bootmgfw.efi
         Default N12 boot programs:
             x86  - boot\x86\pxeboot.n12
             x64  - boot\x64\pxeboot.n12
             ia64 - boot\ia64\bootmgfw.efi

    Banned GUIDs list:

    Boot Image Policy:
         Default image type for x64 clients: Both
         Default boot images:
             x86  -
             x64  -
             ia64 -

    WDS Client Policy:
         Logging policy:
             Enabled: No
             Logging level: Info

         Unattend policy:
             Enabled: No
             Command-line precedence: No
             WDS unattend files:
                 x86  -
                 x64  -
                 ia64 -

    OSChooser Policy:
         Menu name:

    Server Automatic Refresh Policy:
         Refresh period: 900 seconds

    BCD Refresh Policy:
         Enabled: No
         Refresh period: 60 minutes

    Auto-Add Policy:
         Policy: Disabled
         Poll interval: 10 seconds
         Max retry count: 2160 times
         Message to pending clients:
         Retention period:
             Approved devices: 30 days
             Other devices: 1 days
         Defaults for x86:
             Referral server:
             Boot program path:
             WDS client unattend file path:
             Boot image path:
             User: Domain Admins
             Join rights: Full
             Join domain: Yes
         Defaults for x64:
             Referral server:
             Boot program path:
             WDS client unattend file path:
             Boot image path:
             User: Domain Admins
             Join rights: Full
             Join domain: Yes
         Defaults for ia64:
             Referral server:
             Boot program path:
             WDS client unattend file path:
             Boot image path:
             User: Domain Admins
             Join rights: Full
             Join domain: Yes

    WDS PXE Providers:
         Name: VMMOSDProvider
         Path: C:\RemoteInstall\DCMgr\bin\OSDPxeProvider.dll
         Order: 1
         Critical: Yes

         Name: BINLSVC
         Path: C:\Windows\system32\binlsvc.dll
         Order: 2
         Critical: Yes

    WDS Transport Server Policy:
         IPv4 source: Range
             Start address: 239.0.0.1
             End address: 239.0.0.254
         IPv6 source: Range
             Start address: FF15::1
             End address: FF15::FF
         Start port: 64001
         End port: 65000
         Network profile: <Not Applicable>
         Multicast session policy:
             Slow client handling policy: None
             AutoDisconnect threshold: 256 KBps
             Multistream stream count: 2
             Slow client fallback: Yes


    [-----------------------------------------------------------------------------]

    Does everything look right? The previous systems administrator set this up so I am not totally familiar with it. Thanks in advance for any help you can provide!

    -Mike

    Friday, October 11, 2013 2:37 PM

Answers

  • Just wanted to let anyone that has seen this know I fixed it by building a new WDS server. I exported the boot images from the old WDS server and imported them into the new one. Everything works as it should now. The settings are pretty much the default. I assume something on the old WDS server was corrupt and not allowing it to PXE boot.

    Hope it helps anyone that has had a similar problem

    • Marked as answer by mikehen08 Wednesday, October 16, 2013 1:56 PM
    Wednesday, October 16, 2013 1:56 PM

All replies

  • Is your DHCP server and your WDS server on the same subnet?

    If not, you need a helper IP on the switches so the WDS server can get the forwarded clients from the DHCP server.

    Does the DHCP scope you are trying to boot from have the 066 and 067 options filled in correctly?

    Option 66= WDS server name or IP address
    Option 67= Boot file name

    http://technet.microsoft.com/en-us/library/cc732351(WS.10).aspx#BKMK3

    Friday, October 11, 2013 3:11 PM
  • Thanks for your reply!

    The DHCP role is not installed on the WDS server and they are on the same subnet. We have a flat network. I have DHCP running on my domain controllers. None of them have the scope options mentioned above and it was running fine before yesterday so I don't understand why it is not working now.

    In the WDS server properties, the Multicast tab has it set to "Use addresses from the following range:" instead of "Obtain IP address from the following range." Doesn't that mean it is NOT getting an IP through DHCP? But from the WDS server?

    I did not change any settings on the server so it makes no sense why this is not working now. I am totally confused!

    Thanks,

    Mike

    Friday, October 11, 2013 3:31 PM
  • Just wanted to let anyone that has seen this know I fixed it by building a new WDS server. I exported the boot images from the old WDS server and imported them into the new one. Everything works as it should now. The settings are pretty much the default. I assume something on the old WDS server was corrupt and not allowing it to PXE boot.

    Hope it helps anyone that has had a similar problem

    • Marked as answer by mikehen08 Wednesday, October 16, 2013 1:56 PM
    Wednesday, October 16, 2013 1:56 PM
  • I have had the same problem and just want to write my solution here to save other admins about 2 hours of investigation. After packet-sniffing the whole PXE process, I discovered that the WDS server just sends the proxyDHCP ACK messages very delayed. A delay between 9 and 15 seconds. It's too delayed so the PXE Client stops listening to the proxyDHCP ACKs and fails.

    Further investigating with the sniffer on the WDS Server shows me that there are immediately after the first proxyDHCP request a lot of NetBIOS lookups for the domain controller who never get answered (because the DC is on a different subnet). When the NetBIOS lookups end (hence timeout), the proxyDHCP ACK is sent. I have disabled NetBIOS lookups in ncpa.cpl --> Ethernet0 --> IPv4 --> Advanced --> WINS --> Disable NetBIOS over TCP/IP. After that the proxyDHCP ACKs are sent pretty immediately.

    I have had this issue on Windows Server 2019, but I guess this does not depend on the Server version

    Tuesday, September 3, 2019 2:31 PM