locked
XPS Viewer Crashes RRS feed

  • Question

  • When I try to copy text from a XPS document the viewer crashes. I have seen this behavior on multiple computers running Windows 10.

    Is there a fix?

    • Moved by Chenchen Li Friday, October 20, 2017 7:54 AM XPSViewer
    Thursday, October 19, 2017 6:44 PM

All replies

  • Hi L Phillips,

    I have the same issue as you.

    [environment]
      Windows 10 Pro 64-bit, version 1709, build 16299.19
      for testing, I created an XPS file via Excel: [Export]

    P.S.
       I've tried in Windows 7, using the same file.
       XPS viewer works fine (does not crash).

    Regards,

    Ashidacchi


    • Edited by Ashidacchi Friday, October 20, 2017 4:00 AM add comment
    Friday, October 20, 2017 3:52 AM
  • Hi L Phillips,

    This forum(General Office Development) is for development issues related to Office Object Model and your issue is more related to XPS Viewer produces, I would move the thread to Windows 10 Application Compatibility. Thanks for your understanding.

    Best Regards,

    Terry


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    Friday, October 20, 2017 7:27 AM
  • Thanks Terry. I appreciate it.
    Friday, October 20, 2017 8:44 PM
  • Hi, 

    How did you do this? Just right click the text and choose Copy. Where did you copy to?

    Please check event log and see the detailed applications logs related to this issue. I have the latest Windows update installed on my PC, and there is no such issue. 

    Let's test this issue in Clean boot Mode and Safe mode. 

    For further troubleshooting, please help to collect following dump file for our research:

    First enable app crash dump collection by copying following words into notepad, saving it as dump.reg and importing it:

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Windows Error Reporting\localdumps\xpsrchvw.exe]

    "DumpFolder"=hex(2):63,00,3a,00,5c,00,63,00,72,00,61,00,73,00,68,00,64,00,75,\

      00,6d,00,70,00,73,00,00,00

    "DumpCount"=dword:00000010

    "DumpType"=dword:00000001

    "CustomDumpFlags"=dword:00000000

    Then, open xps viewerto repro the issue. If crash issue appeared, please find the *.dump file under c:\.

    To further help you, please upload this file into Onedrive and shared the link here.

    Also, you can try to analyze dump by yourself if you would like to

    How to analyze app crash dump file:

    http://blogs.technet.com/b/askperf/archive/2007/05/29/basic-debugging-of-an-application-crash.aspx



    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, October 24, 2017 10:52 AM
  • I open the xps file in the MS viewer, select text, right click, and click copy. Then XPS crashes at this point. Here is the dump file.

    Dump File Link

    Tuesday, October 24, 2017 9:55 PM
  • Hi, 

    Let's try to run the sfc /scannow in CMD as administrator (System File Checker command) to replace a missing or corrupt copy of the msvcrt.dll file. This DLL file is provided by Microsoft in most versions of Windows, so the System File Checker tool should restore it.

    Analysis results: 

    Probably caused by : msvcrt.dll ( msvcrt!__CxxCallCatchBlock+190 )
    
    BUGCHECK_STR:  APPLICATION_FAULT
    
    STACK_TEXT:  
    000000e6`275ab6d0 00007ffe`44e99e08 KERNELBASE!RaiseException+0x68
    000000e6`275ab7b0 00007ffe`482837f0 msvcrt!__CxxCallCatchBlock+0x190
    000000e6`275ab890 00007ffe`483b9603 ntdll!RcFrameConsolidation+0x3
    000000e6`275af570 00007ff7`321a95df xpsrchvw!WindowsXHpp::WndProcImpl<Mainframe,Mainframe,MainframeBase,&Mainframe::WndProc,&MainframeBase::SetHWND>::CallClientProc+0x7f
    000000e6`275af5e0 00007ff7`321a8931 xpsrchvw!WindowsXHpp::WndProcImpl<Mainframe,Mainframe,MainframeBase,&Mainframe::WndProc,&MainframeBase::SetHWND>::Proc+0x11
    000000e6`275af620 00007ffe`45c6bc50 user32!UserCallWinProcCheckWow+0x280
    000000e6`275af780 00007ffe`45c6b5cf user32!DispatchMessageWorker+0x19f
    000000e6`275af800 00007ff7`321b817c xpsrchvw!MessagePumper::ProcessMessage+0x58
    000000e6`275af830 00007ff7`321b836c xpsrchvw!MessagePumper::GetMessagesAndNotifyOnIdle+0x1e8
    000000e6`275af8c0 00007ff7`32220fc6 xpsrchvw!RealMain+0x1796
    000000e6`275afd80 00007ff7`3222138c xpsrchvw!wWinMain+0x1f4
    000000e6`275afe00 00007ff7`323804a3 xpsrchvw!__wmainCRTStartup+0x1c7
    000000e6`275afec0 00007ffe`459e2774 kernel32!BaseThreadInitThunk+0x14
    000000e6`275afef0 00007ffe`48380d51 ntdll!RtlUserThreadStart+0x21
    


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, October 25, 2017 9:30 AM
  • @ Kate Li,

    I can always reproduce OP's issue.
    Does not it occur in your environment (Windows 10)?

    Ashidacchi

    Wednesday, October 25, 2017 9:34 AM
  • Yes, my computer works fine. Here's my build number:


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, October 25, 2017 10:08 AM
  • Hi Kate Li,

    I appreciate your confirmation and apologize my rude manner.
    I've just checked both with ver.1607(not 1703) and ver.1709 of Windows 10.

    When open an XPS file with XPS viewer and copy a part of text:
      a) Windows 10 ver.1607(not 1703): no problem, copied text can be pasted into notepad.
      b) Windows 10 ver.1709: crashed (see the below screenshots)
           
           
           
           

    ---
    Hi L Phillps,
      Please provide your Windows 10 version and build.

    I suspect Windows 10 version 1709 has some fault with XPS viewer.

    Regards.

    Ashidacchi


    • Edited by Ashidacchi Wednesday, October 25, 2017 11:31 PM typo (version)
    Wednesday, October 25, 2017 11:42 AM
  • Edition: Windows 10 Home 
    Version: 1703 
    OS Build: 15063.674
    Wednesday, October 25, 2017 2:28 PM
  • Here is an example of a file that fails when copying text. I had to move around in this document and copy three different sections before it failed.

    XPS Test File

    Wednesday, October 25, 2017 2:49 PM
  • Hi,

    This is my test result: I used an XPS file that you provided.


    XPS Viewer in my Windows 10 (version 1703, build 15063.674) worked fine.
    If you want my screenshots, please say so, I will provide them.
    And sorry, I have no idea about your issue at this moment.

    Regards,

    Ashidacchi

    Thursday, October 26, 2017 12:38 AM
  • Hi Philips, 

    This could be caused that the file has been blocked, please right click the file and choose Properties, check on Unblock and Apply. 

    The issue can be resolved. 


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, October 26, 2017 12:44 AM
  • Unblocking the file does not help. The file I provided does not always cause the issue. But if I use the outline to move around in the file and copy text, it will eventually fail.

    I have attached another xps document that fails no matter what. 

    Test File that Always Fails

    Thursday, October 26, 2017 2:24 AM
  • Hi L Phillips,

    Thank you for sharing a new (revised) XPS file.
    I can reproduce your issue, even if checkbox [Unblock] is checked.

    I'm wondering if XPS format is "must". Do you have any inevitability of XPS? Can't you use PDF format? 
    (I guess the original file is Word document.)

    And I would like to recommend to send a feedback to MS via Feedback Hub.
         

    Regard,

    Ashidacchi


    • Edited by Ashidacchi Thursday, October 26, 2017 3:13 AM
    Thursday, October 26, 2017 3:12 AM
  • Hi There, I am experiencing the same issue... Windows 10 1709 XPS viewer crashing when copy. Hopefully you can push out an update in between defending against BadRabbit etc :) Thanks - Mitch

    Thursday, October 26, 2017 10:49 AM
  • I will help to feedback this issue in our platform. 

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, October 27, 2017 8:03 AM
  • Open Control Panel > Programs and Features > Turn Windows Features on or off and uncheck XPS Viewer and click OK. Restart your PC and go back and apply a check to XPS Viewer and click OK. Let us know if this resolved your crashing issue.

    Carey Frisch

    Friday, October 27, 2017 8:23 AM
  • Hi Carey Frisch,

    Your approach is a nice alternative to XPS Viewer, i.e. XPS Reader.
    But I'm afraid it could not be a solution for OP's issue. It's up to OP's decision.

    Regards,

    Ashidacchi


    • Edited by Ashidacchi Friday, October 27, 2017 9:05 AM
    Friday, October 27, 2017 8:33 AM
  • Some Insight into Microsoft XPS Viewer

    "XPS is not meant to be used as a file format for intermediate data that still need to be changed. Like with PDF, you’re not supposed to edit XPS files"

    Perhaps saving your document as a PDF would be a viable solution. You can download the free version of Acrobat Read here.


    Carey Frisch

    Friday, October 27, 2017 9:59 AM
  • Nope, this idea doesn't resolve the issue. 

    Carey Frisch

    Friday, October 27, 2017 10:00 AM
  • Hi Carey,

    I am experiencing this issue on 4 separate computers.

    If I open the original Word document, copy its contents to a blank doc, save as XPS  and open in the Viewer then I can copy one selection of text without the XPS viewer crashing. If I copy a second selection in this same file it crashes.

    Not all XPS files cause the crash. Moreover, all the files I have tested have been saved from MS Word. If a document is small (just 3 or 4 pages) then likely it will not cause an issue. If the document has more than 50 pages, contains text, graphics, and the outline (navigation bar on the left side of the screen) is present then it will likely fail if you keep moving around (using the outline) and copying sections.

    The purpose of our using XPS is to provide information that a client can read, navigate, search easily and print but not change. XPS is perfect for that. I do not wish to use a PDF format because most users will open the file with Microsoft Edge. This means no navigation bar in the PDF document unless they download Acrobat Reader. That is not a viable alternative. As Mitch pointed out, I think it is obvious that there is an issue with the XPS viewer that needs to be addressed and corrected by Microsoft. I have used Feedback to inform Microsoft of the issue. In the meantime, I will warn my clients not to copy text from our XPS documents. 

    Best Wishes,
    Lance Phillips


    • Edited by L Phillips Friday, October 27, 2017 12:45 PM
    Friday, October 27, 2017 12:43 PM
  • I am also having this issue. Has there been any progress with this?
    Sunday, November 26, 2017 5:38 AM
  • When will the XPS Viewer copy crash get fixed!?!  Every Windows 10 FCU release on the planet is presently affected by this bug.  This bug was introduced with FCU, in case it's not obvious what to test on.

    This really should be a high priority item, since it affects basic functionality of a feature that has existed in the XPS Viewer since it was first released.

    Wednesday, December 6, 2017 3:24 PM
  • Once again Microsoft devs go silent on a critical bug.  Painful.
    Monday, December 18, 2017 10:06 PM
  • I have the same problem through the last two or three Windows 10 updates. 

    A good workaround that works for me is to use the Windows 10 built print > print to pdf, then copy from the pdf. 

    (Windows 10 Pro version 1709 build 16299.248 64 bit)

    Thursday, February 15, 2018 3:43 PM
  • Agree

    Same issue February 2018 - --> where is the fix from Microsoft........

    Friday, February 23, 2018 2:20 PM
  • Some issue on 1710 and 1803 (TP)

    upvote here: feedback-hub:?contextid=67&feedbackid=7fa4671c-a926-4daf-be89-700ae23716d3&form=1&src=1


    Грамотная постановка вопроса - уже 50% решения.
    SCCM User Group Russia на FaceBook и в Telegram

    Tuesday, March 27, 2018 2:07 PM