locked
Running text-to-speech on non-English Windows 7 Ultimate RRS feed

  • Question

  • I'm running a Hebrew Win7 Ultimate using an English GUI. One of my applications is an advanced MS Word speller with text-to-speech capabilities. This speller has a text-to-speech capabilities, but my dismay, all my efforts to activate text-to-speech on my version failed. I keep getting messages like:

    "Please install a text-to-speech that matches the current windows language" (seems like it asks for a Hebrew text-to-speech (non-existent), while I'm looking for an English text-to-speech)

    or

    "Speech recognition is not supported in the current language"

     

    Can anything be done?

    Saturday, October 9, 2010 6:32 PM

Answers

  • You may also refer the answer in the following thread.

    Speech recognition is not supported in the current language


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by Arthur Xie Friday, October 22, 2010 6:48 AM
    Tuesday, October 12, 2010 7:32 AM

All replies

  •  Check the setting at Control Panel > Region and Language > Keyboards and Languages > Change Keyboards... Is the right flavour of English the default input language?
     

    Noel
    Saturday, October 9, 2010 6:53 PM
  • Well, my settings are different (Format - Hebrew, Location - Israel). Still, I checked your suggestion, changed the format to English and location to United States.

    The change didn't make a difference. Text-to-speech is still unavailable.

    Monday, October 11, 2010 8:41 AM
  • That's not what I suggested. It's the Input language that matters (assuming that this is what Ghotit means by current Windows language), and you find that on the Change keyboards page under Keyboards and languages. (That is misleading, I know, because you don't have to change your keyboard layout to use a different input language.) You have a default input language and can select others using the Language Bar. If you always want your input language to be, say, English (US), then set that as the default regardless of your formats preferences and location. The Ghotit website makes no mention of language, so I have to assume that it's an American thing expecting input in English (US).


    Noel
    Monday, October 11, 2010 9:41 AM
  • You may also refer the answer in the following thread.

    Speech recognition is not supported in the current language


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by Arthur Xie Friday, October 22, 2010 6:48 AM
    Tuesday, October 12, 2010 7:32 AM
  • You won't believe it!! I got Hebrew Win7 (English language package) to work. All I had it do is the most bizzarre act, correct me if it is not.

    ALL ENHANCEMENTS MUST BE DISABLED

    All I did was to enter my default audio setting, open "Enhancements" and check the "Disable all enhancements".

    Why? Don't ask me. Still, it works.

    Sunday, October 24, 2010 7:17 PM