RDP screen goes black after successful remote login


  • I have a Windows 2008 Server that I have been connecting to once a month remotely to apply OS updates.  Often, I reboot that server and it uses auto-logon to login and run an application. 

    Today, I rebooted the server and when I try to connect with RDP, I get the login prompt and enter my credentials, I see a few expected messages fly by on the host OS (the last one I see is the word Welcome), but then the screen goes black.

    The apps on the server are running successfully because our applications can connect to them, we just can't logon to the desktop of the Windows Server 2008.

    I made no configuration changes (I NEVER do) other than to apply the latest Windows Server updates.

    I would prefer not to drive to the computers location, or try to coordinate a time to have the server hosting company assist me with troubleshooting; but is there anything else I can do?  Any ideas about what might cause this?

    Sunday, February 6, 2011 9:27 PM


  • Wow, today my RDP screen was still black.  So I tried CTRL-ALT-END.  Then I hit cancel, then I closed RDP.  Then I re-opened RDP and I had my desktop back! YAY!!!  I hope this solution works next time.
    Rob Kraft
    • Marked as answer by Rob Kraft Sunday, October 16, 2011 8:03 PM
    Sunday, October 16, 2011 8:03 PM

All replies

  • Hi,



    According to the description, I would like to confirm the following questions so that we can provide the exact suggestion:


    1.       Do all clients encounter this issue, such as Windows XP and 7?


    2.       Do all users encounter the same issue when logging on to the RDS server?


    3.       Have you found any related event log when this issue happens?


    4.       Have you tried to disable all firewalls to test whether this issue exist?





    Tuesday, February 8, 2011 9:13 AM
  • I'm sorry, I didn't have an email address assigned after the recent change in the Microsoft message boards so I did not receive notification of this reply.

    This problem also occurred logging directly onto the server.  So it was not an RDP problem.  When we logged on at the physical server, the screen went black after the welcome message displayed.  However, the mouse cursor was still visible and functional.  We had no option at that point except to perform a hard reboot.  When the server rebooted, everything worked normally.

    Rob Kraft
    • Marked as answer by Rob Kraft Thursday, February 10, 2011 1:52 PM
    • Unmarked as answer by Rob Kraft Wednesday, December 14, 2011 2:48 PM
    Thursday, February 10, 2011 1:52 PM
  • Hi Rob,



    Thanks for your update.


    Can you any new driver for the firmware of server? Also please try to run a clean boot to isolate any device drivers or programs that are loading at startup that may be causing a conflict.





    Friday, February 11, 2011 2:06 AM
  • I have the same problem. My system is windows server2008 enterprise without hyper-v, run as a guest OS on top of HYPER-V, I send ctrl+alt+del get to login screen, after I login as administrator, I get black screen except the mouse point on the screen, I can login as other account get normal screen, only administrator's account has this problem. After I rebooted the guest OS, problem dissappeared, I can login as administrator and get normal screen by using RDP. But after a two weeks today this problem is coming back again. There is no change to the system, don't know what is cauing the problem and how to prevent?


    Edward Hua



    Monday, July 18, 2011 6:50 PM
  • Bummer, I had the same problem occur again today.  Obviously this is a flaw in Windows Server 2008.  I hope Microsoft can fix it soon.
    Rob Kraft
    • Proposed as answer by phildorn Monday, February 2, 2015 1:05 PM
    • Unproposed as answer by Rob Kraft Monday, February 2, 2015 5:41 PM
    Saturday, October 15, 2011 7:24 PM
  • Wow, today my RDP screen was still black.  So I tried CTRL-ALT-END.  Then I hit cancel, then I closed RDP.  Then I re-opened RDP and I had my desktop back! YAY!!!  I hope this solution works next time.
    Rob Kraft
    • Marked as answer by Rob Kraft Sunday, October 16, 2011 8:03 PM
    Sunday, October 16, 2011 8:03 PM
  • Thanks for this Rob.  We are using SBS 2011 Standard.  RDP using a Windows 7 Pro client.  Worked like a charm. 

    Login Screen -> Credentials -> Welcome message -> Black Screen -> Ctrl-Alt-End, then Cancel -> Screen is back

    Not too concerned because no services are failing according to the logs. Just a small flaw.  But, in any event, it occurs in SBS 2011 as well.  



    • Proposed as answer by Sheshnath Yadaw Friday, January 6, 2012 1:54 PM
    • Unproposed as answer by Rob Kraft Monday, February 2, 2015 5:41 PM
    • Proposed as answer by Pash Cracken Wednesday, November 30, 2016 12:54 PM
    Wednesday, December 14, 2011 2:17 PM
  • If you happen to be running Windows on a Mac, you can use Ctrl-Alt-fn-<right arrow> to simulate Ctrl-Alt-End.
    Sunday, January 29, 2012 8:35 PM
  • I have a desktop running XP 64 bit and had the same problem. I hit CTRL-ALT-HOME and got the Start Menu and task bar. Right clicked on the task bar and picked show desktop. The desktop appeared and it functioned normally after that. I have to go through this sequence every time I RDP now.
    Tuesday, March 27, 2012 2:44 AM
  • Thanks Rob!!  I was about to Cry!!  Worked like a charm.
    Monday, April 2, 2012 3:15 AM
  • Thanks Rob!

    I had to finish some important stuff from home and the connection stayed blank after receiving the "Welcome" message - Ctrl-Alt-End did the trick!

    Now I can finish the upgrade, my boss will be happy tomorrow and I'll fetch some beer :)



    • Proposed as answer by hwbaldwin Sunday, September 10, 2017 12:30 AM
    Thursday, May 10, 2012 5:41 PM
  • Hello all,

    I am having the same issue - only CTRL-ALT-END doesn't do anything for me. CTRL-ALT-DEL only lets me open task manager on my client computer, not in the remote session - this is even when choosing the "Apply Windows key combinations" to be "On the remote computer".

    I'm running Windows 7, with dual screen (I've tried telling it to use only one monitor) - but I seem to be ok to remote in using my wifes username and password. It is only my own.

    When I press buttons (such as CTRL ALT DEL/END) I can hear a sound like the "Default Beep" sound in windows.

    Tried a lot of things. I do feel like it sits on the "Welcome" message for far longer than it normally does.

    As per another thread I found on the same issue, I tried connecting with a smaller resolution to reset the bitmap cache (as per

    In the same thread someone posted they had the problem occur because they left a game on their client computer in full-screen mode. I had a game open, tried closing that but no luck.

    I notice I have some updates pending install, will try installing those and restarting.

    *Update: Restart didn't work. Update was only a security update for Silverlight. Am now updating graphics drivers but I doubt this will work because as mentioned above I can log in fine using my wifes username/password. I may need to remote in with hers and restart the server.

    • Edited by DanPritch Friday, May 11, 2012 11:06 AM
    Friday, May 11, 2012 10:48 AM
  • Well I had this problem now a couple of times in the last week or two.

    Nothing specific running on the 2008 R2 server, I just disconnected and reconnected a couple of minutes later and I saw login was successful but then I got the black screen. Always had to restart the server remotely via shutdown /m \\server /r command.

    Just found this topic here with the CTRL+ALT+END trick and will it try next time but I also use an Android RDP client which does not support such keyscombination.

    I guess that this bug was caused by the patchday before the last one because it happened the first time for me two weeks ago and never had such a problem - also didnt change anything in the system or on the hardware.

    I found only this in the logs (german) 

    Protokollname: Application
    Quelle:        Desktop Window Manager
    Datum:         11.05.2012 18:00:47
    Ereignis-ID:   9009
    Ebene:         Informationen
    Benutzer:      Nicht zutreffend
    Computer:      Epyon
    Der Desktopfenster-Manager wurde mit dem Code (0x40010004) abgebrochen.
    <Event xmlns="">
        <Provider Name="Desktop Window Manager" />
        <EventID Qualifiers="16384">9009</EventID>
        <TimeCreated SystemTime="2012-05-11T16:00:47.000000000Z" />
        <Security />

    Desktop manager has been aborted.

    Protokollname: Application
    Quelle:        Microsoft-Windows-User Profiles Service
    Datum:         11.05.2012 18:00:48
    Ereignis-ID:   1530
    Ebene:         Warnung
    Benutzer:      SYSTEM
    Computer:      Epyon
    Es wurde festgestellt, dass Ihre Registrierungsdatei noch von anderen Anwendungen oder Diensten verwendet wird. Die Datei wird nun entladen. Die Anwendungen oder Dienste, die Ihre Registrierungsdatei anhalten, funktionieren anschließend u. U. nicht mehr ordnungsgemäß.  
     DETAIL - 
     5 user registry handles leaked from \Registry\User\S-1-5-21-408648707-2363534474-3651942527-500:
    Process 2320 (\Device\HarddiskVolume2\Windows\System32\winlogon.exe) has opened key \REGISTRY\USER\S-1-5-21-408648707-2363534474-3651942527-500
    Process 2320 (\Device\HarddiskVolume2\Windows\System32\winlogon.exe) has opened key \REGISTRY\USER\S-1-5-21-408648707-2363534474-3651942527-500\Software\Policies\Microsoft\Windows\CurrentVersion\Internet Settings
    Process 1660 (\Device\HarddiskVolume2\Windows\System32\svchost.exe) has opened key \REGISTRY\USER\S-1-5-21-408648707-2363534474-3651942527-500\Software\Policies\Microsoft\Windows\CurrentVersion\Internet Settings
    Process 2320 (\Device\HarddiskVolume2\Windows\System32\winlogon.exe) has opened key \REGISTRY\USER\S-1-5-21-408648707-2363534474-3651942527-500\Software\Microsoft\Windows\CurrentVersion\Internet Settings
    Process 1660 (\Device\HarddiskVolume2\Windows\System32\svchost.exe) has opened key \REGISTRY\USER\S-1-5-21-408648707-2363534474-3651942527-500\Software\Microsoft\Windows\CurrentVersion\Internet Settings
    <Event xmlns="">
        <Provider Name="Microsoft-Windows-User Profiles Service" Guid="{89B1E9F0-5AFF-44A6-9B44-0A07A7CE5845}" />
        <TimeCreated SystemTime="2012-05-11T16:00:48.515625000Z" />
        <Correlation ActivityID="{01D03A58-F800-0003-85C0-37DFD32ECD01}" />
        <Execution ProcessID="908" ThreadID="1104" />
        <Security UserID="S-1-5-18" />
      <EventData Name="EVENT_HIVE_LEAK">
        <Data Name="Detail">5 user registry handles leaked from \Registry\User\S-1-5-21-408648707-2363534474-3651942527-500:
    Process 2320 (\Device\HarddiskVolume2\Windows\System32\winlogon.exe) has opened key \REGISTRY\USER\S-1-5-21-408648707-2363534474-3651942527-500
    Process 2320 (\Device\HarddiskVolume2\Windows\System32\winlogon.exe) has opened key \REGISTRY\USER\S-1-5-21-408648707-2363534474-3651942527-500\Software\Policies\Microsoft\Windows\CurrentVersion\Internet Settings
    Process 1660 (\Device\HarddiskVolume2\Windows\System32\svchost.exe) has opened key \REGISTRY\USER\S-1-5-21-408648707-2363534474-3651942527-500\Software\Policies\Microsoft\Windows\CurrentVersion\Internet Settings
    Process 2320 (\Device\HarddiskVolume2\Windows\System32\winlogon.exe) has opened key \REGISTRY\USER\S-1-5-21-408648707-2363534474-3651942527-500\Software\Microsoft\Windows\CurrentVersion\Internet Settings
    Process 1660 (\Device\HarddiskVolume2\Windows\System32\svchost.exe) has opened key \REGISTRY\USER\S-1-5-21-408648707-2363534474-3651942527-500\Software\Microsoft\Windows\CurrentVersion\Internet Settings

    Protokollname: Application Quelle: Microsoft-Windows-User Profiles Service Datum: 11.05.2012 18:00:50 Ereignis-ID: 1532 Aufgabenkategorie:Keine Ebene: Informationen Schlüsselwörter: Benutzer: SYSTEM Computer: Epyon Beschreibung: Das Benutzerprofil wurde angehalten Ereignis-XML: <Event xmlns=""> <System> <Provider Name="Microsoft-Windows-User Profiles Service" Guid="{89B1E9F0-5AFF-44A6-9B44-0A07A7CE5845}" /> <EventID>1532</EventID> <Version>0</Version> <Level>4</Level> <Task>0</Task> <Opcode>0</Opcode> <Keywords>0x8000000000000000</Keywords> <TimeCreated SystemTime="2012-05-11T16:00:50.691406200Z" /> <EventRecordID>13071</EventRecordID> <Correlation /> <Execution ProcessID="908" ThreadID="932" /> <Channel>Application</Channel> <Computer>Epyon</Computer> <Security UserID="S-1-5-18" /> </System> <EventData> </EventData> </Event>

    Profile has been stopped!

    Protokollname: Application
    Quelle:        Microsoft-Windows-Winsrv
    Datum:         11.05.2012 18:00:46
    Ereignis-ID:   10002
    Ebene:         Informationen
    Benutzer:      EPYON\Administrator
    Computer:      Epyon
    Die folgende Anwendung wurde beendet, weil sie nicht reagiert hat: explorer.exe.
    <Event xmlns="">
        <Provider Name="Microsoft-Windows-Winsrv" Guid="{9D55B53D-449B-4824-A637-24F9D69AA02F}" />
        <TimeCreated SystemTime="2012-05-11T16:00:46.789062500Z" />
        <Correlation />
        <Execution ProcessID="688" ThreadID="2392" />
        <Security UserID="S-1-5-21-408648707-2363534474-3651942527-500" />
        <HungAppEvent xmlns:auto-ns2="" xmlns="">

    Force close of explorer.exe

    Client is Windows 7 64bit SP1 latest Windows updates

    Server is 2008 R2 SP1 also latest updates

    Bug happened first time about 2 weeks ago. Same bug on Android RDP client and Windows 7 client.

    I sometimes use hibernation on the client without closing the rdp connection, maybe that could have some impact after automatic reconnecting?

    Can I help with anything else?

    • Edited by Janus83 Friday, May 11, 2012 5:16 PM
    Friday, May 11, 2012 4:11 PM
  • Hi Rob, thanks for this update. It just works perfect
    Thursday, May 31, 2012 4:11 AM
  • Works like a charm, unless you're running an RDP inside another RDP.... then you're screwed. Nice one MS!

    Thursday, September 27, 2012 9:32 AM
  • It worked. Thanks for the solution.
    Saturday, October 6, 2012 4:42 PM
  • Hello

    Same problem with a new installation of SBS 2011 (based on SRV 2008/R2) with every client I try to connect.

    The problem is not specifiable in detail. 70% of time, the logon works normal.

    I found another solution that works in our case:
    Each time when we were inactive, the screensaver came after 10 minutes -> one keystroke or a mouse movement, and after the password input the desktop was here.
    It works also, when we set the screensaver to reactivation without password. So we set the timeout to one minute and no password for reactivation.

    That helps for the moment.

    • Proposed as answer by Bazvv Tuesday, October 17, 2017 8:41 AM
    • Unproposed as answer by Bazvv Tuesday, October 17, 2017 8:41 AM
    Thursday, October 11, 2012 1:52 PM
  • On Win7 conecting to XP Pro SP3 allowed enter user and password as normal then black screen.

    Tried changing screen resolution of rdp connection back down to 1024x768 and connected fine

    Changed back to full screen and back to black screen. 

    So try changing rdp connection screen resolution 

    Thursday, October 11, 2012 10:01 PM
  • Just type  CTRL+ALT+END, no CTRL+ALT+DEL.

    Best regards

    Ninja 4 IT

    • Proposed as answer by Eduard Vlasov Thursday, July 7, 2016 5:52 PM
    Tuesday, November 20, 2012 6:39 PM
  • Same problem and resolution here.

    Windows 7 client RDP-ing into Windows 2008 server.  Sometimes I get a black screen.

    Make sure you are in full screen mode and press Ctrl-Alt-End.

    You should get the screen that allows you to lock, logoff, etc.

    Press Cancel and everything is back to normal!


    Monday, December 3, 2012 5:40 PM
  • Thanks for this.  I was running into the same issue this morning and came across your post.  Just wanted to say thank you.
    Wednesday, December 26, 2012 6:02 PM
  • Thank you Rob!!!  CTRL-ALT-END did the trick!
    Friday, March 15, 2013 3:10 AM
  • I had the same poblem, thanks I tried your solution and  it worked.
    Wednesday, May 1, 2013 8:26 AM
  • Is it just me, or is the 'solution' not just a work around? It seems to me that there is a problem that has no solution. Thanks though for the work around, it does the trick but leaves the bug/error/problem as it is; a nuisance...

    Hope that MS has a real solution or maybe it is in an update. the hardware that I connect to is an HP ProBook 6570b Windows 7 Pro latest updates by MS in place.

    Friday, July 12, 2013 9:40 AM
  • I am having the same issue - only CTRL-ALT-END doesn't do anything for me. I tried full screen as well in 2 different client but just I can see the black screen . the server is the SBS 2011 and RDP clients are windows 7 .
    Thursday, August 1, 2013 1:42 AM
  • Thanks Rob. Worked for me. 

    Ran into this problem twice in the last week. Your solution worked like a charm. 

    Friday, August 2, 2013 8:31 PM
  • I had the same issue this morning.  Could not rdp to server.  I figured my profile was corrupt.  Got my co-worker to login to the server with another profile and delete my session in task manager. That worked for me.
    • Proposed as answer by DDeng Thursday, August 22, 2013 9:50 AM
    Wednesday, August 14, 2013 11:25 AM
  • I'm going to venture a guess and say that Windows has a bug in the way it deactivates screensavers.  I run a screen saver called "electric sheep" and I've noticed that sometimes with Windows 7, when I return to my computer, the screen saver's icon remains in the taskbar like it's still running -- this is not normal behavior for the screen saver at all, FYI.  It even locked up my entire desktop at one point, and when I finally ended the screen saver's process, everything sprang back to life on the desktop.  Pressing CTRL-ALT-END got rid of the black screen and brought up the CTRL-ALT-DEL screen as expected, and then pressing cancel returned me to my desktop.  There is clearly a bug somewhere.
    • Proposed as answer by B.Stromberg Tuesday, September 10, 2013 10:32 AM
    • Unproposed as answer by B.Stromberg Tuesday, September 10, 2013 10:32 AM
    Friday, August 30, 2013 7:17 PM
  • Found the (permanent) solution (for me) after 3 hours: Add the "Authenticated Users" and "Interactive Logon" to the local "Users" group and reboot. If the machine is a DC, do the same in the builtin\users Group - aaaand the screen is back wihtout black. Fixed all my Black-Logon-Machiens instantly.

    The bug sits somewhere between the twintoken acquirement and the uac-prompt; the interactive logon is able to take the twintoken but cannot display the uac-warning that it is doing so. Twintoken ... what a faceplam-idea. If I got $1 for every uac/twintoken/runas/runasfoo problem I've seen, I would buy the windows division. Twice.

    <small>Thanks to the guys from and Marc for putting it up as KB at</small>

    • Proposed as answer by B.Stromberg Tuesday, September 10, 2013 10:43 AM
    Tuesday, September 10, 2013 10:43 AM
  • Thanks for this.  It saved me this morning.
    Friday, September 13, 2013 4:05 PM
  • I am also getting a blank black screen after successful login to the rdc.

    Whereas,other users are properly able to connect to it.Only my screen blacks out.Whereas,till sometime back I was able to connect to it and the screen didn't go black.But,after sometime when I again logged in to the rdc this issue came up.Can someone please help?

    What could be the possible reason of this?

    Any help will be appreciated?

    Sunday, September 15, 2013 6:18 AM
  • Worked for me just now. Thanks!

    Tuesday, September 17, 2013 1:10 PM
  • The solution in KB 970879 requires rebooting into safe mode.  However, I don't have physical access to the server, making this impossible.  Is safe mode really required?  Is there any other way?
    • Proposed as answer by Milan Pavasovic Saturday, November 16, 2013 9:22 PM
    • Unproposed as answer by Milan Pavasovic Saturday, November 16, 2013 9:22 PM
    Tuesday, October 8, 2013 2:57 AM
  • KB970879 was not helpful.  The local Users group already had the Interactive and Authenticated Users account, and the problem still occurs.  The problem seemed to start happening after installing Microsoft Office Professional Plus 2013 on my Windows 7 system.

    Previously, when this problem occurred with Office 2003, I simply installed KB2661332 and the problem went away, but that hotfix doesn't seem to work with this version.

    • Proposed as answer by Milan Pavasovic Saturday, November 16, 2013 9:21 PM
    • Unproposed as answer by Milan Pavasovic Saturday, November 16, 2013 9:21 PM
    Wednesday, October 9, 2013 5:08 AM
  • Hello world:)

    VPN connection and than rdp to local ip solved this problem for me.

    I have simple setup. Windows 2008 R2 SP1 Standard. Server has DC, DNS, DHCP, File & Print, NPS & Acces services running.

    When I try to RDP connect from away location, i get prompted for my credentials and after successful login i sometimes see remote interface for some short time and in majority of times i get BLACK screen immediately.

    I tried updates and hotfixses suggested on forums online but nothing worked for me.

    Also CTRL+ALT+END does nothing for me.

    Only solution for the moment is this VPN bypass. No preoblems when i connect to VPN first and than rdp to which is lan IP of my server.

    Hope someone finds real solution for this, Milan:)

    Saturday, November 16, 2013 9:36 PM
  • I am having the same problem and have yet to find a permanent solution.  Here is the setup:

    Multiple Win 7 clients, fully patched

    Windows 2008 R2 Server with RDP enabled (no RD-session or terminal services licensing), fully patched

    RDP connection over public IP w/ non-standard RDP port

    I have found a temporary (band-aide) fix for the issue.  If I log in via standard RPD session (start > mstsc) and I receive the black screen I switch to RDP admin session (start > mstsc /admin) and the screen comes up.  If I had most recently used RDP admin session I switch back to standard RDP session and the screen comes up.  Still very annoying since I have to switch back and forth between the two session types.  Hope this helps those who the ctrl + alt + end command doesn't work for.

    I am also experimenting with disabling bitmap caching on the client connection by opening the RDP connection with notepad and adding the following below value.  I haven't verified that this works 100% of the time.


    • Edited by mnispel Saturday, November 23, 2013 8:00 PM
    Saturday, November 23, 2013 7:55 PM
  • I had the same issue - RDP to another RDP gave me black screen.

    Enable sending all key combinations to the RDP session on the machine from where you are connecting to the target machine.

    Inside target machine press CTRL+SHIFT+Esc and that would pop up Task Manager.

    Click New Task and type "explorer.exe", hit Enter and there you go!

    Thursday, November 28, 2013 6:20 PM
  • life saver!
    Sunday, December 1, 2013 11:50 PM
  • Hi,


    According to the description, I would like to confirm the following questions so that we can provide the exact suggestion:


    1.       Do all clients encounter this issue, such as Windows XP and 7?


    2.       Do all users encounter the same issue when logging on to the RDS server?


    3.       Have you found any related event log when this issue happens?


    4.       Have you tried to disable all firewalls to test whether this issue exist?


    Hi, I'm also experiencing the same issue (black screen on rdp connections), but with more issues:

    1. Black screen appears when i have an active rdp connection to remote Win7 64bit SP1 PC (over LAN) AFTER i have minimized FULL_SCREEN RDP session window, wait 3-5-10 seconds (the longer - the better to reproduce) and restore the window - it's black. Pressing Ctrl-Alt-End brings
    "Windows security" screen, hitting esc and get desktop back.

    2. If I change from full window to none-full, I'm getting "previous bitmap" screen, not actual, so Ctrl-Alt-End is the only way to resolve - again.

    3. Issue observed on hi-end video cards (both ATI and NVidia) with latest drivers on host (PC with session on, not client), with Intel GMA everything is ok. So I suppose there are problems with bitmap caching (turning it off on client doesn't help).

    The issue is observed under following rdp client settings:

    Remote Desktop Connection
    Shell Version 6.3.9600
    Control Version 6.3.9600
    Network Level Authentication supported.
    Remote Desktop Protocol 8.1 supported.

    Update: changing color depth to 24bit (or less) in rdp file solves the problem, but this is a partial (unwanted) solution.

    Update2: this issue is due to (now suspended by Microsoft) update 2830477: Update for RemoteApp and Desktop Connections feature is available for Windows. Here is more info: Remote Desktop Services Blog.Uninstalling this update resolves all issues. Can be done in WSUS by declining this update.

    As commented by MS in blog:


    Update on November 18, 2013: We received feedback from some of you that with the RDP 8.1 update package installed, some users are unable to use their redirected smart cards in remote sessions. We have temporarily removed the update package from Windows Update and the Download Center while we investigate the problem and update the package with a fix if necessary.  We’ll post an update on this blog as soon as we have a timeline for republishing the update package.

    • Edited by D F Saturday, January 18, 2014 11:09 AM
    Tuesday, December 10, 2013 9:54 PM
  • This simple (yet so elegant) work around made my day. :)

    Thank you.

    Thursday, December 19, 2013 11:50 PM
  • What was the workaround? Please share at your convenience. Thanks.
    Thursday, January 9, 2014 4:45 PM
  • Thank you very much "Rob Kraft" for very simple solution. This has worked for me. 
    Thursday, January 16, 2014 9:38 AM
  • Am having the same problem also with my VDI deployment.  After logging in through the gateway when I get redirected to my VM it'll give me a black screen.  If I sit and wait about 90 seconds it eventually comes up.  That part that bothers me is that it wasn't doing this when I first set it up.

    Does this sound like the same issue or something unrelated with similar symptoms?

    Friday, January 17, 2014 4:07 PM
  • It is not the same issue. The issue I had would not resolve itself even after ten minutes; and the keystroke would immediately bring up the screen.

    Rob Kraft

    Friday, January 17, 2014 5:16 PM
  • Hi. Just deactivate Aero-Theme on Client-PC and in the RDP-Session. Take "Windows Basic" or "Windows Classic".
    Monday, January 20, 2014 11:35 AM
  • This definitely worked for me just now. Wonder why that happens.
    Tuesday, February 11, 2014 1:27 PM
  • This solution does not work for me. I have 2 terminal 2008 r2 patched. But the kb2830477 is not on both systems.

    De solution Rob explained also does not work. I s till have black screens and a user who is logging in and the keyboard goes crazy.

    Rdp connection is adapted to everything is told here. but still no solution.

    Ik installed a complete new terminal and again same issue.

    Al 3 systems are virtual  (esx5.1)

    I still think this is a bug.

    Friday, February 14, 2014 10:29 AM
  • I tried this found on MS KB (which one i forgot...) and it works for me only that the aero theme is disabled the rest looks much better (vdo viewing and other experiences)


    To enable RDP 8.0 on a remote computer that's running Windows 7 SP1, follow these steps:

    Note The following instructions are applicable only to remote computers that are running Windows 7 SP1. 1.Install the appropriate version of the update package by running the Windows6.1-KB2592687 update file.
    2.Restart the computer.
    3.Open the Local Group Policy Editor. gpedit.msc
    4. Enable the Remote Desktop Protocol policy. The setting for this policy is under the following node:
    Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Remote Session Environment

    5. If the UDP functionality is required, enable the RDP Transport policy, and then set the value to Use both TCP and UDP. The setting for
    the RDP Transport policy is under the following node:
    Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Connections
    Note Configuring the RDP Transport policy also lets the firewall allow UDP port 3389.
    6.Restart the computer.

    hope this helps for those who just installed ALL updates from windows update site... :)

    Monday, February 17, 2014 6:21 PM
  • Thank you, thank you, THANK YOU!  Hours of pouring over Google & Bing searches did not produce results.  Your suggestion did. It saved me.
    Friday, March 14, 2014 1:26 AM
  • thanks, worked for me END!


    Monday, March 17, 2014 4:58 PM
  • I just had an RDP session that worked fine when I was in the office, but was black when I got home.  Closing the connection and reconnecting didn't help.  Sometimes when I tried to connect, I would get disconnected with a protocol error.

    I was able to connect to other existing sessions on the machine, and start new sessions as new users (I have access to 4 different accounts on that machine between domain and local), but that one session would stay black no matter what I did.  Now I'm in the office, so I logged on via the console, and got the same thing.  I tried Ctrl+Alt+End, and it displayed the screen via RDP but not via the console, cancelling didn't help.

    Finally, I connected as a local admin, and killed dwm.exe and explorer.exe for that session.  I then reconnected, and the screen came back.  I also found that there was a "Restart Now" dialog from Windows Update open on the desktop.  The session was as a non-admin, and UAC is enabled on the machine, so maybe there was a bad interaction with a UAC dialog and RDP while the connection was inactive.

    Windows 7 x64 Ultimate connecting to Windows Server 2008.

    Tuesday, April 1, 2014 2:29 PM
  • I have the same problem when I was connecting to one of our servers using RDP, then suddenly it went black, as in PLAIN BLACK after the "Welcome" message.

    I tried the CTRL+ALT+END and it worked!

    Thanks a lot! :)

    Thursday, April 3, 2014 7:24 AM
  • Hello every one,

    i was facing the same issue, after login to my remote Server (Windows Server 2003) I was getting a black screen and no other screens are visible. After applying the given settings as in above figure 2 i.e. Experience tab, I got my Desktop visible.

    Thanks...100% working....

    I Applied below settings
    Desktop Composition - Checked
    Visual Styles - Checked
    Persistent bitmap caching - Checked
    Reconnect if the connection is dropped - Checked

    Wednesday, April 9, 2014 9:09 PM
  • Thanks alot Rob. Worked like a charm. This saved my day :)
    Thursday, April 10, 2014 9:09 AM
  • Worked like a charm!  Thanks. 
    Thursday, May 15, 2014 10:59 PM
  • Hey..!! I had the same issue with my server 2008 Remote log in. then i tried the above mentioned solution...It worked out........!!!!!!!!!!!!!!!!!111

    Thanks....!!!!!!!! for sharing the tread here.....

    Friday, May 23, 2014 4:04 AM
  • Thanks.. it worked for Windows 7 too.. I was using my system from another machine.
    Friday, June 6, 2014 3:56 AM
  • This solution worked for me.  Just hit CTL+ALT+END, then choose task manager, it will bring back your screen.
    Friday, June 6, 2014 11:18 PM
  •  Yes I have also tried CTRL-ALT-END.  Then I hit cancel, then I closed RDP.  Then I re-opened RDP and I had my desktop back!
    Friday, June 20, 2014 8:22 AM
  • You are a life saver Rob !! Thanks. Saved me from going to work since I was getting black screen whenever I RDP'd from home to my work PC


    Monday, June 23, 2014 10:34 PM
  • Just type  CTRL+ALT+END, no CTRL+ALT+DEL.

    Best regards

    Ninja 4 IT

    CTRL+ALT+END just worked perfectly.
    Tuesday, June 24, 2014 1:40 AM
  • I had the same problem and your trick helped me resolve it. But I used CTRL+ALT+DELETE instead.
    Thursday, July 31, 2014 8:09 PM
  • i tried it today and it worked like a charm. thanks a lot. 
    • Edited by zeboalfgang Monday, September 15, 2014 2:15 PM
    Monday, September 15, 2014 2:15 PM
  • Hello,

    CTRL-ALT-END not working.

    this solution works on Windows7 SP1 client / W2008 R2 STD server RDP :


    Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Connections
    activate BOTH TCP AND UDP !

     .Restart the computer.

    thanks a lot !

    Tuesday, November 18, 2014 10:09 AM
  • Same problem today 3 years later windows 8.1 rdp to windows 7. Solution worked a treat, thank you.
    Wednesday, December 3, 2014 12:32 AM
  • Works for me.
    Tuesday, December 16, 2014 9:13 AM
  • Rob:

    More than 3 years later and this is what I needed to find! Thanks so much.


    Saturday, December 20, 2014 2:12 AM
  • Thank you..the combination of CTRL-ALT-END did work..Awesome
    Thursday, January 15, 2015 1:51 AM
  • My case is, on Windows Server 2012 R2, after installing FileZilla Server, MyPC Backup and WSE_Vosteran was brought in as unwanted, black screen appeared when remote connected to it. By using Ctrl_Alt_End, I was able  to terminate the running processes one-by-one, when it came to "Run Once Wrapper", boom, the remote desktop was shown. After removing those unwanted, reboot, "Run One Wrapper" disappeared from Task Manager, and remote connection was back on working charmingly!

    • Edited by NickWink Tuesday, January 27, 2015 5:25 PM
    Tuesday, January 27, 2015 5:22 PM
  • Rob,

    Thanks for your tip. I tried it and it worked perfectly. You're a genius.

    Thanks once again

    Islam Ejaz

    Tuesday, February 10, 2015 9:50 AM
  • Thanks, that helped me out as well. Had this problem on a small business server 2011 (SP1)
    Tuesday, March 24, 2015 8:30 AM
  • Thanks Rob!   CTRL-ALT-END was the trick!

    Rita V.

    Wednesday, April 15, 2015 3:11 AM
  • Thanks Rob

    That works like a charm!


    Thursday, April 16, 2015 3:27 PM
  • CRTRL ALT END worked, thank you so much , what this is doing in background?
    Thursday, June 25, 2015 7:56 AM
  • Awesome!!!! Thanks for this post!

    You should never, never doubt what nobody is sure about. -Willy Wonka

    Wednesday, July 15, 2015 4:50 PM
  • Yes its working thanks Rob....

    • Edited by SunilIGX Thursday, July 23, 2015 3:32 AM
    Thursday, July 23, 2015 3:32 AM
  • CRTRL ALT END worked, thank you so much
    Tuesday, August 4, 2015 4:06 AM
  • Perfect! worked for me :)
    Wednesday, August 5, 2015 10:16 PM
  • Its really works . Thanks a lot.
    Friday, December 4, 2015 6:46 AM
  • Hi Rob,

    I recently used your answer to solve the same issue. I believe the cause is 'explorer.exe' failing / dying, as i was able to CTRL + ALT + END, run Task Manager and then run Explorer. Hope this helps in the future

    Sunday, December 6, 2015 11:03 PM
  • UAC. UAC is the problem. That bullshit, yes. In my case the first login was successful and working, but any other consecutive attempt was not working. I was getting either a flickering(unusable) or completely black screen, on RDP or directly on the console of the 2012 R2 server. In the Application eventlogs there were lots of errors with eventID 1000(Faulting application name: explorer.exe, version: 6.3.9600.17415, time stamp: 0x54503a3a
    Faulting module name: unknown).
     UAC was disabled. I just enabled it, reboot the server, and then I was able to log in with multiple working sessions. I even disabled back UAC and reboot the server again and things were working normally. Beware of UAC :)
    Thursday, December 24, 2015 11:30 AM
  • Very works!!!
    Thursday, December 24, 2015 1:42 PM
  • Posting this in case you have spent countless hours such as myself exhausting every search engine answer on fixing the black screen stuck at a remote desktop connection to Windows 10 Pro (but applicable to any other operating system such as Windows 2003 Server, Windows 2008, or Windows 7

    Ensure you have all security operations disabled. At this point, I am sure you have tried disabling your router firewall, windows firewall, software anti-virus, etc. It turned out I had device installation restrictions enabled. In the group policy editor (start -> run -> gpedit.msc -> Computer Configuration -> Administrative Templates -> System -> Device Installation -> ensure you DISABLE all the "Prevent installation of devices") or anything else you may have previously enabled to lockdown your work environment. Upon disabling these system security settings, I was able to complete a remote desktop connection and it apparently installed the necessary drivers/devices so I could then re-enable these settings and resume having my machine locked down with future remote desktop connections working flawless.

    Good luck

    • Proposed as answer by Priscila Silva Thursday, January 11, 2018 11:57 AM
    Tuesday, February 2, 2016 11:19 AM
  • I logged in to a black screen this morning on Windows Server 2012 and was able to recover by changing the display resolution on RDP settings to less than full screen.  Logged back out, changed resolution back to full screen and all is good now.
    Friday, February 26, 2016 2:14 PM
  • Yes CTRL-ALT-END cancel works for my RDP black screen! Thanks for your post!!
    Friday, March 11, 2016 1:41 AM
  • Hi,

    I have the same problem,i have restart RDP services of the  system which u want to take RDP,now the problem i resolve

    Tuesday, March 15, 2016 5:08 AM
  • it worked like a charm!
    Tuesday, March 15, 2016 3:05 PM
  • thanks, I got quick resolution.
    Thursday, March 17, 2016 4:03 AM
  • ! free disk space !

    My rule is to make sure that there is enough free disk space on the drives to handle a page file up to 1.5 times the amount of memory and an additional 10% of the total drive size in free space

    Adjusting the paging file did the trick for me

    Right click on Computer, Select Properties, Click on Advanced system settings

    select the Advanced tab, under performance click settings, select the Advanced tab, 

    Click Change under Virtual memory, 

    Either select, Automatically manage paging file size for all drives

    or, adjust individual drive settings.

    Wednesday, April 27, 2016 4:24 AM
  • Cancel did not work for me, but I did log of using CTRL-ALT-END and then logged in back. Worked! Thanks!


    Wednesday, May 4, 2016 1:33 PM
  • Same issue here. Opted for your CTRL-ALT-END recommendation and was given the option to Log Off, Shut Down, or Launch Task Manager. Opted for Log Off as a quick test and that ultimately solved the issue. My suspicion is that the connection had been open and closed, but never actually logged off, so when updates were running on the server, it compromised that connection in some way. Once I logged off and it completed its updates to the user profile, etc, I was able to log in with success. 

    Thanks Rob!

    Wednesday, May 18, 2016 3:12 PM
  • Nice!! Thanks man! save me some hassles 
    Friday, June 24, 2016 7:16 AM
  • Hi Rob Kraft,

    Thanks for writing about CTRL-ALT-END,

    I tried above mentioned and today my RDP screen which was black is okay now and working normal.

    Thanks indeed dude.


    Sunday, September 4, 2016 6:33 AM
  • Thanks. Just the CRTL-ALT-END helped me after starting a Visual Studio update before leaving work, then VPN back to check on it.
    Saturday, October 8, 2016 2:59 AM
  • Thanks, I had to connect my work PC for a very important deploy on Pod, just couldn't believe seeing the screen blank, this saved me going to work at this time of the evening :)
    Tuesday, October 25, 2016 5:28 PM
  • Thank you~ 

    CTRL-AlT-End and Arrow down, Enter worked for me ~ cause I could see only black screen

    I felt like blind.

    Monday, November 21, 2016 2:19 AM
  • Wow, today my RDP screen was still black.  So I tried CTRL-ALT-END.  Then I hit cancel, then I closed RDP.  Then I re-opened RDP and I had my desktop back! YAY!!!  I hope this solution works next time.
    Rob Kraft
    Thanks the solution worked perfectly. Save my life. Earlier i had to reboot the target machine. But this solution is awesome. Thanks man
    Thursday, December 15, 2016 9:15 AM
  • I know this thread was started a few YEARS ago, but I wanted to let someone know that it still fixed my problem - and I have Windows 10!  The IT dept at the company I work for is using me as their tester for Windows 10 (how it works on their servers, handles all of the Remote Desktops we have to use on a daily basis, etc), and I have to say that the black screen upon successful login of this RD was a first for me... Of course instead of me asking IT to fix it, I googled this in the forums, and found this thread -- tried the Control+Alt+End from the black screen, and it allowed me to logout and then when I opened it back up again, it WORKED!!! 

    So 5 years later, and on way newer Microsoft operating system - this little gem of a trick still worked!!!! :) thanks- I was FREAKING.

    Wednesday, December 28, 2016 9:18 PM
  • We've gotten a lot of mileage out of this post, I'm glad it is still useful.  This is my one great contribution to the world! :)  Thanks for letting us know it works for Windows 10 also!

    Rob Kraft

    Rob Kraft

    Thursday, December 29, 2016 12:24 AM
  • Thank you verymuch. Its working to me..!!
    Monday, January 30, 2017 9:49 AM
  • Edit Remote desktop connection properties. 

    Go to Experience tab , then select "Low-speed broadband (256 kbps - 2 Mbps) from the dropdown list and save.

    Friday, March 17, 2017 5:38 AM
  • Oh, thank you so much! It just saved me.
    Saturday, March 18, 2017 11:52 AM
  • I started having black screen for few weeks until I found the problem. Users were telling me that their screen has gone blank after they came back from lunch (inactivity). At times I could reset the session but as time progressed I had to restart the terminal server and the need for solution became more urgent.

    So I pressed CTRL+ALT+DEL on the server, selected "All user" I started closing all the applications running under the "user name" until I found one process which will not close.

    Checked the application it relates to and uninstalled the application.

    It seems to have taken care of this problem.

    Thursday, June 29, 2017 12:49 PM
  • Can anybody help me out? i have a windows 2008 i login and it says .....The task you are trying to do can't be completed because Remote Desktop Services is currently busy. Please try again in a few minutes. Other users should still be able to log on... i have tired to CTRL-ALT-END but it's still not working, please i need help

    Tuesday, August 8, 2017 10:40 PM
  • Enabling UAC on Server 2012 worked for me :) 

    Cheers Ticoloco

    Monday, September 4, 2017 10:01 AM
  • Solution for Windows 10:


    2 Select Windows Explorer under "Processes" tabl

    3. Click "Restart"


    • Proposed as answer by Zeek Friday, October 12, 2018 6:03 PM
    Monday, October 23, 2017 5:13 PM
  • Thanks

    For me Control Alt End did the trick.

    Friday, November 17, 2017 1:48 PM
  • CTRL-ALT-END did not show up any thing for me. The screen was black and unresponsive. I tried to connected with RDPManger from iOS and the same black screen. But both sessions where trying to connect not kicking any one off.

    I just waited... about 5 minutes. All of a sudden both devices started to login, then one kicked the other off. All started working again without pressing anything.

    MCTS,MCPD - Piotr Kula

    Tuesday, November 21, 2017 11:25 AM
  • If the machine is joined to domain, use GPMC on domain controller to change group policy if it is a workgroup machine, use local group policy.

    Disable UDP 3389 for RDP session and the black screen issue should be resolved. Keep only TCP enabled.

    Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host




    Thursday, November 23, 2017 2:51 PM
  • Wow, today my RDP screen was still black.  So I tried CTRL-ALT-END.  Then I hit cancel, then I closed RDP.  Then I re-opened RDP and I had my desktop back! YAY!!!  I hope this solution works next time.
    Rob Kraft
    I'am just waiting 5 minutes - and Desktop Appeared
    Wednesday, November 29, 2017 10:59 PM
  • Wow, today my RDP screen was still black.  So I tried CTRL-ALT-END.  Then I hit cancel, then I closed RDP.  Then I re-opened RDP and I had my desktop back! YAY!!!  I hope this solution works next time.

    Rob Kraft

    I'am just waiting 5 minutes - and Desktop Appeared

    please press control alt end and select task manager. once the task manager opens select file and run and there type explorer. 

    It will open out the screen

    Thursday, January 18, 2018 2:27 PM
  • OMG! Thank you!
    Thursday, March 8, 2018 1:14 AM
  • OMG>>>>>>>>Thank you Thank you Thank you.   This still works!   
    Saturday, July 21, 2018 12:13 PM
  • Thanks Rob. CTRL-ALT-END caused  a menu to be displayed (on Win7 logging in from Win10), I select the "Lock" option and then just logged in again (just entered my password).  Benefit: I didn't need to reconnect or close my current session :)

    In the past I would have got somebody at the other end to power-cycle the PC, grim :(  Surprised Microsoft have not fixed this, it has been an occasional problem for quite some time.

    • Proposed as answer by Zeek Friday, October 12, 2018 6:00 PM
    Monday, July 23, 2018 5:48 AM
  • Thanks, Rob... it worked...Cheers
    Tuesday, September 4, 2018 8:05 AM
  • Thank you! It also helped me see my screen :)
    Saturday, September 22, 2018 2:08 AM
  • If somebody is logged in to server with remote access. Then ask him to log off the user using remote desktop manager. Its because of some long login session.
    Tuesday, September 25, 2018 6:35 AM
  • PS C:\> invoke-command -computer BigSlobBobzServer01 {Net localgroup Users Interactive /add}
    The command completed successfully.

    PS C:\> invoke-command -computer BigSlobBobzServer01 {Net localgroup Users “Authenticated Users” /add}
    The command completed successfully.

    Friday, October 12, 2018 5:49 PM