locked
All Users including Site collection administrator has only read access to one site collection, but not the other RRS feed

  • Question

  • We have a sharepoint WSS 3.0 environment with a single application and two site collections ( I hope i get the terms rights, since it is a german environment). Both are using the same database and the same administration accounts

    In one collection we now have the problem, that all users, including the primary and secondary site collection administrators, have only read-access to all files, though sharepoint user rights are shown as "Full control".

    A restore failed because of missing access rights.

    I already checked contingents and locks, none are set. Database sizes according to stsadm enumsites are about 600 MB for the blocked one, 50 for the other.

    In the other site collection, all user rights are working correctly as configured in Sharepoint, therefore I don't think the problem is on the SQL Server side.

    Our problem is

    1. what can we do to restore user rights and be able continue working

    2. what is the reason for this behavior and how can we avoid it

    Thanks for any suggestion

    Frank

    Wednesday, September 21, 2011 4:06 PM

Answers

  • Hi Frank,

    I know you said you already checked locks but here is what I would suggest to check in your situation:

    1. Check whehter this particular site collection has a Quota set (CA > Application Mgt > Site collection quotas and locks)?

    2. Also try setting the setsitelock to none

    3. On SQL is there any disk space issue?

    Hope this helps!


    BlueSky2010
    • Marked as answer by Pengyu Zhao Thursday, September 29, 2011 2:16 AM
    Wednesday, September 21, 2011 9:12 PM
  • Thanks Bluesky2010, the check no. 2 solved the problem - sitelock was set to readonly.

    Can this be due to a failed backup?

    Unfortunately I can't check the backuphistory myself since the backups are made by the IT Administrators.

    Frank

    • Marked as answer by Pengyu Zhao Thursday, September 29, 2011 2:16 AM
    Friday, September 23, 2011 12:29 PM

All replies

  • Hi Frank,

    I know you said you already checked locks but here is what I would suggest to check in your situation:

    1. Check whehter this particular site collection has a Quota set (CA > Application Mgt > Site collection quotas and locks)?

    2. Also try setting the setsitelock to none

    3. On SQL is there any disk space issue?

    Hope this helps!


    BlueSky2010
    • Marked as answer by Pengyu Zhao Thursday, September 29, 2011 2:16 AM
    Wednesday, September 21, 2011 9:12 PM
  • Thanks Bluesky2010, the check no. 2 solved the problem - sitelock was set to readonly.

    Can this be due to a failed backup?

    Unfortunately I can't check the backuphistory myself since the backups are made by the IT Administrators.

    Frank

    • Marked as answer by Pengyu Zhao Thursday, September 29, 2011 2:16 AM
    Friday, September 23, 2011 12:29 PM