Windows Server 2012 R2 IPv6 managedaddress=disabled fail


  • Hello,

    on a static IPv6 interface I disable the options routerdiscovery and managedaddress to get only the configured static IPv6 address on the interface. With Server 2012 R2 I can disable it, but it also gets an ip adress from my dhcpv6 server.

    Can someone confirm this?

    I find no other options to disable the dhcpv6 address as shown below:

    Netsh int ipv6 set int 12 routerdiscovery=disabled

    Netsh int ipv6 set int 12 managedaddress=disabled

    Here are my interface options:

    netsh interface ipv6>show addresses

    Interface 1: Loopback Pseudo-Interface 1

    Addr Type  DAD State   Valid Life Pref. Life Address
    ---------  ----------- ---------- ---------- ------------------------
    Other      Preferred     infinite   infinite ::1

    Interface 12: Ethernet

    Addr Type  DAD State   Valid Life Pref. Life Address
    ---------  ----------- ---------- ---------- ------------------------
    Manual     Preferred     infinite   infinite 2001:xxxxxxxxxxxxxx
    Dhcp       Preferred  10d1h37m44s 6d1h37m44s 2001:xxxxxxxxxxxxxxxx
    Other      Preferred     infinite   infinite fe80::94f1:5c6b:8845:f2a7%12

    netsh interface ipv6>show int 12

    Interface Ethernet Parameters
    IfLuid                             : ethernet_10
    IfIndex                            : 12
    State                              : connected
    Metric                             : 10
    Link MTU                           : 1500 bytes
    Reachable Time                     : 26500 ms
    Base Reachable Time                : 30000 ms
    Retransmission Interval            : 1000 ms
    DAD Transmits                      : 1
    Site Prefix Length                 : 64
    Site Id                            : 1
    Forwarding                         : disabled
    Advertising                        : disabled
    Neighbor Discovery                 : enabled
    Neighbor Unreachability Detection  : enabled
    Router Discovery                   : disabled
    Managed Address Configuration      : disabled
    Other Stateful Configuration       : disabled
    Weak Host Sends                    : disabled
    Weak Host Receives                 : disabled
    Use Automatic Metric               : enabled
    Ignore Default Routes              : disabled
    Advertised Router Lifetime         : 1800 seconds
    Advertise Default Route            : disabled
    Current Hop Limit                  : 0
    Force ARPND Wake up patterns       : disabled
    Directed MAC Wake up patterns      : disabled
    ECN capability                     : application

    Best regards,


    Wednesday, October 16, 2013 7:18 PM

All replies

  • Disabling the 'Managed Address' does not stop the system from getting an address via DHCP.   What it does instead is allows it to configure its OWN IPv6 or instead use the static one you've manually set and still gets all of the other configuration information via DHCP.      You likely need to renew your IP information or it might still list both the static and dhcp

    I don't have 2012 to test on currently, but after you've used the netsh commands to disable the routerdiscovery and disable the managedaddress,   do the following, where [index] is your NIC (looks like '12' from your commands so far.

    ipconfig /renew6 [index]

    Brian / ChevyNovaLN

    Wednesday, October 16, 2013 8:17 PM
  • Disabling the M Flag does STOP the system from getting an address via DHCP.

    It worked in Windows 7 / 8 and Server 2008 R2 / 2012.

    I know that I have to release the ipv6 addresses, but only in 2012 r2 it doesnt work.

    So I think it's a bug or a new secret option :D

    I use a router advertisment with A=0 M=1 O=1 for my ipv6 subnet and a Windows 2012 DHCPv6 Server

    Thursday, October 17, 2013 7:29 PM
  • I can confirm this behavior.  I'm glad I'm not the only one who noticed this.  I've been trying to figure out what I'm doing wrong because I was going off documentation I used to setup 2008r2 systems.
    Tuesday, October 22, 2013 7:04 PM
  • I can also confirm this behavior.  I've noticed this also.
    Wednesday, November 06, 2013 8:00 PM
  • Does anyone know of a way to report this Microsoft?

    Best regards,


    Monday, November 11, 2013 7:16 PM
  • Hi,

    I'm having this same problem on a new Windows 2012 R2 server I'm setting up and was wondering if there was an update on this?



    Sunday, February 16, 2014 7:41 PM
  • Hi,

    has anyone an Idea for this Problem?

    I've the same issue, on a 2012R2 std Server which is AD DC an DHCP Server for IPv6 which static IPv6 address, disabled the  routerdiscovery and managedaddress, released the v6 but after a reboot of the Machine, (oder deactivation of the nic) the second dhcp assigned v6 address still appears again.

    Kind regards


    Thursday, March 13, 2014 10:29 PM
  • Hi All:

    Yes, I just recently observed this problem and have a couple of other findings to contribute.

    The functionality of the router discovery and managed address configuration are not preserved across computer reboots for Windows Server 2012 R2.


    Enable RouterDiscovery and ManagedAddressConfiguration
    PS> Set-NetIPInterface Ethernet -AddressFamily IPv6 -RouterDiscovery Enabled
    PS> Set-NetIPInterface Ethernet -AddressFamily IPv6 -ManagedAddressConfiguration Enabled

    Verify the settings using

    PS> Get-NetIPInterface Ethernet -AddressFamily IPv6 | fl * (or, netsh int ipv6 show int Ethernet)

    Type ipconfig -all to display the configuration. Two items will appear in the adapter configuration: 1) An additional IPv6 address will be assigned by DHCPv6, and 2) the router's link-local address will be added to the list of default gateways.

    Next, disable RouterDiscovery and ManagedAddressConfiguration
    PS> Set-NetIPInterface Ethernet -AddressFamily IPv6 -RouterDiscovery Disabled
    PS> Set-NetIPInterface Ethernet -AddressFamily IPv6 -ManagedAddressConfiguration Disabled

    Verify settings using Get-NetIPInterface

    Type ipconfig -all to display the configuration. The IPv6 address assigned by DHCPv6 will be removed AND the router's link-local address will no longer be present in the list of default gateways.

    Reboot the computer. Once the computer reboots, verify interface settings using Get-NetIPInterface. Both RouterDiscovery and ManagedAddressConfiguration will be disabled.

    Type ipconfig -all. An additional IPv6 address will be assigned by DHCPv6, however, the router's link-local address will NOT be in the list of default gateways.

    Attempts to disable RouterDiscovery and ManagedAddressConfiguration will not remove the additional IPv6 address assigned by DHCPv6. Instead, you must first enable RouterDiscovery and ManagedAddressConfiguration then disable RouterDiscovery and ManageAddressConfiguration.

    This does appear to be a defect. Efforts to pass this along to the Windows networking folks would be appreciated. Thank you!

    Have a GREAT DAY!!


    • Edited by em2slyn Monday, April 21, 2014 1:13 AM Correction
    Thursday, April 10, 2014 12:10 PM
  • I ran across this thread as we are just now working on enabling IPv6 in our environment and seeing the same issues as other posters.   Based on network sniffs taken by our network administrator, I can see that even after running the commands that Shaun provided on both Windows Server 2012 and Windows Server 2012 R2:

    PS> Set-NetIPInterface EthName -AddressFamily IPv6 -RouterDiscovery Disabled
    PS> Set-NetIPInterface EthName -AddressFamily IPv6 -ManagedAddressConfiguration Disabled

    we do also still have DHCPv6 multicast requests coming from servers.

    I was then using these commands to look at all available settings/options


    Get-NetIPInterface EthName | FL

    and noticed that the value for DHCP on IPv6 is set to enabled, EVEN THOUGH I have a static IPv6 address configured correctly via the GUI.

    So, I ran one additional command:

    PS> Set-NetIPInterface EthName -AddressFamily IPv6 -DHCP Disabled

    and the multicast requests have now disappeared.  We do not actually have DHCPv6 available at this time on this subnet, so I can't yet see if it picks up any extra address, but the traffic appears to have stopped on the wire.  We are trying to prevent our servers from ever getting a DHCPv6 address by accident (should someone drop in a router with RA, for example, that shouldn't be there, etc).

    This last command seems to have done the trick, but in my mind, shouldn't be necessary.  It seems as if there is a bug where toggling the GUI interface from DHCPv6 to a static address is NOT correctly disabling DHCP on that interface.  Doing the same thing on the IPv4 address using the GUI DOES disable the same "DHCP" parameter.

    Hopefully this can be addressed, and in the meantime, maybe this can help someone else!

    • Proposed as answer by AndrewD Thursday, March 24, 2016 6:41 PM
    Thursday, June 19, 2014 4:01 PM
  • Try enabling router discovery and managed address first, then disable them both as follows.

    PS> Set-NetIPInterface EthName -AddressFamily ipv6 -RouterDiscovery Enabled
    PS> Set-NetIPInterface EthName -AddressFamily ipv6 -ManagedAddress Enabled

    PS> Set-NetIPInterface EthName -AddressFamily ipv6 -RouterDiscovery Disabled
    PS> Set-NetIPInterface EthName -AddressFamily ipv6 -ManagedAddress Disabled

    I wrote this up in "Windows Server 2012 R2 IPv6 Managed Address Configuration functionality does not persist across reboots" that steps through the process and provides additional diagnostic information. Anyway, hopefully the networking team at Microsoft will get a chance to look at this problem.

    Friday, June 20, 2014 12:39 PM
  • Hi There,

    I'm having this issue with my server2012r2 environment. does anyone know if there has been any progress from mr microsoft ?

    Tuesday, January 13, 2015 2:37 PM
  • Hi

    I'm having this exact issue as well any news from Microsoft? or a way for a work around to persist after reboot.



    Update *
    OK it seems after doing the Disable DHCP for the IPv6 Address Family as well as all the commands in the above post it does persists after a reboot. but I'm going to do further tests tomorrow but its looking good for my 2012 R2 Domain controllers, DNS server etc  why doesn't this happen automatically when a server has a  role installed that needs just a single static IPv6 address!!! ?
    • Edited by Boris67 Thursday, January 29, 2015 5:57 PM
    Thursday, January 29, 2015 5:04 PM
  • @ Aqueries and Boris:

    The settings changed from Server 2012 to Server 2012 R2 in that the DHCP interface setting does not automatically change when spcifying managed configuration. Here is how to create a static IPv6 address on a network adapter on Server 2012 R2:

    Example Settings
    Network Adapter Name: Ethernet
    IPv6 Address: 2001:db8::10/64
    Default Router: 2001:db8::1 (Optional)

    PS> Set-NetIPAddress Ethernet -AddressFamily IPv6 -DHCP Disabled
    PS> New-NetIPAddress 2001:db8::10 -InterfaceAlias Ethernet -PrefixLength 64 -DefaultRouter 2001:db8::1
    PS> Set-NetIPAddress Ethernet -AddressFamily IPv6 -RouterDiscovery Disabled -ManagedAddressConfiguration Disabled

    This is what I use and it works. The post from Midnite_A gave insight into the solution. I'm pretty sure this will also work on Server 2012 systems.

    Have a GREAT DAY!!


    Thursday, January 29, 2015 6:28 PM