none
Deploying Office 365 through TS RRS feed

  • Question

  • I've posted over to the Office 365 forum but didn't get much luck so I thought I would come over here.

    I'm really struggling to deploy the Office 365 installation.  In fact, I'm having a hard time getting it installed full stop.

    So the process I have followed is:

    1. Download the Office Deployment Tool
    2. Run the deployment too (which extracts setup.exe and a template for the XML file)
    3. Modify the XML file to:
    <Configuration>
      <Add SourcePath="" OfficeClientEdition="32" >
        <Product ID="O365ProPlusRetail">
          <Language ID="en-us" />
        </Product>
      </Add>  
      <Display Level="None" AcceptEULA="TRUE" />  
      <Logging Name="OfficeSetup.txt" Path="%temp%" /> 
    </Configuration>

    4. I've then run the setup.exe /download configuration.xml - this seems to download some files (about 1GB worth)

    5. I then copy this entire folder to the C:\ of a fresh build and run 'setup.exe /configure configuration.xml'

    This fails with an error in the log of:

    C2R Client returned failing error code 17002

    I've tried to deploy over the network form a share with 'Everyone' access and the same result.

    At this point I have no idea whats going on,  does anyone have this working?


    Monday, March 3, 2014 4:10 AM

Answers

  • Thanks for the reply,  I sorted it though.

    The XML file should def be the same (depending on your requirements).

    The issue I had was that I wasn't specifying the 'UPDATES' section at all, so it was causing it to fail.  I specifically added a 'FALSE' setting to the updates and it is now working. 

    For some reason I just expected it would default to 'FALSE' if not defined, but I guess I was wrong.

    Anyway, for future Googler's here is my working XML file:

    <Configuration>
    <Add SourcePath="" OfficeClientEdition="32" >
        <Product ID="O365ProPlusRetail">
          <Language ID="en-us" />
        </Product>
    </Add>
    <Updates Enabled="FALSE" UpdatePath="" />
    <Display Level="None" AcceptEULA="TRUE" />
    <Logging Path="%temp%" />
    <Property Name="AUTOACTIVATE" Value="1" />
    </Configuration>

    This XML will download and install from the same location as the setup.exe file.

    • Marked as answer by mhouston100 Tuesday, March 4, 2014 9:48 PM
    Tuesday, March 4, 2014 8:57 PM

All replies