none
How to disable domain join for 1 task sequence? RRS feed

  • Question

  • In our environment we have MDT 2012 Update 1 and have been using it for around 2 years.  Everything works fine but I have now been asked to create a task sequence for the sole purpose of testing hardware when it comes back from an end user.  This seems simple enough to create a task that will install the OS, inject drivers, and that be it.  My current default rules join the machine to our domain and obviously I don't want that in this situation.

    My question is how can I eliminate the domain join for this task only?

    Here are my current rules:

    [Settings]
    Priority=Default
    
    [Default]
    _SMSTSORGNAME=PC Deployment
    HideShell=Yes
    OSInstall=Yes
    DoNotCreateExtraPartition=YES
    SkipApplications=Yes
    SkipAppsOnUpgrade=YES
    SkipAdminPassword=YES
    SkipProductKey=YES
    SkipComputerName=YES
    SkipDomainMembership=YES
    SkipUserData=YES
    UserDataLocation=AUTO
    SkipLocaleSelection=YES
    SkipTimeZone=YES
    SkipBitLocker=YES
    SkipSummary=YES
    SkipBDDWelcome=YES
    SkipFinalSummary=NO
    TimeZone=002
    TimeZoneName=Central Standard Time 
    
    
    JoinDomain=corp.domain.com
    DomainAdmin=Admin
    DomainAdminPassword=Password
    MachineObjectOU=OU=OSBuilds,DC=CORP,DC=DOMAIN,DC=COM
    
    FinishAction=REBOOT

    I've tried putting TaskSequenceID as the top priority and setting it to join workgroup but it didn't work.
    Wednesday, June 12, 2013 1:34 PM

All replies

  • Hi,

    My suggestion is to create a bootable usb hard disk. ( Just to test .)

    Open up MDT- Advanced Configurations - Media.
    Create new media. choose the selection profile you want to use.

    Update and when finished go to folder \Content\Deploy\control\customsettings.ini

    Edit out joining the Domain. Copy the all the Content folder to a bootable usb hard disk.

    If this works and you perfer using a lan network. Set up a copy of your present deployment in a virtual lab Deployment server setup, which is not part of the domain in the IT Dept.


    Please bear in mind, that my answer is based on the details given in your post. The more I get the better the answer, Slan go foill, Paul

    Wednesday, June 12, 2013 5:41 PM
  • Unfortunately, processing by Task Sequence in CustomSettings.ini no longer works by default in MDT 2012 Update 1.  This can be done, but requires a few modifications.  See the article here: http://www.the-d-spot.org/wordpress/2012/07/20/how-to-use-different-settings-per-task-sequence-with-mdt-2012/


    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    Wednesday, June 12, 2013 6:05 PM
    Answerer
  • We have overruled Task Sequence properties at the beginning of the Task Sequence when we had the need to override a CustomSettings.ini property.   I have never tested this on the Domain join properties but it usually works with most properties:

    Example:


    "My laptop can beat up your laptop" http://www.panasonic.com/toughbook MDT Task Sequence Duplicator (MDT 2010 U1, MDT 2012 Beta 1) https://panaconsulting.egnyte.com/h-s/20110720/5322c025f299460c Application Bundle Duplicator (MDT 2010 U1, MDT 2012 Beta 1) https://panaconsulting.egnyte.com/h-s/20110720/2aebf7d1887e43cb

    Wednesday, June 12, 2013 8:30 PM
  • Hi,

    Make a copy of your customsettings.ini and call it customsettingswg.ini, remove the part with domain join and add the workgroup you wish to use

    then in the sequence add this like the picture below.


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, June 13, 2013 8:23 AM
  • Jorgen - I tried your option and it still presents me with the window to name the machine and choose to join the domain or workgroup.
    Thursday, June 13, 2013 2:02 PM
  • I tested my suggestion above and it worked in my environment:

    At the top of the Task Sequence in the initialization group I added the following "Set Task Sequence Variables" steps:

    Nulled out the following Variables:

    JoinDomain=

    DomainAdmin=

    DomainAdminDomain=

    DomainAdminPassword=

    Added the following Task Sequence Variable

    JoinWorkGroup=Workgroup


    MDT Task Sequence Duplicator https://panaconsulting.egnyte.com/h-s/20130614/61707be809944999 Application Bundle Duplicator https://panaconsulting.egnyte.com/h-s/20130614/405e7d64e5d54610

    Friday, June 14, 2013 4:14 PM
  • Just to clarify,

    you removed from customsettingswg.ini

    JoinDomain=corp.domain.com
    DomainAdmin=Admin
    DomainAdminPassword=Password
    MachineObjectOU=OU=OSBuilds,DC=CORP,DC=DOMAIN,DC=COM

    And and added to the same cusomsettingswg.ini

    JoinWorkgroup=Workgroup

    Another question, did you remove the "old" _SMSTasksequence folder and MININT folder from your test machine before testing ?


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Friday, June 14, 2013 6:38 PM
  • The _SMSTaskSequence and MININT folders were removed. 

    Basically I just overruled the Task Sequence variables that are set in CustomSettings.ini by adding "Set Task Sequence Variable" steps in the Initialize Phase of the Task Sequence: 

    Then NULL Variables that you need removed and set variables you need set:

    Null variables you need removed (JoinDomain)

    Set Variables you need set (Join Work Group)

    You will have to Null all the Domain variables and Set the Workgroup variable.   


    MDT Task Sequence Duplicator https://panaconsulting.egnyte.com/h-s/20130614/61707be809944999 Application Bundle Duplicator https://panaconsulting.egnyte.com/h-s/20130614/405e7d64e5d54610

    Friday, June 14, 2013 8:43 PM
  • Note that many variables are configured as "first value wins", so even if your Task Sequence tries to override it, it may not take.  You can look at ZTIGather.xml for a list of which properties can be overwritten and which can't (as well as their descriptions).  After the "Set Task Sequence Variable" step, check your logs to see if the value was actually overwritten and what it's new value is (if it's what you wanted or not).

    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    Saturday, June 15, 2013 2:15 AM
    Answerer
  • I tested my suggestion above and it worked in my environment:

    At the top of the Task Sequence in the initialization group I added the following "Set Task Sequence Variables" steps:

    Nulled out the following Variables:

    JoinDomain=

    DomainAdmin=

    DomainAdminDomain=

    DomainAdminPassword=

    Added the following Task Sequence Variable

    JoinWorkGroup=Workgroup


    MDT Task Sequence Duplicator https://panaconsulting.egnyte.com/h-s/20130614/61707be809944999 Application Bundle Duplicator https://panaconsulting.egnyte.com/h-s/20130614/405e7d64e5d54610


    I've tried this option but you still get presented with the window to select the domain, workgroup, etc...  When you build the machine it does over write and work the way it is intended but my hope is to prevent that window from showing at all.
    Tuesday, June 18, 2013 4:03 PM
  • 2 Methods.

    First (recomended)

    edit your customsettings.ini as in this sample

    _____________________________________________________________________

    [Settings]
    Priority=TaskSequenceID, Default
    Properties=CustomProperty
     
    [Default]
    OSInstall=Y
     
    [TSName]
      SkipDomainMembership=YES

    _____________________________________________________________________

     

    Where "TSName" is the ID of your Task Sequence and your current customsettings go under default.

    .

    .

    .

    Second Method(Experts only).

    1. Make a backup of DeployWiz_Definition_ENU.xml for safekeeping.
    2. Open the DeployWiz_Definition_ENU.xml in Notepad and modify the following section as below
    	<Pane id="ComputerName" reference="DeployWiz_ComputerName.xml">
    		<Condition><![CDATA[UCase(Property("SkipDomainMembership"))<>"YES" or UCase(Property("SkipComputerName"))<>"YES"]]></Condition>
    		<Condition><![CDATA[Property("DeploymentType")<>"REPLACE" and Property("DeploymentType")<>"CUSTOM" and Property("DeploymentType") <> "StateRestore" ]]></Condition>
    		<Condition><![CDATA[ ucase(oEnvironment.Item("TaskSequenceID")) <> "TSName" ]]></Condition>
    	</Pane>

    Important - Update "TSName" with the ID of the Task Sequence you with to filter.

    Let me know how this works for you.

    .

    .

    /Andrew


    Blog: http://scriptimus.wordpress.com




    Tuesday, June 18, 2013 9:36 PM
  • The method one you have listed does not work.  I've tried that many times.  I will look in to your second option.
    Tuesday, July 2, 2013 1:36 PM