locked
Regedit does not display all the registry keys RRS feed

  • Question

  • For some reason not all existing keys in the registry are being displayed when using regedit utility.

    I know that the key exists because it is added by my code and it is being read back by the programming code correctly.

    However regedit cannot find it.

    How to correct that?

    /jas

    Thursday, October 23, 2014 7:17 PM

Answers

  • What version of Windows are you using?

    64-bit Windows has two (2) registries.

    The default is to run the 64-bit regedt32.exe which is in the C:\Windows\System32 directory and view the 64-bit register.

    If you want to view and/or edit the 32-bit register you must run the C:\Windows\WOW64\regedt32.exe.

    See info in Microsoft's article How to view the system registry by using 64-bit versions of Windows  


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”


    • Marked as answer by jastrzebiec Thursday, October 23, 2014 8:41 PM
    • Edited by Rick Dee Friday, October 24, 2014 10:55 AM typo
    Thursday, October 23, 2014 8:21 PM

All replies

  • What version of Windows are you using?

    64-bit Windows has two (2) registries.

    The default is to run the 64-bit regedt32.exe which is in the C:\Windows\System32 directory and view the 64-bit register.

    If you want to view and/or edit the 32-bit register you must run the C:\Windows\WOW64\regedt32.exe.

    See info in Microsoft's article How to view the system registry by using 64-bit versions of Windows  


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”


    • Marked as answer by jastrzebiec Thursday, October 23, 2014 8:41 PM
    • Edited by Rick Dee Friday, October 24, 2014 10:55 AM typo
    Thursday, October 23, 2014 8:21 PM
  • Thank you. That's done it.

    /jas

    Thursday, October 23, 2014 8:41 PM