locked
how to set-up a range for system restore on windows vista? RRS feed

  • Question

  • Hi,
     
    I'm having a problem with the system restoration. It's eating up all my local disk. Every day the hard disk getting filled by at least 2 GB. When i turn the system restore off, then i get back the disk but again when i turn it it gets full.
     
    so i want to get a solution for this. may be i can set a range for this so it wont take much of the disk size. else if it gets going like this, i will be end up with zero hard disk.
     
    i hope you understand what i meant.
     
    i'm looking for an answer.
     
     
    thank you
    Saturday, September 22, 2007 2:43 AM

All replies

  • I know it uses a lot more drive space in Vista. But it is a good life line. There are alternatives. Change the amount of disk space used is one option. But then you will have fewer restore points. Change how often a restore point is made is another. This will allow fewer points but you can go back in time more.

    I think the amount of space used by System Restore is 15% of free hard drive space. After that older points will be deleted. You can view your size and even change it but not like you could before. Now you need to open an elevated command prompt with administrator privileges.

    If your hard drive is filling up for no apparent reason check your Restore size. Log on to Windows as an administrator. In the "Run" box type "command" without the quotes. Press the Enter key. If "Run" is not enabled on the start menu. Go to All Programs>Accessories>Run or Go to All Programs>Accessories and right click Command Prompt. Click Run as administrator.

    At the command prompt type "vssadmin List ShadowStorage" withoute the quotes.

    With the proper syntax you can use Command Prompt to change the amount of space used by System Restore here.

    The syntax for changing a given drive's shadow volume size is:
    vssadmin resize shadowstorage /on= /for= /maxsize=
    <drive_letter> is the drive letter to change the storage parameters for; <max_size> is the maximum size with a suffix that designates which units you're using (typically MB or GB). If you typed vssadmin resize shadowstorage /on=c: /for=c: /maxsize=2GB, this would resize the shadow volume for the C: drive to 2GB. The changes should take effect immediately.

    AUTOMATIC SCHEDULING OF RESTORE POINTS.

    The default setting of once every 24 hours was to often for me. Even with a 300G drive 15% didn't let me go back far enough because each point took up so much space. So I used Task Scheduler to change it to once every 48 hours unless a Restore point was made for another reason or my system wasn't idle at the scheduled time. Just my preference.

    Go to Start>Programs>Accessories>System Tools>Task Scheduler>

    Click the arrow > next to to Task Scheduler Library. Do the same for Microsoft. Do the same for Windows. Click on the System Restore Folder on the left.

    On the right click Properties. Click on the Triggers tab. Click Edit. Change "daily" recur every 1 day to 2 days. Click OK. Click OK. Close Task Scheduler.

    Changing how often System Restore schedules a point via the registry is not something I've done yet but I have looked at it on my system. It looks simple enough. Just be sure to backup the registry first in case you do it wrong.

    Click "Start">"Run". Type "regedit" without the quotes. Click "OK".

    On the left pane expand HKEY LOCAL MACHINE and navigate to HKLM\SOFTWARE\Microsoft\WindowsNT\CurrentVersion \SystemRestore.

    Double click "RPGlobalInterval". Tick Decimal instead of Hexadecimal. Under Value Data change the number to a setting you want. The default setting is 86400 seconds or 24 hours. Changing it to 172800 will change it to once every 48 hours. Click OK and close regedit.


    All versions of Vista take a lot of drive space to install. If you need more drive space don't disable System Restore. Get a bigger drive or revert to XP. If your using vista x64 ultimate upgrade your RAM too.
    Thursday, January 31, 2008 7:11 PM