none
Help with XML to Flat File XSD RRS feed

  • Question

  • Hi All,

    I'm working on a migration project which converts the BizTalk integrations to Azure Logic Apps. I have a BizTalk XSD which makes a flat file. But I need to remove trailing spaces from the record. How can I achieve this? To be more specific, I have 7 elements and last element's pos_length value is 10. But sometimes the XML contains only 8 or 9 characters for that element. But the flat file fills it with spaces. If it's 8, 2 extra spaces and if 9 1 extra space. I don't want those spaces before the next record starts. How can I avoid it?

    Regards,

    Jijo Joseph

    Saturday, January 18, 2020 4:07 PM

All replies

  • Have you made sure that the padding character is not set?  Have you enable the allow early termination flag?
    Sunday, January 19, 2020 6:50 PM
  • Padding character is 'space' which is needed for other fields. But the last field does not need padding. I tried "allow_early_termination" but didn't work for me.
    Monday, January 20, 2020 8:47 AM
  • Can you share an example schema that demonstrates the problem?
    Tuesday, January 21, 2020 1:39 AM