locked
Can't add a content DB (Sharepoint 2007) RRS feed

  • Question

  • Hello,

    Recently I have changed some users in my farm, the change was for a security reason.

    The change was in some levels: the application pools that run the web sites and the SharePoint services (administration and timer). After this changes ,I was trying to add a content DB to an existing web application.The process took a long time and never finished (it was stuck in the processing page).When I checked the sql manager, I noticed the content db was created even though it didn't appear in the central administration (meaning it didn't connect in the Sharepoint level).

    I have tried to restore the iis setings file with no success. Furthermore, i have manually changed back the user identities of the services and the application pools, but even that wasn't helpful.

    Can you please help me?

    Thanks in advance.

    • Edited by Gal SP Monday, August 13, 2012 8:19 AM
    Monday, August 13, 2012 8:18 AM

All replies

  • What permission changes did you make and how big was the content database you were trying to add?

    Steven Andrews | SharePoint Professional | http://www.twitter.com/backpackerd00d | https://baron72.wordpress.com/

    Monday, August 13, 2012 1:45 PM
    Answerer
  • I don't remember the changes but i know what are the current permissions.The user that is running the services (Windows SharePoint Services timer and administration) and the application pools has a sysadmin on the sql, db owner on the config DB, farm admin on SharePoint and local administrator permissions on the FE and the BE.

    Secondly, I was trying to add a new content DB.

    Do you have any idea what is the problem?
    Tuesday, August 14, 2012 8:58 AM