locked
I am in the Farm administrator group and I get a 403 error with my login but not with the service account RRS feed

  • Question

  • i've taken soem code from my SP 2010 Developer class and tried to use it at work and I can only get it to run when I login with the service account that runs sharepoint. My account causes a 403 error when i try to access the page. I looked in Central Admin and both of our accounts are Farm Administrators. Is there another place I need to give my account rights?
    Wednesday, May 9, 2012 8:56 PM

All replies

  • Hi,

    Are you using FBA? We have seen this in past while using FBA. To resolve we simply added the account in site collection administrator and it worked.


    Thanks, Rahul Rashu

    Thursday, May 10, 2012 3:59 AM
  • We are using claims based authorization and I am in the farm admin group and also in the admin group on the web server front end. I'll double check to see if I am in admin on both front end servers. Is there anywhere else in the farm I need to change security. 
    Thursday, May 10, 2012 1:46 PM
  • What exactly are you trying to access?  If you're trying to access a site collection or site you still need to grant yourself access.  Being a member of the Farm Administrators group does not automatically give you access to sites and site collections.  Are you one of the site collection admins for the pages you're trying to access?

    Paul Turner http://redmanta.co.uk/blog Twitter: @RedMantaUK MCTS:WSS,MOSS,2010 MCITP:2010.
    Please remember to click "Propose As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.

    Thursday, May 10, 2012 2:00 PM
  • It is a file at this path: http://reporting10dev.chi.ecommunity.com/_layouts/FarmView/farmhierarchy.aspx

    I'll made myself a site collection admin  and gave my self full control through site permissions to http://reporting10dev.chi.ecommunity.com and still get the 403 error.


    Thursday, May 10, 2012 2:27 PM
  • Have you been able to discover anything from the logs?

    Paul Turner http://redmanta.co.uk/blog Twitter: @RedMantaUK MCTS:WSS,MOSS,2010 MCITP:2010.
    Please remember to click "Propose As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.

    Friday, May 11, 2012 12:44 PM
  • The event viewer logs or something from process explorer\monitor or fiddler. I'm new to SP and havent' found my way around the admin side yet. I've also been handed some SSIS and powershell projects to take me away from this project.
    Thursday, May 17, 2012 6:20 PM