locked
Trying to test stuff... Cannot launch sequenced app on a computer with the client installed RRS feed

  • Question

  • Hey everyone, I'm pretty new to virtualizing applications, and definitely new to MDOP and APP-V, but we are testing applications for our company and I can't figure out what's going on here.

     I've sequenced a few applications, let’s start with Google Earth 4.1. I've got a VM running that I sequenced the app on, and a completely separate computer that I've got nothing but the basics and the Desktop Client installed on. I run the MSI file generated by sequencing the app on the computer with the client installed, it runs through the installer with no problems, but when I try to launch the application it says there's no connection to the server, which is absolutely right because we don't have a server setup anywhere yet as we are still testing.

    Now all of that is fine and dandy, except my coworker is able to run the MSI and successfully launch the application without any problems (Meaning, no server issues like I see on my client computer).

    Can someone please let me know what I need to do in order to avoid building out a server just yet so we can go through our 100+ applications, sequence, and test each of them?

    Thanks so much for your help. I'm sure this is going to be something simple, but I've looked and I can't seem to find anything.

    Thanks again!

    -Duane

    Wednesday, September 29, 2010 2:27 PM

Answers

  • Here's an example SFTMIME command that works:

    SFTMIME ADD PACKAGE:"Microsoft_Office_2010_x64_084154.001" /MANIFEST "\\\VBOXSVR\Packages\Microsoft Office\2010_x64\000\Microsoft_Office_2010_x64_084154.001_manifest.xml" /OVERRIDEURL "\\\VBOXSVR\Packages\Microsoft Office\2010_x64\000\Microsoft_Office_2010_x64_084154.001.sft" /GLOBAL /CONSOLE

    Confirm that the location of the SFT file is available to all users including the local system. I'm not sure what the device not ready issue is, but the first place to go is the App-V client log.

    • Marked as answer by Pricky Wednesday, September 29, 2010 7:14 PM
    Wednesday, September 29, 2010 6:57 PM
    Moderator

All replies

  • Add the packages locally via this process:

    1. Create a local folder to contain the packages (e.g. C:\Packages)
    2. Change the ApplicationSourceRoot registry value to C:\Packages http://technet.microsoft.com/en-us/library/cc843817.aspx
    3. Copy the packages into the C:\Packages folder (a package will generally be stored on its own folder, copy that folder into C:\Packages
    4. Install the package via the generated MSI or the SFTMINE ADD PACKAGE command
    5. Optionally set the client into Work Offline mode (via the notfication area icon)

     

    Wednesday, September 29, 2010 4:11 PM
    Moderator
  • Hey Aaron, thank you for your reply - At least I know this is possible now.

    The thing that's stopping me right now is I'm still getting some errors. If I run the command "sftmime ADD PACKAGE:"ACDSee 9" /MANIFEST C:\Packages\ACDSee.9.Output" it returns "The device is not ready." with error code 4604EE8-23C02532-00000015.

    I've found no support for this error online (so far) and am still a little confused about this problem.

    Let me know if you can think of a reason for that error, or at least can point me to some documentation that mentions the error.

    Thanks!
    -Duane

     

    Wednesday, September 29, 2010 6:17 PM
  • Wednesday, September 29, 2010 6:25 PM
  • The thing that's stopping me right now is I'm still getting some errors. If I run the command "sftmime ADD PACKAGE:"ACDSee 9" /MANIFEST C:\Packages\ACDSee.9.Output" it returns "The device is not ready." with error code 4604EE8-23C02532-00000015.

    Add the /OVERRIDEURL switch to the command, see the documentaiton in Znack's link for more info.
    Wednesday, September 29, 2010 6:35 PM
    Moderator
  • Hey Aaron, I tried just about every variation of the command possible, including the /OVERRIDEURL switch, and I'm still getting the same "Device not ready" error.

    I'm going to keep poking though.
    Thanks for being so prompt!
    -Duane

     

    Wednesday, September 29, 2010 6:40 PM
  • Here's an example SFTMIME command that works:

    SFTMIME ADD PACKAGE:"Microsoft_Office_2010_x64_084154.001" /MANIFEST "\\\VBOXSVR\Packages\Microsoft Office\2010_x64\000\Microsoft_Office_2010_x64_084154.001_manifest.xml" /OVERRIDEURL "\\\VBOXSVR\Packages\Microsoft Office\2010_x64\000\Microsoft_Office_2010_x64_084154.001.sft" /GLOBAL /CONSOLE

    Confirm that the location of the SFT file is available to all users including the local system. I'm not sure what the device not ready issue is, but the first place to go is the App-V client log.

    • Marked as answer by Pricky Wednesday, September 29, 2010 7:14 PM
    Wednesday, September 29, 2010 6:57 PM
    Moderator
  • Well I'll be a monkey's uncle. I think the "Device not ready" problem spurred from me not placing the FULL path to the actual file. I understood the documentation as only putting the folder in the command line... That's kind of lame, but it's at least working right now.

    I can say that on my partners computer he's got file associations for the .osd file... The command line for this (In the file associations) is:

    "C:\Program Files\Microsoft Application Virtualization Client\sfttray.exe" "%1" %*

    I don't know why his client setup a file association for OSD's and mine didn't, but sounds a little weird to me.

    In any case, it is working now and I can continue with testing. Thank you so much for you assistance, Aaron!

    -Duane

     

    Wednesday, September 29, 2010 7:14 PM