none
SCOM agents not visible in operations console

    Question

  • Hello,

    i've installed SCOM 2012 agent on one of server, from Installation disk.

    when i was viewing in operations console, i could not find that machine.

    Question:

    when you re installing agent from Installation disk, it is like standalone and has not to be appeared in console?


    Costa Curta

    Wednesday, August 01, 2012 8:42 PM

Answers

  • You have to go into the console, go to administration, go to pending actions and manually approve the manually installed agent.

    Regards, Blake Email: mengotto<at>hotmail.com Blog: http://discussitnow.wordpress.com/

    Wednesday, August 01, 2012 8:46 PM
    Moderator

All replies

  • You have to go into the console, go to administration, go to pending actions and manually approve the manually installed agent.

    Regards, Blake Email: mengotto<at>hotmail.com Blog: http://discussitnow.wordpress.com/

    Wednesday, August 01, 2012 8:46 PM
    Moderator
  • Hi,

    If you have your manament group global configuration set to "reject manual installed agents" it will never show up. this setting is under administration - settings - security. Change this to manually or automaticly approve manually installed agents. Restart the scom service on the "agent" server and it should show up soon.

    hope this helps.

    Wednesday, August 01, 2012 8:53 PM

  • Hi,

    For the configurations about manual installed agents, please refer to the following document:

    Process Manual Agent Installations
    http://technet.microsoft.com/en-us/library/hh212853.aspx

    If the computer is in an untrusted domain or workgroup, please also see:

    When you try to install a System Center Operations Manager agent on a workgroup computer without using a gateway server, Operations Manager cannot see the workgroup computer
    http://support.microsoft.com/kb/947691

    Step by Step for using Certificates to communicate between agents and the OpsMgr 2007 server
    http://blogs.technet.com/b/operationsmgr/archive/2009/09/10/step-by-step-for-using-certificates-to-communicate-between-agents-and-the-opsmgr-2007-server.aspx

    Hope this helps.

    Thanks.


    Nicholas Li

    TechNet Community Support

    Thursday, August 02, 2012 6:41 AM
    Moderator
  • Hi Guys,

    I had similar issue under the SCOM 2012 R2. Some of the SCOM Agents has been installed manually by using*.msi file on the servers. Such Agents were not visible under "Pending Management" in the SCOM Administration Console.

    When I try the Discovery Wizard...  process I got the message that these computers are pending for approval already (agents has been installed already). Only one agent at once showed up in Pending Management but when I tried to approve it, I get the error message with generic ID and "Index was out of range" error.

    I've deleted the "C:\Program Files\Microsoft System Center 2012 R2\Operations Manager\Server" (rename it to the ..._old) and restart the SCOM Health Service (net stop/start healthservice), I flushed the DNS cache (ipconfig /flushdns) but it didn't help.

    I run the "Get-SCOMPendingManagement" command from the SCOM Power Shell (send the result to a text file "... > C:\result.txt") and I saw that all missing servers were described as:

    AgentName              : server_name
    ManagementServerName   : scom_server_name
    AgentPendingActionType : ManualApproval
    LastModified           : date
    ManagementGroup        : SCOM_managementgroup_name
    ManagementGroupId      : server_id

    It shows that SCOM is aware of those SCOM Agents but probably due to some SCOM bug such agents didn't show up in the Pending Management properly and "Approval" didn't work for them properly.

    So I've reconfigured SCOM (Administration -> Settings -> Security) and in addition to the "Review new manually agent installations in pending management view" I've check the "Automatically approve new manually installed agents". Then I've restarted the SCOM HealthService on the SCOM Management Server (net stop/start healthservice)

    After the restart, when I opened MoerationManager console the previously pending servers were now in the "Agent Managed" folder (Not monitored, at the begining, but Healthy after few minutes when SCOM get the status from them).

    For Security purpose "Automatic approval" should be disabled but to solve the issue you can enable it.

    As I see its better to install SCOM Agents from SCOM Console than manually from msi file.

    Microsoft should solved this (bug) Maybe in SCOM 2016 it works well.

     

    Wednesday, June 27, 2018 12:44 PM