locked
IPAM Upgrade Failed - Windows Server 2012 R2

    Question

  • Hi All,

    I'm experiencing some problems with the upgrade procedure of an IPAM service hosted on a Windows Server 2012 R2 instance which originally was deployed on a non-R2 version. I've recently done in-place upgrade of the W2K12 OS to W2K12R2 which went absolutely fine, however when I'm trying to upgrade the IPAM service itself (from v6.2.0.1 to v6.3.0.1), I'm receiving an error message right after the database schema update procedure.

    Received error message:

    Failed to convert Schema. Please see the details.
    The given key was not present in the dictionary.
    Please restart the Wizard to update the IPAM server.

    Tried to restart the wizard several times, but it ends up with the same result.
    Also I noticed that the event log shows some authentication problems with the WID DB service:

    Connecting to IPAM database failed with,
        Number: 18456
        ErrorCode: -2146232060
        Level: 14
        State: 1
        Message: Login failed for user 'NT AUTHORITY\NETWORK SERVICE'.

    For database,
        Database Type: WindowsInternalDatabase
        Database Authentication Type: WindowsAuthentication
        Database Name: IPAM
        Database Path: C:\Windows\System32\ipam\Database
        Database Server:
        Database Server Port: 0
        Username:

    The original IPAM deployment was pretty much a standard one by the official MS guides so there were no custom actions applied at any point in time. Right now I can access neither the IPAM features nor the previously made inventory, because server manager wouldn't let me do so until the upgrade is complete. For the time being this upgrade failure seems to be a bug.

    Kindly ask you to help me out with this issue.

    Thanks in advance.
    Friday, September 27, 2013 9:48 PM

All replies

  • I am also seeing the same issue.

    Tuesday, October 22, 2013 2:28 PM
  • Exactly same here, after server 2012 to 2012r2 in place upgrade.


    Wednesday, October 23, 2013 9:13 AM