none
Express Full Backups not running when sheduled in Protection Group RRS feed

  • Question

  • Dear DPM Backup Guru's,<o:p></o:p>

    Environment: DPM 2010 / Exchange 2010<o:p></o:p>

    The PG that I have configured is just backing up a copy of an exchange DAG DB. The Express Full backup is scheduled to run at 8PM. When you look at 'Today's Jobs' it is in the schedule to run at 5PM. This is a pretty HUGE exchange environment so I have quite a few PG sets to get thru all the DAG DB's. The PG's have staggered start times. All the jobs in the 'Today's Jobs' list are all off -3 hours. I've tried removing DB's from protection and rebuilding them in a new PG thinking that maybe the PG was corrupt. That didn't change anything. I figure I could just add 3 hours to the start time in the PG so that the jobs would start when I wanted them to but that is just a 'Band-Aid' fix.<o:p></o:p>

    Anyone have any thoughts?

    Thanks!

    James

    Tuesday, October 30, 2012 4:34 PM

Answers

  • Hi,

    You can run this SQL script to see what time zones DPM is using when scheduling backup jobs.  Open SQL management studio using administrative privileges and connect to the DPM instance, then run the below script and see what time zone the DPM server is in and the protected servers.

    Use DPMDB
    select svr.ServerName, svr.serverid, tz.Description, tz.DaylightName,tz.StandardName, tz.DaylightBias from tbl_AM_ServerTimeZone tz join dbo.tbl_AM_Server svr on tz.ServerId = svr.ServerId



    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    • Marked as answer by James_USPS Monday, December 3, 2012 5:55 PM
    Tuesday, November 27, 2012 4:24 PM
    Moderator
  • Hi,

    DPM will not allow you to remove an agent when there are data sources still under active protection, you will need to stop protection first. 

    Try these steps for each effected protected server:

    NOTE: These steps assume a local SQL dpmdb.

    1) Make sure there are no active DPM jobs running.
    2) Stop protection and maintain replica for each data source of a protected server. That will move the data sources to an Inactive Protection group.
    3) Disable the DPM Servers network interface from Control Panel\Network and Internet\Network Connections.
    4) In DPM Console, locate the protected server agent, right-click and choose uninstall.  When it errors out, it will ask if you want to remove the agent from the DB, choose yes.
    5) Re-enable the DPM NIC, then install the agent again using the "attach agent" flow - that will get the current time zone information from the client and update the DPM tables.
    6) Re-protected the data sources and that will bring them out of the inactive protection group.  Run a CC to get them green.  Future jobs will be scheduled correctly based on new time zone settings.
    7) Repeat for each effected protected server.
    8) In the future, make sure servers are configured for their correct time zones before protecting. 


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    • Marked as answer by James_USPS Monday, December 3, 2012 5:55 PM
    Thursday, November 29, 2012 5:56 PM
    Moderator

All replies

  • Hi James,

    Could you give us more details on how your PG are configured ? Express Full 8PM/Sync ? Active/Passive/Both ? How many database per PG ? Other PG protecting different datasource is running prior DAG protection on the Exchange server ?

    Stephane.


    Please remember to click “Mark as Answer” on the post that helps you. This posting is provided "AS IS" with no warranties. knowledge is valid only if it is shared by All.

    My DPM blog Yet Another DPM Blog

    Tuesday, October 30, 2012 9:34 PM
  • Our exchange environment has 100 DAG's. I have broken all the DAG's into 10 protection groups of 10 DB's. The active DB's are in one site being backed up by a DPM server in that site. Those backups are configured for 'Full Backups' and do a 'sync' every hour. There scheduled full backup runs when specified in the protection group. In our other site there are copy's of the same DB's.  All of them are just doing "Copy backups" on another DPM server in that site. All of these DB's are passive. Their backups for some reason run 3 hours earlier than what is scedueled in their protection group.

    Basically it looks some thing like this:

    Database                    Mailbox Server                    Is Active
    --------------------------------------------------------------------
    DAG01-DB001             ExchangeServer1                True
    DAG01-DB001             ExchangeServer2                False
    DAG01-DB001             ExchangeServer3                False
    DAG01-DB001             ExchangeServer4                False

    ExchangeServer's 1 & 2 are in one site and 3 & 4 are in another.

    I'm running Full Backups and Sync's every hour on ExchangeServer2 and running Copy Backups on ExchangeServer4

    Backups are scheduled in the protection group in both sites at 8PM. ExchangeServer2 runs as scheduled. ExchangeServer4, even though it's scheduled at 8PM runs at 5PM.

    I can't seem to figure out why it is not running as schedueled in the protection group.

    Thanks again!

    James

    Wednesday, October 31, 2012 2:49 PM
  • Hi James,

    if you are protecting more than one copy of the exchange database, then configure one exchange database for full backup and the others for copy backup.

    But remember that there can be only one single backup job running against a given database.

    So you can't have fullbackup and copy backup at the same time => 8:00 PM. Besides if your backup job overlap you will get an error event id 9840 “backup failed because the database is already in the process of being backed up”.

    Could you verify your settings for Copy backup job ?

    Stephane


    Please remember to click “Mark as Answer” on the post that helps you. This posting is provided "AS IS" with no warranties. knowledge is valid only if it is shared by All.

    My DPM blog Yet Another DPM Blog

    Friday, November 2, 2012 11:21 AM
  • James_USPS,

    DPM schedules and runs jobs in the protected servers time zone, so if the DPM Server is west coast (GMT-8) and the exchange server is on the east coast (GMT-5) then when you schedule a backup at 8:00pm protected servers time that is really 5:00pm local time.

    For more information on time zones see http://technet.microsoft.com/en-us/library/bb808946.aspx

    FYI - DPM records the time zone information for a protected server (and the DPM Server) at the time of installation of the agent, and once recorded it is never updated, so if you installed an agent when the server time zone setting was GMT-5, and you change it later to GMT-8, DPM will still schedule jobs using GMT-5 time zone.  Only way around that would be to stop protection uninstall the agent using DPM console, then re-install the agent and the new time zone will be recorded and used for future backup jobs..


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.


    Wednesday, November 7, 2012 11:35 PM
    Moderator
  • Mike,

    I don't see how thats possible. There is only a 2 hour difference in the time zones for one site to the other and the backups that are not running when speciffied are off by 3 hours. Also, I have this configuration on other DPM servers and everything runs as scheduled. I don't think time zone adjustments are the answer.

    Any other ideas?

    James

    Tuesday, November 27, 2012 2:20 PM
  • Hi,

    You can run this SQL script to see what time zones DPM is using when scheduling backup jobs.  Open SQL management studio using administrative privileges and connect to the DPM instance, then run the below script and see what time zone the DPM server is in and the protected servers.

    Use DPMDB
    select svr.ServerName, svr.serverid, tz.Description, tz.DaylightName,tz.StandardName, tz.DaylightBias from tbl_AM_ServerTimeZone tz join dbo.tbl_AM_Server svr on tz.ServerId = svr.ServerId



    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    • Marked as answer by James_USPS Monday, December 3, 2012 5:55 PM
    Tuesday, November 27, 2012 4:24 PM
    Moderator
  • Mike,

    OK! I think you are on to something here. Some of the servers I'm having issues with are not set to the correct time zone. Now the question is how do I change them without having to remove a bunch of stuff from protection. A 'TRUCK LOAD' of work went into building the protection groups and I'd rather not have to rework those if possible. I was looking at http://technet.microsoft.com/en-us/library/bb808864.aspx, even though this is DPM2010. Will I be able to uninstall the DPM client from the effected server, then .\Remove-ProductionServer.ps1 without removing the bad client from protection? I suppose I could remove them one at a time and maybe that wouldn't be too hard to work out...

    What are your thoughts?

    Thanks!

    James

    Thursday, November 29, 2012 2:15 PM
  • Hi,

    DPM will not allow you to remove an agent when there are data sources still under active protection, you will need to stop protection first. 

    Try these steps for each effected protected server:

    NOTE: These steps assume a local SQL dpmdb.

    1) Make sure there are no active DPM jobs running.
    2) Stop protection and maintain replica for each data source of a protected server. That will move the data sources to an Inactive Protection group.
    3) Disable the DPM Servers network interface from Control Panel\Network and Internet\Network Connections.
    4) In DPM Console, locate the protected server agent, right-click and choose uninstall.  When it errors out, it will ask if you want to remove the agent from the DB, choose yes.
    5) Re-enable the DPM NIC, then install the agent again using the "attach agent" flow - that will get the current time zone information from the client and update the DPM tables.
    6) Re-protected the data sources and that will bring them out of the inactive protection group.  Run a CC to get them green.  Future jobs will be scheduled correctly based on new time zone settings.
    7) Repeat for each effected protected server.
    8) In the future, make sure servers are configured for their correct time zones before protecting. 


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    • Marked as answer by James_USPS Monday, December 3, 2012 5:55 PM
    Thursday, November 29, 2012 5:56 PM
    Moderator
  • Thanks for you help Mike. With you assistance I was able to get it all worked out.
    Monday, December 3, 2012 5:56 PM