none
Sharepoint 2010 + UAG suddenly not work - Cannot open office document directly RRS feed

  • Question

  • My Sharepoint 2010 system use UAG as authorization.  Users were able to directly left click the office document (word, excel, powerpoint) on sharepoint web interface.  The MS office at client computer will open the document immediately.

    Start from this week, our users reported that when open document at web interface, a password prompt will pop up (it is not the supposing reaction, because the user have logged in via UAG already). Even he key in the correct login+password, he still get password prompt.  

    However, users can right click the document and download them to their desktop, edit the doc and upload it back to Sharepoint.  It is weird.

    On the UAG server, there is application log like follow:

    A request from source IP xxxxxx, user on truck sptrunk; Secure=1 for application Internal Site of type Internet Site failed because the method used PROPFIND is not valid for requested URL xxxxxxxxxxxxxxxxxxxxxx 

    After some tests, we proved that the problem ONLY occur on MS office document.  There is no problem open jpeg or txt.

    Anyone encountered similar issue with me? Any input is appreciate. Thanks!


    • Edited by Mark Lui Friday, September 27, 2013 2:48 AM
    Friday, September 27, 2013 2:01 AM

All replies

  • Recently we have applied following windows patches:

    KB2844286
    KB2840631
    KB2835361
    KB2834886
    KB2833946
    KB2832414

    Friday, September 27, 2013 8:15 AM
  • Hi LG,

    This issue may happen if there is a time difference between the server (UAG) and the client.

    The SSO with SharePoint office is based on persistent cookie that being sent by the server for a very short time. The time is based on the Server's local time, so if the client and the server's time is not in sync, this may cause the browser to delete the cookie too shortly.

    I recommend to double-check the server's time (include timezone changes, like daylight saving, etc) and see if adjust the time at the server (and/or client) fix the issue...

    Ophir.


    ** Edit:

    Just notice the following: "Even he key in the correct login+password, he still get password prompt. " - does the user use "domain\username" or just "username"  when they provide the credentials? If it fail even with "domain\user" it may not be related to the time difference...

    Saturday, September 28, 2013 3:23 PM
    Moderator
  • Thanks for information.

    We have tried login with domain/username or username, both not work.

    Also the time between server and client seems the same.

    Mark

    Monday, September 30, 2013 9:12 AM
  • The problem is solved by upgrade UAG to sp2.  It is the Microsoft patches compatibility issue.
    Friday, October 4, 2013 6:22 AM