• Question

  • We are using excel 2016 or excel 2010 to convert XLS file to XLSX file.

    We've found that the error "Microsoft Office file type blocked by File Block settings in the trust center" pops up suddenly.

    However, we faced below problems.

    1. The checkboxes of "File Block Settings" are disabled. We cannot modify the values to open XLS file and convert to XLSX.

    2. We have tried to modify the registry HKCU\Software\Policies\16.0\excel\fileblock and updated their values to DWORD  = 0,e.g. xl2macros.

    However, we have found that the values will be revoked suddenly during certain of time.

    Can you please kindly advise ? Is there any security patch installed ? How can we disable file block settings in excel 2016 ? 

    • Moved by Chenchen Li Wednesday, September 14, 2016 6:03 AM Not development issue
    Monday, September 12, 2016 9:14 AM


All replies

  • Is the file type you are trying to convert .xlm (not .xls)?

    .xlm and xlsm files contain macros, executable code (VBA) where .xls and .xlsx do not and the security people in MS want to protect you from possible malicious code.

    The files you are converting, do you know their source?

    Best regards, George

    Monday, September 12, 2016 2:36 PM
  • Hi,

    Thanks for posting here.

    This forum(Excel for Developers) is for Developer discussions and questions involving Microsoft Excel, like developing issues related with Excel Object model

    Since your issue is more related to Excel Product, I would move this thread into the following forum, you could receive valuable suggestion or workaround there.


    Thanks for your understanding.



    Wednesday, September 14, 2016 6:02 AM
  • Hi,

    Please contact your AD administrator and confirm if any Group Policy is configured for the File Block Settings in your environment:



    Winnie Liang

    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, September 30, 2016 1:56 PM