locked
Linux Integration Service Version 3.5 installed and it shows "Network Degraded" RRS feed

  • Question

  • In my Windows 2012 R2 , all my Linux virtual machines show "network degraded" in the Hyper-V manager.

    I installed the 3.5 version although the Fedora 20 kernel already comes with some hyper-v modules, looking to get rid of the message. I did not succeed, in fact, I am not shore if my new 3.5 modules are bring used or not.

    I type

    modinfo hv_vmbus
    filename:       /lib/modules/3.13.7-200.fc20.x86_64/kernel/drivers/hv/hv_vmbus.ko
    license:        GPL
    alias:          acpi*:VMBus:*
    alias:          acpi*:VMBUS:*
    depends:
    intree:         Y
    vermagic:       3.13.7-200.fc20.x86_64 SMP mod_unload
    signer:         Fedora kernel signing key
    sig_key:        C3:83:0B:47:32:E7:AE:9D:9E:43:FC:FB:76:F1:35:CC:8F:FF:60:9E
    sig_hashalgo:   sha256

    Can anybody tell me if I am using the latest modules, and if not, how can I make sure they do load?

    Federico


    ff

    Saturday, March 29, 2014 10:56 PM

All replies

  • I found that Fedora 20 uses vmbus version 2.4 and it is impossible to install version 3.5 from the ISO provided, because the kernel number is different.

    The question is, if I compile version 3.5, will it actually work with kernel 3.13.7-200?

    I need as much performance as I can get for a new application


    ff

    Saturday, March 29, 2014 11:37 PM
  • I tried to compile version 3.5 in Fedora 20 and of course, it does not compile.

    However, it should, because the Linux kernel has the hv modules already. Can somebody make it work?

    I need to recommend my employer to use Hyper-V or another virtualization solution, and so far, my love for hyper-v is losing the contest.

    I can open a support incident if necessary. Please somebody from Microsoft respond.


    ff

    Sunday, March 30, 2014 12:10 AM
  • I tried to compile Integration Services on RHEl 6.5, the latest of the 2.6 line, and compilation fails

    ./rhel6-hv-driver-install
    Building Modules
    make: Entering directory `/usr/src/kernels/2.6.32-431.11.2.el6.x86_64'
    make: Leaving directory `/usr/src/kernels/2.6.32-431.11.2.el6.x86_64'
    make: Entering directory `/usr/src/kernels/2.6.32-431.11.2.el6.x86_64'
      CC [M]  /usr/src/LIS3.5/hv-rhel6.x/hv/netvsc_drv.o
      CC [M]  /usr/src/LIS3.5/hv-rhel6.x/hv/netvsc.o
      CC [M]  /usr/src/LIS3.5/hv-rhel6.x/hv/rndis_filter.o
    /usr/src/LIS3.5/hv-rhel6.x/hv/rndis_filter.c: In function ‘rndis_filter_set_device_mac’:
    /usr/src/LIS3.5/hv-rhel6.x/hv/rndis_filter.c:579: error: incompatible type for argument 3 of ‘utf8s_to_utf16s’
    include/linux/nls.h:55: note: expected ‘enum utf16_endian’ but argument is of type ‘wchar_t *’
    /usr/src/LIS3.5/hv-rhel6.x/hv/rndis_filter.c:579: error: too few arguments to function ‘utf8s_to_utf16s’
    /usr/src/LIS3.5/hv-rhel6.x/hv/rndis_filter.c:584: error: incompatible type for argument 3 of ‘utf8s_to_utf16s’
    include/linux/nls.h:55: note: expected ‘enum utf16_endian’ but argument is of type ‘wchar_t *’
    /usr/src/LIS3.5/hv-rhel6.x/hv/rndis_filter.c:584: error: too few arguments to function ‘utf8s_to_utf16s’
    make[1]: *** [/usr/src/LIS3.5/hv-rhel6.x/hv/rndis_filter.o] Error 1
    make: *** [_module_/usr/src/LIS3.5/hv-rhel6.x/hv] Error 2
    make: Leaving directory `/usr/src/kernels/2.6.32-431.11.2.el6.x86_64'
    Installing Modules
    cp: cannot stat `./*.ko': No such file or directory

    Can somebody help?


    ff

    Sunday, March 30, 2014 1:05 AM
  • Nobody answers. Is Hyper-V a dead-end technology?

    ff

    Wednesday, April 2, 2014 1:31 PM
  • Hi Philip, Sorry for the huge delay. I was focusing on some other tasks and therefore could not reply on time. My mistake. Now on to answers.

    You cannot install LIS 3.5 on Linux distributions that come prebuilt with LIS drivers. For a full chart of supported distributions and LIS driver availability, please take a look here: http://technet.microsoft.com/en-us/library/dn531030.aspx

    Next, please feel free to ignore the degraded message. That is a bug in the Hyper-V console and we are working on publishing a KB article to make this information public.

    Furthermore, kernel 3.13 has drivers that are latest and better than LIS 3.5. So you are not going to find anything newer in LIS 3.5 in comparison to kernel 3.13.

    Please let me know if you have further questions and I apologize again for the delay in response.

    Thanks,

    Abhishek

    Thursday, April 3, 2014 12:36 AM
  • You need to change all instances of "utf8s_to_utf16s" in rndis_filter.c to have 5 arguments.You can see how it is being used in other files of your kernel. 

    For example:

            ret = utf8s_to_utf16s(NWADR_STR, NWADR_STRLEN, cfg_nwadr);

    should be changed to

            ret = utf8s_to_utf16s(NWADR_STR, NWADR_STRLEN, UTF16_HOST_ENDIAN, cfg, NWADR_STRLEN);

    Wednesday, May 7, 2014 9:07 PM