ActivCard / ActivClient and (NMCI) CAC Card RRS feed

  • Question

  • I'm going to try to list as much info as I have for my situation.  I've just set up Win7 32-bit on my Macbook Pro and it is working fine.  Updated and running smooth.  I was able to use the files and instructions on http://www.militarycac.com to get my SCR331 to a "usable" state -- that is, ActivCard recognizes the reader and Win7 says it's working properly (i.e. I have the correct driver installed).  Firmware version is reported as 1.40 and (device?) driver version is reported as 1.39.

    I have ActivCard Gold 3.1 installed currently, as that's the version that my IT guy gave me back when I was setting it up on my Thinkpad T60 about 3 years ago.  The T60 can still connect to webmail (https://webmail.xxxx.navy.mil) and read email easily, but I'd like to set up Win7 to work on this laptop so I don't have to keep lugging two laptops with me when I go on the road (I know I should be using Vista, but I'm avoiding Vista and XP OEM discs/keys are $140 now).

    In any event, when I insert my CAC (V5.2 on the back of the card), ActivCard reports it as being inserted in the system tray, but it cannot pull the certificates.  I can copy pasta the error report, but that seems excessive.  ActivCard's Troubleshooting Wizard says "Your card does not comply with any of the known profiles," so on the surface it seems to be an easy fix.

    I'm still getting used to the format of these MS forums, so if I've duplicated someone's issue, I apologize and ask that you just point me to a link that has a potential solution.

    I am away from home right now (Memorial Day family trip) so I have limited access to resources; though obviously anything web-related I can get to -- if it doesn't need a CAC card/certificate.  I can provide any other information you wish to help get this up and working.
    Saturday, May 23, 2009 5:23 PM


All replies

  • Quick update:  Seeing 1-2 other similar threads after Googling, I'm assuming I can download ActivClient 6.1 if I can access https://infosec.navy.mil once I get home.  I would like to avoid paying to get the program from Envoy Data, but I may not have a choice.  Speaking of which, they seem to only ship out the program.  Is it possible to receive the program via download if I talk to a cust. serv. representative?
    Saturday, May 23, 2009 5:41 PM
  • Hello sherretz,  I believe your problem is with the antiquated version of Active Card Gold.  If you are running Windows 7, you will more than likely need the ActiveClient 6.1.  Is the Windows 7 considered 64 bit?  If so, you would need the ActtivClient 6.1 for Vista 64 bit. 

    Thanks for the plug to my site:  http://militarycac.com   Have you looked at the Navy specific page?  http://militarycac.com/Navy.htm  has everything I know about the Navy and CAC use.

    CW3 Michael J. Danberry   http://militarycac.com  Webhelper.

    Michael J. Danberry
    Sunday, June 7, 2009 2:20 AM
  • Actually, it appears that Windows 7 doesn't require that you install ActivClient at all

    I'm using my CAC to reach our Outllook Web Access (OWA) portal on Win 7 RTM x64 without having to install ActivClient.  That functionality is apparently built-in to Win 7 now.
    Tuesday, August 11, 2009 7:56 PM
  • Concur. After I read the last post, I tried it and it worked. Just plugged in SCR331 card reader with CAC inside. Bada Bing. Logged on to webmail.xxxx.ncmi now.
    Running Win 7 RTM x86. Before I read this post I installed Activclient 6.1 on Win 7 RTM x64, that worked also.

    It's slow on both, logging in, but it works.
    Friday, August 14, 2009 2:18 AM
  • And to get to the infosec web site you need to be coming from a .mil address. So unless you have access to a VPN into a .mil domain. No dice getting there. That's true for a majority of .mil web sites. For good reason.
    Friday, August 14, 2009 2:21 AM
  • I can log on to web sites with my cac with or without the activclient 6.1 installed.  But I am unable to digitally sign documents with IBM Lotus Viewer.  I get the following error:
    "The specified CSP doesn't contain any unexpired digitial signature certificates for the matching your certificate filter (see Advanced Preferences)."
    Any ideas?
    • Edited by av8rdude Monday, September 28, 2009 1:38 PM edit
    Monday, September 28, 2009 1:35 PM
  • Hello av8rdude,

      What version of ApproveIt do you have installed?  I know when I was trying ot test IBM Lotus Viewer, I was getting the same error.  Army IT folks have been directed to uninstall Lotus Viewer and install Pure Edge, then Approve It.  Now we can site again.  I guess there is no ApproveIt version out yet that works with Lotus Viewer.

      There is some information regarding your error at:  https://militarycac.com/errors2.htm#specified_CSP  If none of these work, please look at:  https://militarycac.com/pureedge.htm  followed by https://militarycac.com/approveit.htm 

    CW3 Michael J. Danberry 612-328-8768 https://militarycac.com
    Monday, October 12, 2009 7:07 PM
  • You dont need CAC Card Software to use NMCI Webmail on Windows 7. All you have to do is follow the steps at the website below. I am using Windows 7 Ultimate and my NMCI Webmail works fine.

    Try this tutorial I found on the Internet.

    link > http://nerdynerdnerdz.com/?p=103
    Saturday, February 27, 2010 12:12 AM
  • I am using the most up to date version of Activeclient from AKO, ApproveIt 5.8.3, and this problem is only affecting specific forms, not all of them. An unsigned Acceptable Use policy we can sign fine, but an OER we get this error.  I've tried the advanced settings from Militarycac.com that was suggested as a fix and still no luck.  Any ideas?
    Monday, January 3, 2011 9:42 PM
  • @Net_Knight,  You are correct that Windows 7 doesn't need ActivClient.  This is however only if the cardholder has 1 of 2 specific CACs.  Read more at:  http://militarycac.com/noactivclientwindows7.htm 

    @Solego, There are some forms that if signed out of order, the word Sign will stay gray.  Or in your case give you other problems.  It is more than likely the specific form since you can sign other forms.

    CW3 Michael J. Danberry 703-679-8989 (Google voice) / 612-328-8768 (Sprint) https://militarycac.com
    Sunday, May 1, 2011 12:08 PM
  • Sir! Thanks for Military CAC - I am using x86 Windows 7 (I know, I know, blame my employer it's their laptop) and the built-in PIV 800-73 driver Works Great with my Oberthur ID One 128 v5.5 Dual card. (Also kewl to see that NIST SP 800-73 "Interfaces for Personal Identity Verification" is driving this bus -- I don't know any of the listed authors from Part 1 but I'm a big NIST fan.)

    However - I use AKO Webmail with S/MIME -- you guessed it, problems abound! When I am trying to sign an email, I have no certificate listed in the pulldown after clicking on the Security tab (the certificate pulldown is disabled, in fact). The certificate comes from the smartcard; apparently the S/MIME control doesn't work with the built-in Windows 7 drivers.

    So...I want to use the ActivClient drivers. I disabled the Windows PIV driver and reinstalled the ActivClient No dice - ActivClient recognizes that a card is inserted but cannot read it with error: "Your card does not comply with any of the known profiles" for the ATR "3b db 96 00 80 1f 03 00 31 c0 64 b0 f3 10 00 07 90 00 80". Looks like an upgrade to ActivClient would be in order, eh? Or, I just can't use this machine to send encrypted emails via AKO. That would suck...

    Any ideas?

    Andrew Bruce

    Wednesday, August 3, 2011 10:40 PM
  • Oops, I did a bit of searching and had the brainwave to look for an updated ActivClient, which led me back to militarycac.com, where I finally read the Oberthur note and the link you have for the hotfix. Works like a charm, you are The Man! Thank you thank you thank you...
    Wednesday, August 3, 2011 10:51 PM
  • Chief Danberry,

    I've been trying to install my cac reader so i can acces my iPERMS on my AKO but I kind of got stucked in the lotus part because when I try to access my CAC y shows a windows saying Insert a SmartCard and it's already insert. What can I do to fix it?

    Wednesday, February 22, 2012 3:13 PM
  • @Jose, Sorry, I haven't been in this forum for awhile.  I would like you to visit:  http://militarycac.com/questions.htm  and fill out the webform, that way I can assist you much better.

    CW3 Michael J. Danberry 703-679-8989 (Google voice) https://militarycac.com

    Saturday, March 10, 2012 2:49 AM
  • I'm having the same sort of issue except I just recently got a new CAC and my old one worked perfectly on my computer. But now with my new CAC i get the error "Your card does not comply with any of the known profiles". I've tried numerous different things to try and resolve this. Everything is up to date and I have all the proper drivers. If anyone can help me please.
    Tuesday, November 6, 2012 8:32 PM
  • @Jose,  If you only need access to iPerms, you don't need to worry about Lotus Forms and ApproveIt.   To fix your insert a Smart Card issue, please follow this guide:  https://tiny.army.mil/r/0Owo

    CW3 Michael J. Danberry 703-679-8989 (Google voice) / 612-328-8768 (Sprint) https://militarycac.com

    Monday, December 17, 2012 3:37 AM