locked
Office 365 & Exchange 2013 - Shared Calendar using Public Folders RRS feed

  • Question

  • Hi There,

    I have started migration to Office 365, and it will be a hybrid set up with some users in the 365 and some on-premise (Exchange 2013 CU7).

    We currently use Shared Calendars, but I have found that you can't share permissions from the either side..

    So I had a thought to use a Public Folder and its capability to do Calendars.

    Unfortunately I am not sure on how to set it up, I have followed several web sites suggestions, but none have worked..

    I am flexible as to where I can create the Public Folder Mailbox, on either Office 365 or on-premise, but, so far, either way has only shown the public folders on the users that are in the same area.

    Is this even possible and if so, how can I get it working?

    Thanks,

    -Tim

    Thursday, November 5, 2015 9:17 AM

Answers

  • Unfortunately the whole company uses a single calendar to track staff movements, and also for some meeting rooms..
    And all or nothing for Public Folders is fine, we don't currently have any..

    Ironically I managed to get the thing working (I think, just need to fully double check)

    I created a Public Folder Mailbox on-premise, and then a public folder.

    I gave myself owner permissions to the folder.

    I then synced the public folder mailbox to office 365 like all the other users (not migrated)

    I could then successfully run on the MSOL powershell connection: 

    Set-OrganizationConfig -PublicFoldersEnabled Remote -RemotePublicFolderMailboxes PFMailbox1

    Many hours later the folders appeared in my outlook.

    Unlike in the link you provided, I didn't need to create a separate database, just created it using the on-premise Public Folders. Also the scripts do not work in Exchange 2013, the only useful step is the last one.

    I have a system running Exchange 2013 so the 2007 Public Folders is not an option, but I do know they brought back public folder from CU7 of Exchange 2013..

    From my original post above, it turned out I needed to sync the mailbox across like all the other mailboxes, this then allowed the set-organizationconfig to find the public folders.

    Thanks anyway :)

    -Tim

    • Marked as answer by Timjeens Friday, November 6, 2015 9:17 AM
    Friday, November 6, 2015 9:17 AM

All replies

  • The best answer is to migrate workgroups together.  Shared public folder calendars don't work very well.

    Migrating public folders is all or nothing.  During coexistence, when mailboxes are both on premises and in Office 365, everyone uses on-premises Exchange 2007 public folders.

    https://technet.microsoft.com/en-us/library/dn249373%28v=exchg.150%29.aspx?f=255&MSPPError=-2147217396


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    Thursday, November 5, 2015 4:54 PM
    Moderator
  • Unfortunately the whole company uses a single calendar to track staff movements, and also for some meeting rooms..
    And all or nothing for Public Folders is fine, we don't currently have any..

    Ironically I managed to get the thing working (I think, just need to fully double check)

    I created a Public Folder Mailbox on-premise, and then a public folder.

    I gave myself owner permissions to the folder.

    I then synced the public folder mailbox to office 365 like all the other users (not migrated)

    I could then successfully run on the MSOL powershell connection: 

    Set-OrganizationConfig -PublicFoldersEnabled Remote -RemotePublicFolderMailboxes PFMailbox1

    Many hours later the folders appeared in my outlook.

    Unlike in the link you provided, I didn't need to create a separate database, just created it using the on-premise Public Folders. Also the scripts do not work in Exchange 2013, the only useful step is the last one.

    I have a system running Exchange 2013 so the 2007 Public Folders is not an option, but I do know they brought back public folder from CU7 of Exchange 2013..

    From my original post above, it turned out I needed to sync the mailbox across like all the other mailboxes, this then allowed the set-organizationconfig to find the public folders.

    Thanks anyway :)

    -Tim

    • Marked as answer by Timjeens Friday, November 6, 2015 9:17 AM
    Friday, November 6, 2015 9:17 AM