locked
ERR9999 after VMM SSP 2.0 installation RRS feed

  • Question

  • Hi,

    We have a Hyper-V CSV cluster running with 2 nodes and a SAN.
    The nodes run Server 2008 R2 Enterprise, the SAN is running Storage Server 2008.
    A separate physical server (2008 R2) is used for VMM 2008 R2. This box also runs SQL Server 2008 SP1 for the VMM database. (this used to be SQL 2005 Express, but it's upgraded to SQL 2008 SP1).

    Everybody is happy in the above situation.

    Now, VMM SSP 2.0 is here, so we installed a new physical server (also 2008 R2), installed SQL 2008 Enterprise SP1 (default instance), installed VMM Administrator Console (tested and works), and IIS (according to the deployment guide, single-machine deployment).

    After installation, I browse to the self-service portal (which is basically http://servername).
    The browser remains blank for about 30 seconds, until "website found" appears in the statusbar.
    After 10 more seconds, the site pops-up, with:

    ERR9999 Unknown Error. Please send this message to the database administrator.

    Any ideas? SQL works fine, I can browse in the database with the Management Studio, etc.
    Thank you!
    Mp

    Wednesday, November 10, 2010 7:41 PM

Answers

  • Hi,

    VMMSSP2.0 also supports SQL instance other than default Mssqlserver. 

     

    Scenario: Let’s say you have "SSP" SQL instance listening on port 1450 & default "Mssqlserver" Instance is listening on port 1433. Both instances are on same SQL Server machine "A" & You would like to install VMMSSP2.0 on "SSP" instance.

     

    Steps: During installation -on page "Connect VMMSSP Server and Website to Database Server”, you need to set

    ·          Database Server =A\SSP

    ·          SQL Server Instance =SSP

    ·          Port=1450

     

    Thanks,

     

    • Marked as answer by Yogesh C Monday, November 29, 2010 6:41 PM
    Monday, November 29, 2010 6:41 PM

All replies

  • Hi Mp,

    Can you check running status for "MSSQLServer"Service on you DB machine ? If it is stopped, Can you please start same and try again?

    Let me know if it works.

    Thanks,

    Wednesday, November 10, 2010 9:27 PM
  • Hi Yogesh,

    Thanks for the quick reply.
    Which DB machine do you mean? To make things more clear: here's the server set-up.

    Server1: VMM 2008 R2 Server
    Servername: VMM.domain.local
    Server 2008 R2 Ent, SQL 2008 Express (using MICROSOFT$VMM$ instance from default VMM installation settings)

    Server2: SSP 2.0 Server (new)
    Servername: SSP.domain.local
    Server 2008 R2 Ent, SQL 2008 Enterprise SP1 (using MSSQLSERVER default instance)
    This server contains the DITSC database, which is visible with the Management Studio

    SO, if you mean the SSP server as the "DB machine", than yes: it's running. And yes: we've restarted the server more than once. :)
    If you mean the VMM server, than no, because there's only a named instance on this server. (which hasn't been rebooted btw).

    Thanks.
    Mp.

    Wednesday, November 10, 2010 10:01 PM
  • Yes, I mean to say "SSP.domain.local" machine as DB (SQL Server ) machine.

    Please go to SSP.Domain.Local machine -> Run Services.MSC -> Locate MSSQLServer Service -> Check running status of this MSSQLServer Service -> If it is stopped the start same and try to open VMMSSP2 portal again.

    Let me know if you still face an issue in viewing portal.

    Thanks,

    Wednesday, November 10, 2010 10:33 PM
  • All services are started. I can also browse to http://ssp/reportserver where I can see an empty reportserver website.

    Seems like nobody has these problems after installing SSP 2.0...

    Saturday, November 13, 2010 8:12 PM
  • Hi MP,

    (1) Can you please share ConnectionString available in web.config file located at  < VMMsSP2.0 Installed Location>\Portal directory?

     

     <ConnectionStrings>

        <add name="MicrosoftDDTKConnectionString" connectionString="Data source=po-anddemo-hvh1, 1433; Integrated Security=true; Initial Catalog=DITSC" providerName="System.Data.SqlClient"/>

      </connectionStrings>

     

    (2) Is your SQL Server listening to a port other than 1433?   

     

     Thanks,

     

    Monday, November 15, 2010 10:32 PM
  • Hi all,

    in my case, after removing port from connection string it works fine:

     <add name="MicrosoftDDTKConnectionString" connectionString="Data source=po-anddemo-hvh1; Integrated Security=true; Initial Catalog=DITSC"

    Best Regards

    Heinz

     

    Tuesday, November 16, 2010 12:48 PM
  • Hi heinz,

    It looks like your SQL Server is configured to listen to dynamic port. By default- during SSP2.0 installation, Default port 1433 is shown to user. but if SQL server is listening to dynamic port then you need to remove 1433( i.e keep it blank).

    Let me know if you need anything.

    Thanks,

     

    Tuesday, November 16, 2010 7:18 PM
  • Dear all:

                 I`m from china. Sorry, but I met with the same question! My reference

    Microsoft System Center Virtual Machine Manager Self‑Service Portal 2.0

    Deployment Guide Step by step and operation

    Database version: sql server 2008 r2

    os:server 2008 r2

    vmm:scvmm r2

    In the process of installation, the SSP servcie components can be confess to database instance, and successfully created DITSC database

     But after completing the installation, service cannot be started,the service:self-service-portal,After the check system logs,find ERROR 9999 description:

    With SQL Server connection is established with the network occurs when the related or specific from examples of mistakes. Not found or unable to access servers. Please verify whether correctly and examples name already SQL Server configured to allow remote connection. (provider: TCP provides program, as freely: 0 - since the target computer actively refused, unable to connect.

    The service after the manual, less than a minute, service and stop it.What should I do?Help me

    Thank you!

    Tuesday, November 23, 2010 9:03 AM
  • Hi Wt,

    Is your SQL Server Service( MSSQLServer) running ? If not, Can you please start this service & then start "Virtual Machine Manager Self-Service portal 2.0 " service.

    Let me know result

    Thanks,

     

    Wednesday, November 24, 2010 1:14 AM
  • Thanks

    SQL Server Service is the start,Manual after startup "Virtual Machine Manager Self-Service portal 2.0 "services, oneself again stopped.

     

     

    Pray for me! Tomorrow night will know the results!

    Wednesday, November 24, 2010 2:11 PM
  • Hi,

    During installation, do you use administrator account on application pool identity? If not, then you will receive the above error message. To solve this, try go to IIS Manager > Application Pool > VMMSSPAppPool > Right Click and Select Advanced Settings. In Process Model - Identity, change to domain\administrator account. Once complete, right click the application pool and recycle.

    Try to browse the VMM SSP web site.

     


    laiys
    Friday, November 26, 2010 9:06 AM
  • Sorry, so long time to reply.I install a success, also know the reason.As follows:

    1、Before installation database, create a new database instance, no choice default database instance.eg:ssp

    2、It to the client installation,I chose the default database instance MSSQLSERVER.

    3、After installation is finished,open the IE https://sspserver( VMM SSP web site)

    4、Can normal landing,So suggest that people in installation database, keep default examples.

    This BBS why not sent the screenshot? What a pity!

    Monday, November 29, 2010 9:48 AM
  • Hi,

    VMMSSP2.0 also supports SQL instance other than default Mssqlserver. 

     

    Scenario: Let’s say you have "SSP" SQL instance listening on port 1450 & default "Mssqlserver" Instance is listening on port 1433. Both instances are on same SQL Server machine "A" & You would like to install VMMSSP2.0 on "SSP" instance.

     

    Steps: During installation -on page "Connect VMMSSP Server and Website to Database Server”, you need to set

    ·          Database Server =A\SSP

    ·          SQL Server Instance =SSP

    ·          Port=1450

     

    Thanks,

     

    • Marked as answer by Yogesh C Monday, November 29, 2010 6:41 PM
    Monday, November 29, 2010 6:41 PM
  • Removing the port number also worked for me. I would try this first if you are having problems.
    Wednesday, May 11, 2011 12:10 PM