locked
Exchange 2007 with logs and space problems RRS feed

  • Question

  • Hello,

    I have inherited an exchange 2007 server that is running the Hub Transport, Client Access, and mailbox roles on it. A couple concerns I have after digging around on the server is that the transaction logs are a shade over 300GB which is taking up most of the 500GB that is on the server. I noticed that LCR has been disabled, so I tried to resume that and it automatically fails saying  its missing a log file. So I then tried to reseed the database to get LCR working again, problem with that is the seed errors out with insufficient disc space. There is only 27GB left on the server and it is burning around 1GB a day. I can complete backups of exchange but it will not purge any of the logs. 

    I am completely out of ideas and need some help. 

    Thank you. 

    Wednesday, August 8, 2012 2:54 PM

Answers

  • Hi,

    Please verify if you have manually delete any files in the LCR storage group and database folders after you disaled LCR.

    How to Disable Local Continuous Replication

    http://technet.microsoft.com/en-us/library/fdbffbbd-65b0-4ae9-9bd6-b121042c7763.aspx

    After that, please try to make full backup again.

    Note: please make sure you backup Exchange information store, not the mailbox folder or the edb file.


    Xiu Zhang

    TechNet Community Support

    • Marked as answer by BarTarantula13 Wednesday, August 15, 2012 1:31 PM
    Thursday, August 9, 2012 7:08 AM
  • Thank you Xiu,

    Turning off LCR and running a complete backup truncated the transaction logs and then cleared them. I know have space to breath again. 

    • Marked as answer by BarTarantula13 Wednesday, August 15, 2012 1:31 PM
    Wednesday, August 15, 2012 1:31 PM

All replies

  • I haven't done much with LCR, but can you disable it entirely, and re-enable it once you've done something to remove the logs?

    "something" could be enable circular logging, or take a full backup.



    Mike Crowley | MVP
    My Blog -- Planet Technologies

    Wednesday, August 8, 2012 5:10 PM
  • thanks Mike for responding

    LCR is not working as it should in the first. those logs are only 80MB so disabling wont do much, unless there is something that happens when LCR is disabled that would let me clear the transaction logs. 

    I have taken at least 3 full backups each time it will pass a physical consistency check and "all files are validated and no errors are detected."  but when the backup completes it says "no log files can be truncated" and no logs are removed. 

    so the whole backup plan wont work 

    Wednesday, August 8, 2012 5:30 PM
  • Hi,

    Please verify if you have manually delete any files in the LCR storage group and database folders after you disaled LCR.

    How to Disable Local Continuous Replication

    http://technet.microsoft.com/en-us/library/fdbffbbd-65b0-4ae9-9bd6-b121042c7763.aspx

    After that, please try to make full backup again.

    Note: please make sure you backup Exchange information store, not the mailbox folder or the edb file.


    Xiu Zhang

    TechNet Community Support

    • Marked as answer by BarTarantula13 Wednesday, August 15, 2012 1:31 PM
    Thursday, August 9, 2012 7:08 AM
  • Hello Xiu,

    When I disable LCR it gives me the single warning box but inside there are two warnings. one is to manually delete log files and database files, which I'm ok with since there is no EDB file and the logs were only 80MB.

    But the second warning tells me to delete the TransactionLogFiles. that is the 300GB file i am trying to eliminate. wont deleting those cause a major problem with the database? 

    Thursday, August 9, 2012 1:05 PM
  • Thank you Xiu,

    Turning off LCR and running a complete backup truncated the transaction logs and then cleared them. I know have space to breath again. 

    • Marked as answer by BarTarantula13 Wednesday, August 15, 2012 1:31 PM
    Wednesday, August 15, 2012 1:31 PM