locked
Word 2010 PDF Does Not Enable URI Links RRS feed

  • Question

  • I use Word 2010 64-bit on Windows 7 64-bit.  When I save a document as a PDF with embedded links to websites, the URI information is displayed when I hover over a link, but I cannot click the link to open a browser window.  When I convert using an online conversion website, I get a PDF document that enables the links to be clicked.  (I also have Acrobat Professional and can't convert.)

    This has to be a Word problem if an online website can convert it properly.


    Seth Thomas
    Monday, April 25, 2011 3:08 PM

Answers

  • Here's the solution:

    The reason I was having a problem is that the default PDF format is PDF/A which is the ISO compliant PDF.  Click Options button when the Save As window opens and uncheck that option.  Then the links are created correctly.  Appears that once you uncheck that option it remains unchecked for all future pdf conversions.


    Seth Thomas
    • Marked as answer by Seth40 Friday, May 13, 2011 3:31 PM
    Friday, May 13, 2011 3:29 PM

All replies

  • There is no problem here with Word 2010 32 Bit.

    Note that as Microsoft themselves do not recommend using the 64 bit version of Office unless it is really necessary for very complex Excel spreadsheets, if you have the option of uninstalling the 64 bit version and installing the 32 bit version, that is probably the best thing to do.


    Hope this helps.

    Doug Robbins - Word MVP,
    dkr[atsymbol]mvps[dot]org
    Posted via the Community Bridge

    "Seth40" wrote in message news:32dc81e4-d8f4-47fd-b02c-22e340d5340b@communitybridge.codeplex.com...

    I use Word 2010 64-bit on Windows 7 64-bit.  When I save a document as a PDF with embedded links to websites, the URI information is displayed when I hover over a link, but I cannot click the link to open a browser window. When I convert using an online conversion website, I get a PDF document that enables the links to be clicked.  (I also have Acrobat Professional and can't convert.)

    This has to be a Word problem if an online website can convert it properly.


    Seth Thomas


    Doug Robbins - Word MVP dkr[atsymbol]mvps[dot]org
    • Marked as answer by William Zhou CHN Monday, May 2, 2011 9:03 AM
    • Unmarked as answer by Seth40 Friday, May 13, 2011 3:30 PM
    Monday, April 25, 2011 11:52 PM
  • Doug,

    I use Word 2010 32-bit on my notebook and agree that the PDF is created correctly with the URL link.  However, if this is a problem others are experiencing with the 64-bit version, then Microsoft needs to fix this bug.  Certainly not worthwhile for me to go through the effort of uninstalling the 64 bit version just because of this one bug, especially because of all of the customization I have already done with a number of the Office applications.


    Seth Thomas
    Tuesday, April 26, 2011 12:44 AM
  • Mine has same problem as Seth Thomas but on Excel 2007 SP2 32-bit.

    When I save an Excel 2007 document as a PDF with embedded links to another PDF document or website, the URI information is displayed when I hover over a link, but I cannot click the link to open a browser window. It actually has the letters URI that preceeds the URL of the document/website. 

    Wednesday, May 4, 2011 6:10 PM
  • Here's the solution:

    The reason I was having a problem is that the default PDF format is PDF/A which is the ISO compliant PDF.  Click Options button when the Save As window opens and uncheck that option.  Then the links are created correctly.  Appears that once you uncheck that option it remains unchecked for all future pdf conversions.


    Seth Thomas
    • Marked as answer by Seth40 Friday, May 13, 2011 3:31 PM
    Friday, May 13, 2011 3:29 PM
  • Based on my recent experience getting hyperlinks to work with Word-generated pdfs, I'll add something to Seth's solution:

    When you select pdf file type in the "Save As" window, the "Optimize for" option has to be set to "Minimize size (publishing online)" for hyperlinks to work in the pdf file.

    Thursday, February 23, 2012 4:02 PM